Wampserver 3.1.4 as a production server not working
Posted by: EndlessEncounters (160.32.217.---)
Date: October 17, 2018 02:08PM

I have been using now Wampserver for over 10 years. Recently I decided to do an upgrade from 2.5 to 3 but unfortunately it's just not working out for me.

I have tried several online tutorials and I have even tried several tutorials on here going through threads but none seem to work so far. I never had such a problem with earlier versions of Wamp but Wampserver 3 I just can't for the life of me seem to get the website showing on the web.

Any help would be appreciated! Thanks!

Registered: 11/21/2007 04:17AM



Edited 1 time(s). Last edit at 10/23/2018 09:50PM by EndlessEncounters.

Options: ReplyQuote
Re: WampServer 3.0.0 as a production server not working
Posted by: Otomatic (Moderator)
Date: October 17, 2018 06:20PM

Hi,

It would still be necessary to understand what you would like to do.
So, start with READ (and answer) BEFORE YOU ASK A QUESTION

Then explain exactly what your problem is.

And, thirdly, I would like to say that Wampserver is designed to be a development server and that if some people want to make it a production server, it is in full knowledge of the facts, i.e. it is not Wampserver that must replace the skills required to do so, especially if the person who wants to make it a production server does not use a Windows Server version and a DNS server.

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.4 32 bit - Apache 2.4.37 - PHP 7.2.11/7.1.23/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.10
Wampserver 3.1.4 64 bit - Apache 2.4.37 - PHP 7.2.11/7.1.23/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.10
PhPMyadmin 4.8.3 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: WampServer 3.0.0 as a production server not working
Posted by: EndlessEncounters (160.32.217.---)
Date: October 17, 2018 10:13PM

- Windows 10 64 bit
- WampServer Version 3.1.4 64 bit
- Apache Version 2.4.35
- PHP Version 7.2.11
- MySQL Version 5.7.23
- MariaDB 10.3.10
- WampServer icon is Green and Online





- In my file system c:\Windows\System32\drivers\hosts.
(nothing has been changed from default as i will be using this for ONLY production.




- Do you have access to localhost (Homepage WampServer)? (YES)
- No error message at the bottom of the page!

- Do you have access to phpMyAdmin? (YES)

- Both ports 80,443 are properly forwarded to the right computer.
- Firewall (Nod32) allowing all traffic to and from Wampserver
- WampServer (c:\wamp64\)

- Virtual Hosts defined, below



# Virtual Hosts
#
<VirtualHost *:80>
ServerName localhost
ServerAlias localhost
DocumentRoot "${INSTALL_DIR}/www"
<Directory "${INSTALL_DIR}/www/">
Options +Indexes +Includes +FollowSymLinks +MultiViews
AllowOverride All
Require local
</Directory>
</VirtualHost>


#
<VirtualHost *:80>
ServerName canadacommunity.org
DocumentRoot "c:/wamp64/www/canadacommunity"
<Directory "c:/wamp64/www/canadacommunity/">
Options +Indexes +Includes +FollowSymLinks +MultiViews
AllowOverride All
Require all granted
</Directory>
</VirtualHost>



http: // canadacommunity.org /
Im trying to access my site from a static Ip (NOT WORKING)

Registered: 11/21/2007 04:17AM



Edited 3 time(s). Last edit at 10/17/2018 10:19PM by EndlessEncounters.

Options: ReplyQuote
Re: WampServer 3.0.0 as a production server not working
Posted by: EndlessEncounters (160.32.217.---)
Date: October 17, 2018 10:57PM

For now until someone responds here in this thread, I will continue to run 2.5 as it works online as a production server.

Registered: 11/21/2007 04:17AM

Options: ReplyQuote
Re: WampServer 3.0.0 as a production server not working
Posted by: Otomatic (Moderator)
Date: October 18, 2018 09:16AM

Hi,

If your hosts file is empty, it means that your VirtualHost is not well defined because you did not activate the DNS server.

Have you read The need for Virtual Host

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.4 32 bit - Apache 2.4.37 - PHP 7.2.11/7.1.23/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.10
Wampserver 3.1.4 64 bit - Apache 2.4.37 - PHP 7.2.11/7.1.23/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.10
PhPMyadmin 4.8.3 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: WampServer 3.0.0 as a production server not working
Posted by: EndlessEncounters (160.32.217.---)
Date: October 18, 2018 09:57PM

Hi, yes my hosts file was one of the first things done DNS was restarted right after. Any other methods to get this site online?

Registered: 11/21/2007 04:17AM



Edited 1 time(s). Last edit at 10/18/2018 10:06PM by EndlessEncounters.

Options: ReplyQuote
Re: WampServer 3.0.0 as a production server not working
Posted by: Otomatic (Moderator)
Date: October 18, 2018 10:22PM

Hi,

If your hosts file is empty you don't have a DNS.

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.4 32 bit - Apache 2.4.37 - PHP 7.2.11/7.1.23/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.10
Wampserver 3.1.4 64 bit - Apache 2.4.37 - PHP 7.2.11/7.1.23/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.10
PhPMyadmin 4.8.3 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: WampServer 3.0.0 as a production server not working
Posted by: EndlessEncounters (160.32.217.---)
Date: October 20, 2018 09:45AM

Otomatic,yes my hosts file is there, what is the final step to put wampserver online. Thanks!

Registered: 11/21/2007 04:17AM

Options: ReplyQuote
Re: WampServer 3.0.0 as a production server not working
Posted by: EndlessEncounters (160.32.217.---)
Date: October 20, 2018 10:11PM

My hosts file has the information, what is the next step to get this online.

Registered: 11/21/2007 04:17AM

Options: ReplyQuote
Re: WampServer 3.0.0 as a production server not working
Posted by: Otomatic (Moderator)
Date: October 21, 2018 10:48AM

Hi,

With "Require all granted" there is authorization for access from the outside.
You should also check with your firewall to see if external connections are allowed and with your router to possibly perform port forwarding.

But "canadacommunity.org" as a ServerName will be a problem, since this site already exists on the Internet.

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.4 32 bit - Apache 2.4.37 - PHP 7.2.11/7.1.23/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.10
Wampserver 3.1.4 64 bit - Apache 2.4.37 - PHP 7.2.11/7.1.23/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.10
PhPMyadmin 4.8.3 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: WampServer 3.0.0 as a production server not working
Posted by: EndlessEncounters (160.32.217.---)
Date: October 21, 2018 08:22PM

Otomatic Hi

Yes i have Require all granted in virtual hosts for the servername

Actually canadacommunity.org I own and iright now ts running off wamp 2.5 live and i want to get running with wamp 3

Thanks

Registered: 11/21/2007 04:17AM

Options: ReplyQuote
Re: WampServer 3.0.0 as a production server not working
Posted by: Otomatic (Moderator)
Date: October 22, 2018 12:45PM

Hi,

External access should work by typing, in the browser address bar:
'http://ip-wan/canadacommunity.org/

ip-wan being the internet IP address of the PC on which your site is hosted.
This cannot be done from the same PC on which the site is hosted.

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.4 32 bit - Apache 2.4.37 - PHP 7.2.11/7.1.23/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.10
Wampserver 3.1.4 64 bit - Apache 2.4.37 - PHP 7.2.11/7.1.23/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.10
PhPMyadmin 4.8.3 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: WampServer 3.0.0 as a production server not working
Posted by: EndlessEncounters (160.32.217.---)
Date: October 23, 2018 09:40PM

Otomatic Hi

I am desperately wanting to put this online with wampserver 3 so far no luck.

Registered: 11/21/2007 04:17AM

Options: ReplyQuote
Re: Wampserver 3.1.4 as a production server not working
Posted by: EndlessEncounters (160.32.217.---)
Date: October 24, 2018 11:07AM

I think at this point I have tried everything, im open and willing to activate teamviewer or anydesk, and allow someone to play around with wamopserver 3 to get me online,

Thanks!

Registered: 11/21/2007 04:17AM

Options: ReplyQuote
Re: Wampserver 3.1.4 as a production server not working
Posted by: RiggsFolly (Moderator)
Date: October 24, 2018 04:24PM

Hi,

I dont think Oto provides remote fixing, but I have in the past.

I am rather busy right now, but I could possibly have a look with TeamViewer at some point in the next couple of days, otherwise it will have to be next week.

I am in the UK so I am on UTC+1. If you can find a time during my evenings I may be available.

If this sounds ok, give me a couple of times when you can also be available and we will see if we cannot get together.

Once we have arranged a time, you can send me a "Private Message" (see menu above) and send me your TeamViewer ID and Password.

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.1.3 32bit & 64bit)
<Apache 2.4.29/2.2.31> <PHP 7.2/7.1/7.0/5.6/5.5/5.4> <MySQL 5.7.19/5.6.39/5.5.28>
<MariaDB 10.2.14> <phpMyAdmin4.8.1> <MySQL Workbench 6.3.10>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-

Options: ReplyQuote
Re: Wampserver 3.1.4 as a production server not working
Posted by: EndlessEncounters (160.32.217.---)
Date: October 24, 2018 09:43PM

RiggsFolly Hi

That is very nice of you! Sure we can always set a time where your free and take it from there.

Registered: 11/21/2007 04:17AM

Options: ReplyQuote
Re: Wampserver 3.1.4 as a production server not working
Posted by: RiggsFolly (Moderator)
Date: November 01, 2018 10:00AM

Ok I have some time today.

Can you send me your TeamViewer ID and Password using a Private Message when you also have some time.

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.1.3 32bit & 64bit)
<Apache 2.4.29/2.2.31> <PHP 7.2/7.1/7.0/5.6/5.5/5.4> <MySQL 5.7.19/5.6.39/5.5.28>
<MariaDB 10.2.14> <phpMyAdmin4.8.1> <MySQL Workbench 6.3.10>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-

Options: ReplyQuote
Re: Wampserver 3.1.4 as a production server not working
Posted by: EndlessEncounters (160.32.217.---)
Date: November 01, 2018 10:55AM

No problem @RiggsFolly, i sent you all the information in PM

Registered: 11/21/2007 04:17AM

Options: ReplyQuote
Re: Wampserver 3.1.4 as a production server not working
Posted by: EndlessEncounters (160.32.217.---)
Date: November 01, 2018 06:56PM

Words cannot express how grateful I am for your help today. You were there for 4 hours. Thank you for everything that you've done to help me. Hopefully someday we will get this figured out!

Registered: 11/21/2007 04:17AM

Options: ReplyQuote
Re: Wampserver 3.1.4 as a production server not working
Posted by: EndlessEncounters (160.32.217.---)
Date: November 02, 2018 03:04AM

Ok UPDATE

I took out the folder php 7.2 out of wam64 version 3.14 and placed into the wamp 2.5 version.
The only thing i had to do was edit the php.ini file replace all links with wamp64 rwith wamp.
The PHP is updated and it seems to be working, just fine.


They say php 5.5 upgraded to 7.2 is 250% overall faster.


Im still waiting to upgrade wamp version 2.5 with 3.14 but i guess for now ill be fine.

Thank You

Registered: 11/21/2007 04:17AM

Options: ReplyQuote


Sorry, only registered users may post in this forum.