Pages: 12Next
Current Page: 1 of 2
Wamp Server 2.2 Windows 7 64-bit and curl not working side-by-side configuration incorrect
Posted by: pioneear (---.zone14.bethere.co.uk)
Date: June 27, 2012 09:57PM

Having problems with php Curl not starting using the following wamp installation:

wampserver2.2e-php5.4.3-httpd2.2.22-mysql5.5.24-x64.exe on Windows 64bit.

OR

wampserver2.2e-php5.4.3-httpd-2.4.2-mysql5.5.24-x64.exe on Windows 64bit.

Getting curl failed to start because the side-by-side configuration incorrect?

Getting the following error in the event log?

Activation context generation failed for “c:\wamp\bin\php\php5.4.3\ext\php_curl.dll”. Dependent Assembly Microsoft.VC90.DebugCRT,processorArchitecture=”amd64″,publicKeyToken=”1fc8b3b9a1e18e3b”,type=”win32″,version=”9.0.21022.8″ could not be found. Please use sxstrace.exe for detailed diagnosis.

Tried downloading the following:

[www.mediafire.com]

Replaced the old php_curl.dll with the new one in \wamp\bin\php\php5.4.3\ext\

And, tried running Apache again.

Apache runs but then when checking if Curl is actually running in php info Curl is NOT listed as switched on.

[pioneear.wordpress.com]



Edited 2 time(s). Last edit at 06/27/2012 10:03PM by pioneear.

Options: ReplyQuote
Re: Wamp Server 2.2 Windows 7 64-bit and curl not working side-by-side configuration incorrect
Posted by: stevenmartin99 (Moderator)
Date: June 27, 2012 11:09PM


Options: ReplyQuote
Re: Wamp Server 2.2 Windows 7 64-bit and curl not working side-by-side configuration incorrect
Posted by: ndmaque (---.steria.co.uk)
Date: June 28, 2012 09:11PM

i have the same issue as above
I have windows 7 64bit so downloaded
wampserver2.2e-php5.3.13-httpd2.2.22-mysql5.5.24-x64.exe


I read many posts, most mention copying 3 files from c:/wamp/bin/php/php5.3.13/ext/ into C:\Windows\system32 or C:\Windows\SysWOW64 folder
php_curl.dll
libeay32.dll
ssleay32.dll


below is a typical post i found but didn't resolve my problem
[stackoverflow.com]



i clicked the php_curl option in the WAMP GUI thing and double checked the php.ini settings
C:\wamp\bin\apache\apache2.2.22\bin\php.ini
it was uncomented as expected like this...
extension=php_curl.dll

But no curl in phpinfo() and get this in my apache error log...
PHP Startup: Unable to load dynamic library 'c:/wamp/bin/php/php5.3.13/ext/php_curl.dll' - The application has failed to start because its side-by-side configuration is incorrect. Please see the application event log or use the command-line sxstrace.exe tool for more detail

i havent figured out how to use sxstrace.exe yet (any help or advice gladly accepted)

PS: I'm not gay it's just we are not allowed Linux at work honest (*|*)

Options: ReplyQuote
Re: Wamp Server 2.2 Windows 7 64-bit and curl not working side-by-side configuration incorrect
Posted by: chytons (41.71.136.---)
Date: July 04, 2012 05:38PM

Go to [www.anindya.com] download *php_curl-5.4.3-VC9-x64.zip* under "Fixed curl extensions:" and replace the php_curl.dll in ext folder. This worked for me.

Options: ReplyQuote
Re: Wamp Server 2.2 Windows 7 64-bit and curl not working side-by-side configuration incorrect
Posted by: n6rej (---.pool.dsl.scrtc.com)
Date: July 07, 2012 04:12AM

Thanks that fixed the curl issues grinning smiley Maybe someone can update the packages cause I JUST dl'd and it has those bugs.

Options: ReplyQuote
Re: Wamp Server 2.2 Windows 7 64-bit and curl not working side-by-side configuration incorrect
Posted by: ndmaque (---.12-2.cable.virginmedia.com)
Date: July 07, 2012 12:47PM

Yay solved (for me)
I removed the 64 bit version and installed the 32 bit version

i ticked the php curl and it worked first time, nothing to configure and no files to download and/or copy from a to b etc

thanks everyone.

Options: ReplyQuote
Re: Wamp Server 2.2 Windows 7 64-bit and curl not working side-by-side configuration incorrect
Posted by: freeed (---.pivot.net)
Date: July 10, 2012 03:18AM

THANK YOU! I had the same issue with curl and using the version from Anindya's site fixed everything, now curl is working. Thanks!

Options: ReplyQuote
Re: Wamp Server 2.2 Windows 7 64-bit and curl not working side-by-side configuration incorrect
Posted by: junkjack (175.143.59.---)
Date: November 25, 2012 10:44AM

chytons Wrote:
-------------------------------------------------------
> Go to
> [www.anindya.com]
> 4-64-bit-for-windows/ download
> *php_curl-5.4.3-VC9-x64.zip* under "Fixed curl
> extensions:" and replace the php_curl.dll in ext
> folder. This worked for me.


it work!! thanks hope wamp fix that issues..

Options: ReplyQuote
Re: Wamp Server 2.2 Windows 7 64-bit and curl not working side-by-side configuration incorrect
Posted by: kwacky1 (---.lns20.bne4.internode.on.net)
Date: December 19, 2012 01:46PM

+1

Thanks for that, php_curl is now working on my Win8 x64 box.

Options: ReplyQuote
Re: Wamp Server 2.2 Windows 7 64-bit and curl not working side-by-side configuration incorrect
Posted by: badjawe (---.38-247-81.adsl-dyn.isp.belgacom.be)
Date: December 31, 2012 04:21PM

I followed every step of this solution, but php still cannot find curl_init() :-(

However, cURL appears enabled when I take a look at phpinfo.

I have the same config : wampserver 2.2 with php 5.4.3 64-bit, apache 2.4.2, and php_curl.dll from anindya in php/ext, sysWOW64 and even system32. libeay32.dll and libssleay32 are in sysWOW64 as well.

EDIT 1/1/2013 :
PROBLEM SOLVED

It appears that my wampserver installation had several instances of php.ini. While wampserver told me that php_curl extension was enabled (ticked in the list), php.ini from php5.4.3/ had still a comment mark ';' in front of the command extension=php_curl.dll

So if nothing seems to work even after you follow every step of the solution mentioned above (big thanks to you, by the way), you should manually look after every instance of php.ini you have, and check that php_curl.dll is REALLY enabled.



Edited 1 time(s). Last edit at 01/01/2013 05:49PM by badjawe.

Options: ReplyQuote
Re: Wamp Server 2.2 Windows 7 64-bit and curl not working side-by-side configuration incorrect
Posted by: bluegr (---.home.otenet.gr)
Date: March 10, 2013 04:43PM

I had the same problem with Wampserver 2.2 (64 bit). Here's what I did to get it working:
1) Go to wampserver->PHP->PHP extensions, enable the php_curl extension
2) Open <wamp server root>\bin\php\php5.3.13\php.ini and uncomment the following line:
extension=php_curl.dll
3) Go to <wamp server root>\bin\php and copy libeay32.dll and ssleay32.dll into your windows\system32 folder
4) If you try and restart wampserver's services, you'll notice that lib_curl still doesn't work. Turns out that the version of php_curl.dll bundled in the pack is not compiled correctly.
Apache's error log contained the following:
<b>Warning</b>: PHP Startup: Unable to load dynamic library 'c:/wamp/bin/php/php5.3.13/ext/php_curl.dll' - The application has failed to start because its side-by-side configuration is incorrect. Please see the application event log or use the command-line sxstrace.exe tool for more detail.
5) You'll need a properly compiled version of php_curl.dll. I downloaded php_curl-5.3.13-VC9-x64.zip from this blog post:
[www.anindya.com]
Direct link:
[www.mediafire.com]
I replaced php_curl.dll inside <wamp server root>\bin\php\php5.3.13\ext with the one above, and everything worked fine smiling smiley
6) To test if the cURL extension is working for you, try this code snippet, obtained from [stackoverflow.com]
<?php
error_reporting(E_ALL);
ini_set('display_errors', '1');
$ch = curl_init();
curl_setopt($ch, CURLOPT_URL,
'http://news.google.com/news?hl=en&topic=t&output=rss');
curl_setopt($ch, CURLOPT_RETURNTRANSFER, 1);
$contents = curl_exec ($ch);
echo $contents;
curl_close ($ch);
?>


Here's another post with similar info (I found this after I wrote these instructions):
[www.o3n.org]

Options: ReplyQuote
Re: Wamp Server 2.2 Windows 7 64-bit and curl not working side-by-side configuration incorrect
Posted by: zdy (27.17.16.---)
Date: March 12, 2013 08:08AM

I win7 64-bit system, open the curl extension failed to use wamp
apache log
<b> Warning </ b>: PHP Startup: Unable to load dynamic library 'd :/ wamp/bin/php/php5.3.13/ext/php_curl.dll' - the application can not be started, not because of the application of the parallel configuration correct. For more information, please refer to the application event log or use the the command line sxstrace.exe tools.

copied to c: \ windows \ system32 folder handling are included in the libeay32.dll, ssleay32.dll have done
The problem persists,
View win7 event viewer Tip
"D: \ wamp \ bin \ php \ php5.3.13 \ ext \ php_curl.dll" Activation context generation failed. Can not find the slave assembly Microsoft.VC90.DebugCRT processorArchitecture = "amd64", PublicKeyToken = "1fc8b3b9a1e18e3b", type = "win32", version = "9.0.21022.8". The use sxstrace.exe detailed diagnosis.

Be found on the website from abroad following solution
Re: Wamp Server 2.2 Windows 7 64-bit and curl not working side-by-side configuration incorrect
Posted by: chytons (41.71.136. ---)
Date: July 04, 2012 05:38 PM

Go to [www.anindya.com] download * php_curl-5.4.3-VC9-x64.zip * under "Fixed curl extensions:" and replace the php_curl.dll in ext folder. This worked for me.
Original

Access [www.anindya.com] find downloadwww.cusabio.com/ELISA_Kit-84594/ il-6 elisa kit </a>
php_curl-5.4.3-VC9-x64.zip link; tragedy, download links wall
Removed Hong Kong server eventually download the file
[205.196.120.154]

Replace the previous php_curl. dll after restart apache, buttoned up

Options: ReplyQuote
Re: Wamp Server 2.2 Windows 7 64-bit and curl not working side-by-side configuration incorrect
Posted by: fionapain (---.pres.cable.virginmedia.com)
Date: March 18, 2013 07:05PM

Thanks Andy that solved my problem 2 only took about 3 hours all told till i came across your solution cheers

Options: ReplyQuote
Re: Wamp Server 2.2 Windows 7 64-bit and curl not working side-by-side configuration incorrect
Posted by: sasho (---.dynamic.sbb.rs)
Date: April 03, 2013 01:41PM

after an hour or so it seems that combination of this posts hopefully worked for me to smiling smiley

Options: ReplyQuote
Re: Wamp Server 2.2 Windows 7 64-bit and curl not working side-by-side configuration incorrect
Posted by: quielsimoes@gmail.com (200.223.93.---)
Date: November 23, 2013 02:13PM

Thanks!

Options: ReplyQuote
Re: Wamp Server 2.2 Windows 7 64-bit and curl not working side-by-side configuration incorrect
Posted by: jasna (---.240.166.122.airtelbroadband.in)
Date: May 02, 2014 09:27AM

Thanks smiling smiley

Go to [www.anindya.com] download *php_curl-5.4.3-VC9-x64.zip* under "Fixed curl extensions:" and replace the php_curl.dll in ext folder. This worked for me.

Options: ReplyQuote
Re: Wamp Server 2.2 Windows 7 64-bit and curl not working side-by-side configuration incorrect
Posted by: hedera (---.lightspeed.sntcca.sbcglobal.net)
Date: May 07, 2014 11:07PM

I was very hopeful when I read the thread as I'm having exactly the same problem - curl shows enabled in the php extensions and is uncommented in php.ini (all 3 of them) but it doesn't show in phpinfo() and it never loads.

I have a Windows 7 Pro 64 bit system running WampServer 2.2E 64 bit with PHP 5.3.13, Apache 2.2.22, mySQL 5.5.64. As long as I'm running the PHP DLL that came with my Wamp install, I get this error:

PHP Warning: PHP Startup: Unable to load dynamic library 'c:/wamp/bin/php/php5.3.13/ext/php_curl.dll' - The application has failed to start because its side-by-side configuration is incorrect. Please see the application event log or use the command-line sxstrace.exe tool for more detail.\r\n in Unknown on line 0

Following the instructions in this thread, I used windows Grep to find and update all 3 versions of php.ini. Didn't help.

I downloaded first the 5.4.3 and then the 5.3.13 fixed curl extension DLLs from www.andiya.com. Neither one works. With both of them, I get this error when I try to run curl:

HP Warning: PHP Startup: Unable to load dynamic library 'c:/wamp/bin/php/php5.3.13/ext/php_curl.dll' - The specified procedure could not be found.\r\n in Unknown on line 0

I thought the 5.4.3 library caused the error because of a version mismatch but I get the same error when I use the 5.3.13 DLL. What do I do now? I have a project underway that absolutely must have curl running. I don't want to upgrade to PHP 5.4.X because the site I'm working on has 5.3.x.

hedera
=======
Nature bats last.

Options: ReplyQuote
Re: Wamp Server 2.2 Windows 7 64-bit and curl not working side-by-side configuration incorrect
Posted by: RiggsFolly (---.as13285.net)
Date: May 07, 2014 11:42PM

Are you sure you downloaded the Thread Safe version of the Anindya.com php_curl.dll

Thats the one without the -nts- ( Not Thread Safe ) keywords in the title

From here [www.mediafire.com]

_______________________________________________________________________________________________________________
Windows 7 Pro 32bit running Wampserver 2.5 32bits
<Apache Versions 2.4.10/2.2.26> <PHP 5.6.1/5.5.14/5.4.31/5.3.28> <MySQL 5.6.17/5.5.28>
<phpMyAdmin 4.2.7.1> <MySQL Workbench 6.1.4.11773>

Never try and remember anything you can look up in a book. In other words, when all else fails
Read The Manuals Apache Docs -- MySQL Docs -- PHP Docs -- phpMyAdmin Docs

Options: ReplyQuote
Re: Wamp Server 2.2 Windows 7 64-bit and curl not working side-by-side configuration incorrect
Posted by: RiggsFolly (---.as13285.net)
Date: May 08, 2014 12:03AM

Are you sure you downloaded the Thread Safe version of the Anindya.com php_curl.dll

Thats the one without the -nts- ( Not Thread Safe ) keywords in the title

From here [www.mediafire.com]

_______________________________________________________________________________________________________________
Windows 7 Pro 32bit running Wampserver 2.5 32bits
<Apache Versions 2.4.10/2.2.26> <PHP 5.6.1/5.5.14/5.4.31/5.3.28> <MySQL 5.6.17/5.5.28>
<phpMyAdmin 4.2.7.1> <MySQL Workbench 6.1.4.11773>

Never try and remember anything you can look up in a book. In other words, when all else fails
Read The Manuals Apache Docs -- MySQL Docs -- PHP Docs -- phpMyAdmin Docs

Options: ReplyQuote
Re: Wamp Server 2.2 Windows 7 64-bit and curl not working side-by-side configuration incorrect
Posted by: hedera (---.lightspeed.sntcca.sbcglobal.net)
Date: May 08, 2014 12:25AM

I've NOW downloaded the thread safe version. I didn't know what "nts" stood for, nobody explained it; and the first Andiya.com page I saw only had one version for 5.3.13. I did more searching later and found a link on StackOverflow which led to an Andiya page with TWO 5.3.13 curl replacements, and when I downloaded the other - which you've just explained was the "thread safe" version - it worked like a charm. I'm curious why the first page I looked at didn't have it, but as long as it works now I'll just put it down to "The Internet."

Options: ReplyQuote
Pages: 12Next
Current Page: 1 of 2


Sorry, only registered users may post in this forum.