Internal Server Error
Posted by: farrelldoc (---.dsl.hstntx.sbcglobal.net)
Date: March 01, 2010 02:01PM

Every time I try to view a page on localhost, I get the following error:

============================================

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, admin@localhost and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.


--------------------------------------------------------------------------------

Apache/2.0.63 (Win32) PHP/5.3.0 Server at localhost Port 80

=============================================

At first, I did have it set up wrong with Apache 2.2.11 and PHP 5.3.0, but when I downloaded and installed 2.0.63, I still get the error.

I'm a web designer, and I don't know much about any of this, so forgive me if I'm asking a question about something obvious to the rest of you.

Thanks so much for your help!

Karen

Options: ReplyQuote
Re: Internal Server Error
Posted by: c2dan (---.15-1.cable.virginmedia.com)
Date: March 01, 2010 08:00PM

To see why you're getting the error left click wamp taskbar icon and choose Apache > error log. Post the last 10 lines here.

Options: ReplyQuote
Re: Internal Server Error
Posted by: farrelldoc (---.dsl.hstntx.sbcglobal.net)
Date: March 01, 2010 10:36PM

I copied a few more than 10--the top three are repeated over and over.
================================================


[Mon Mar 01 08:10:01 2010] [error] [client 192.168.0.12] client denied by server configuration: C:/wamp/www/HNAP1
[Mon Mar 01 08:10:04 2010] [error] [client 192.168.0.12] client denied by server configuration: C:/wamp/www/TEADevInfo
[Mon Mar 01 08:10:07 2010] [error] [client 192.168.0.12] client denied by server configuration: C:/wamp/www/
[Mon Mar 01 08:11:44 2010] [alert] [client 127.0.0.1] C:/wamp/www/chickensonline/.htaccess: Invalid command 'RewriteEngine', perhaps mis-spelled or defined by a module not included in the server configuration
[Mon Mar 01 08:11:46 2010] [error] [client 127.0.0.1] File does not exist: C:/wamp/www/favicon.ico
[Mon Mar 01 08:11:49 2010] [notice] Parent: Received shutdown signal -- Shutting down the server.
[Mon Mar 01 08:11:49 2010] [notice] Child 7320: Exit event signaled. Child process is ending.
[Mon Mar 01 08:11:50 2010] [notice] Child 7320: Released the start mutex
[Mon Mar 01 08:12:04 2010] [notice] Child 7320: All worker threads have exited.
[Mon Mar 01 08:12:04 2010] [notice] Child 7320: Child process is exiting
[Mon Mar 01 08:12:04 2010] [notice] Parent: Child process exited successfully.
[Mon Mar 01 15:32:04 2010] [notice] Apache/2.0.63 (Win32) PHP/5.3.0 configured -- resuming normal operations
[Mon Mar 01 15:32:05 2010] [notice] Server built: Jan 17 2008 22:58:29
[Mon Mar 01 15:32:05 2010] [notice] Parent: Created child process 7900
[Mon Mar 01 15:32:05 2010] [notice] Child 7900: Child process is running
[Mon Mar 01 15:32:05 2010] [notice] Child 7900: Acquired the start mutex.
[Mon Mar 01 15:32:05 2010] [notice] Child 7900: Starting 250 worker threads.

Options: ReplyQuote
Re: Internal Server Error
Posted by: farrelldoc (---.dsl.hstntx.sbcglobal.net)
Date: March 01, 2010 10:37PM

BTW, thanks for your help! smiling smiley

Options: ReplyQuote
Re: Internal Server Error
Posted by: c2dan (---.15-1.cable.virginmedia.com)
Date: March 01, 2010 10:50PM

Left click WAMP tray icon choose Apache > Modules > rewrite module

Options: ReplyQuote
Re: Internal Server Error
Posted by: yfastud (Moderator)
Date: March 02, 2010 01:11AM

your script has htaccess file which requires to enable mod-rewrite which you can enable through wamp tray icon smiling smiley

Have fun,

FREE One A Day
FREE Photo
FREE Games
FREE Websites
FREE Portable GPS
FREE WAMP Guides

Options: ReplyQuote
Re: Internal Server Error
Posted by: farrelldoc (---.dsl.hstntx.sbcglobal.net)
Date: March 02, 2010 04:22PM

Thank you so much! That worked!!!

Options: ReplyQuote
Re: Internal Server Error
Posted by: madhurip (---.246.205.139.static-pune.vsnl.net.in)
Date: August 30, 2013 08:59AM

I am getting the same error but it doesn't work.

it shows 500 Internal server error.

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, admin@localhost and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log

Options: ReplyQuote
Re: Internal Server Error
Posted by: RiggsFolly (---.as13285.net)
Date: August 30, 2013 10:14AM

Have you checked the apache error log?
Have you checked the Windows Event log for messages from Apache?

If so what are they?

Options: ReplyQuote
Re: Internal Server Error
Posted by: abhilash.tango (14.139.41.---)
Date: February 16, 2014 06:49AM

[Sun Feb 16 10:45:46 2014] [error] [client ::1] PHP Stack trace:, referer: [localhost]
[Sun Feb 16 10:45:46 2014] [error] [client ::1] PHP 1. {main}() C:\\wamp\\www\\try\\index.php:0, referer: [localhost]
[Sun Feb 16 10:45:46 2014] [error] [client ::1] PHP Warning: include() [<a href='function.include'>function.include</a>]: Failed opening 'smtp/Send_Mail.php' for inclusion (include_path='.;C:\\php\\pear') in C:\\wamp\\www\\try\\index.php on line 23, referer: [localhost]
[Sun Feb 16 10:45:46 2014] [error] [client ::1] PHP Stack trace:, referer: [localhost]
[Sun Feb 16 10:45:46 2014] [error] [client ::1] PHP 1. {main}() C:\\wamp\\www\\try\\index.php:0, referer: [localhost]
[Sun Feb 16 10:45:46 2014] [error] [client ::1] PHP Fatal error: Call to undefined function Send_Mail() in C:\\wamp\\www\\try\\index.php on line 28, referer: [localhost]
[Sun Feb 16 10:45:46 2014] [error] [client ::1] PHP Stack trace:, referer: [localhost]
[Sun Feb 16 10:45:46 2014] [error] [client ::1] PHP 1. {main}() C:\\wamp\\www\\try\\index.php:0, referer: [localhost]
[Sun Feb 16 11:00:49 2014] [alert] [client ::1] C:/wamp/www/try/.htaccess: Invalid command 'RewriteEngine', perhaps misspelled or defined by a module not included in the server configuration, referer: [localhost]
[Sun Feb 16 11:04:55 2014] [alert] [client ::1] C:/wamp/www/try/.htaccess: Invalid command 'RewriteEngine', perhaps misspelled or defined by a module not included in the server configuration, referer: [localhost]

Options: ReplyQuote
Re: Internal Server Error
Posted by: abhilash.tango (14.139.41.---)
Date: February 16, 2014 06:50AM

[Sun Feb 16 10:45:46 2014] [error] [client ::1] PHP Stack trace:, referer: [localhost]
[Sun Feb 16 10:45:46 2014] [error] [client ::1] PHP 1. {main}() C:\\wamp\\www\\try\\index.php:0, referer: [localhost]
[Sun Feb 16 10:45:46 2014] [error] [client ::1] PHP Warning: include() [<a href='function.include'>function.include</a>]: Failed opening 'smtp/Send_Mail.php' for inclusion (include_path='.;C:\\php\\pear') in C:\\wamp\\www\\try\\index.php on line 23, referer: [localhost]
[Sun Feb 16 10:45:46 2014] [error] [client ::1] PHP Stack trace:, referer: [localhost]
[Sun Feb 16 10:45:46 2014] [error] [client ::1] PHP 1. {main}() C:\\wamp\\www\\try\\index.php:0, referer: [localhost]
[Sun Feb 16 10:45:46 2014] [error] [client ::1] PHP Fatal error: Call to undefined function Send_Mail() in C:\\wamp\\www\\try\\index.php on line 28, referer: [localhost]
[Sun Feb 16 10:45:46 2014] [error] [client ::1] PHP Stack trace:, referer: [localhost]
[Sun Feb 16 10:45:46 2014] [error] [client ::1] PHP 1. {main}() C:\\wamp\\www\\try\\index.php:0, referer: [localhost]
[Sun Feb 16 11:00:49 2014] [alert] [client ::1] C:/wamp/www/try/.htaccess: Invalid command 'RewriteEngine', perhaps misspelled or defined by a module not included in the server configuration, referer: [localhost]
[Sun Feb 16 11:04:55 2014] [alert] [client ::1] C:/wamp/www/try/.htaccess: Invalid command 'RewriteEngine', perhaps misspelled or defined by a module not included in the server configuration, referer: [localhost]

Options: ReplyQuote
Re: Internal Server Error
Posted by: RiggsFolly (---.as13285.net)
Date: February 16, 2014 11:22PM

First fix is you need to include rewrite_module into apache


Do this by


left click wampmanager icon -> Apache -> Apache Modules -> rewrite_module

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.2.8 32bit & 64bit) Aestan Tray Menu 3.2.4.7
<Apache versions MULTIPE> <PHP versions MULTIPLE> <MySQL Versions MULTIPLE>
<MariaDB versions MULTIPLE> <phpMyAdmin versions MULTIPLE> <MySQL Workbench 8.0.23>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-

Options: ReplyQuote


Sorry, only registered users may post in this forum.