localhost doesn't work, does work
Posted by: HeXoN (---.access.telenet.be)
Date: August 27, 2007 08:48PM

Hi all!

Sorry if this has been posted several times but I can't find the answer to this problem on the forum (or google).

I installed WAMP5 v1.7.2 on WinXP SP2 (and all latest patches & fixes). Although this worked, no problem whatsoever. Until a few days back. When I go to "localhost" it would not show me the mainpage of WAMP5, but FireFox (uninstalled all plugins) asked me what to do: "Open with..." or "Save". On the other hand, if I do "["]; then it shows me the page. The Windows Host-file seems fine which contains " localhost". In Internet Explorer 7 both methods work, no matter what. But I don't want to use IE. My conclusion is that something is wrong with FireFox, but uninstall, reboot, and re-install doesn't seem to be a remedy.

Anyone has a solution to this (weird) behavior?

Thanks in advance!

Options: ReplyQuote
Re: localhost doesn't work, does work
Posted by: melban (---.norwood.com)
Date: August 27, 2007 09:44PM

Only reason I've seen localhost not work is if you are using a proxy for some reason. it tries to force it through the proxy server and the proxy server can't resolve the name or doesn't have a web server on the machine to give you back any page.

you can check the hosts file entry by open up the hosts file in notepad. There should be an entry like below.

c:/windows/system32/drivers/etc/hosts localhost

Options: ReplyQuote
Re: localhost doesn't work, does work
Posted by: HeXoN (---.access.telenet.be)
Date: August 28, 2007 07:53PM

Hi, thanks for your reply. But the hosts-file was correct, I checked it before and now again, but everything was fine over there :-)

But I found where the problem was. It was really FireFox that caused the problem somewhere. I don't know how, but Internet Explorer 7 and Opera both worked fine, as did FireFox in VirtualPC. So, the conclusion: FF is the troublemaker.

So, I unstalled it (again), but this time I renamed my Mozilla-folder (the one that holds you bookmarks, settings, cookies, .... ) to Mozilla_OLD and reinstalled FF. Worked like a charm. It seems that somewhere in the configuration of the older FireFox there was something changed, but sadly I can't pinpoint what exactly it was. Anyway, after reinstalling I just copied my bookmarks, and things like that, to the freshly created Mozilla folder and it worked.

Thanks from a happy WAMP5 user :-)

PS: for people who are looking for the Mozilla folder with their bookmarks and so on, you can find it at this location (Windows platform)
C:\Documents and Settings\<USERNAME>\Application Data\Mozilla\

Options: ReplyQuote

Sorry, only registered users may post in this forum.