Virtual website cannot be displayed - Check if there is a typo in iseppl
Posted by: AngelaP (137.132.119.---)
Date: May 17, 2022 12:31PM

1. Windows version used (Specify version number AND whether 32 or 64 bit)
Win 10 Education 64-bit

2 - Version WampServer (Specify version number AND whether 32 or 64 bit)
Wampserver 3.2.6 64-bit

3 - Apache Version – 2.4.51
4 - PHP Version – 7.4.26
5 - MySQL Version – 8.0.27
5a - MariaDB version if applicable – n.a.
6 - What color is the WampServer icon (in the notification area of the taskbar)
- green color

If the WampServer icon is green:

8 - Do you have access to localhost (Homepage WampServer)? Yes. I have
8a - If so, is there an error message at the bottom of the page?


9 - Do you have access to phpMyAdmin? - I have

10 - If you refer to an error message, please include the EXACT wording of the error in your post – N.A
11 - If you use an Antivirus and / or Firewall, please include the names of these – Trend Micro (Corporate Firewall)
12 - What is the full path to the installation of WampServer (eg D:\wamp\) – D:\wamp64

13 – http.conf - port 8181. Port 80 is taken by systems.
#Listen 12.34.56.78:80
Listen 0.0.0.0:8181
Listen [::0]:8181



13 - If you have one or more Virtual Hosts defined, please show their definition(s)
Location of httpd-vhosts.conf is in D:\wamp64\bin\apache\apache2.4.51\conf\extra

# Virtual Hosts
#
<VirtualHost *:8181>
ServerName localhost
ServerAlias localhost
DocumentRoot "d:/wamp64/www"
<Directory "d:/wamp64/www/">
Options +Indexes +Includes +FollowSymLinks +MultiViews
AllowOverride All
Require local
</Directory>
</VirtualHost>
#
#

#
<VirtualHost *:8181>
ServerName iseppL
DocumentRoot "D:\wamp64\www\iseppL"
<Directory "D:\wamp64\www\iseppL/">
Options -Indexes +Includes +FollowSymLinks +MultiViews
AllowOverride All
Require local
</Directory>
php_flag display_errors On
php_flag log_errors On
php_value max_upload_size 40M
php_value max_execution_time 120
php_value error_log D:/wamp64/logs/isep_local_phperror.log"
</VirtualHost>
#

Hosts file configuration:

127.0.0.1 localhost:8181
::1 localhost:8181

127.0.0.1 iseppL:8181
::1 iseppL:8181



Folders under “www” directory:


I am trying out the website for “iseppL” folder.

The localhost webpage is displayed. However, when I clicked on iseppL:8181 the webpage cannot be displayed.


The message is “This site can’t be reached”. Check if there is a typo in iseppl.

I am using Chrome as the browser to call up the website “iseppL”.

Thanks.

Regards
Angela

Options: ReplyQuote
Re: Virtual website cannot be displayed - Check if there is a typo in iseppl
Posted by: Otomatic (Moderator)
Date: May 17, 2022 03:11PM

Hi,

> Port 80 is taken by systems.
- What is the result of:
Right-Click -> Tools -> Check port 80

- What is the result of:
Right-Click -> Tools -> Show VirtualHost examined by Apache

------------------------------------------------------------------------------------------------------------
Wampserver 3.2.10 32 bit - Apache 2.4.54 - PHP 8.2.0…5.6.40 - MySQL 5.7.39 - MariaDB 10.5.13/10.6.5
Wampserver 3.2.10 64 bit - Apache 2.4.54 - PHP 8.2.0…5.6.40 - MySQL 5.7.39/8.0.30 - MariaDB 10.5.17/10.9.2
PhPMyadmin 5.2.0 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: Virtual website cannot be displayed - Check if there is a typo in iseppl
Posted by: AngelaP (137.132.119.---)
Date: May 18, 2022 05:35AM

Hi ,

Port 80 is taken by systems.
- What is the result of:
Right-Click -> Tools -> Check port 80

-- Port 80 is used by Server: Microsoft-HTTPAPI/2.0 as shown below:

Test for TCP
Your port 80 is used by a processus with PID = 4
The processus of PID 4 is 'System' Session: Services
The service of PID 4 for 'System' is 'N/A'
*** ERROR *** This service IS NOT from Wampserver - Should be: 'wampapache64'

Test for TCPv6
Your port 80 is used by a processus with PID = 4
The processus of PID 4 is 'System' Session: Services
The service of PID 4 for 'System' is 'N/A'
*** ERROR *** This service IS NOT from Wampserver - Should be: 'wampapache64'

===== Tested by attempting to open a socket on port 80 =====

Your port 80 is actually used by :

Server: Microsoft-HTTPAPI/2.0


- What is the result of:
Right-Click -> Tools -> Show VirtualHost examined by Apache

==
VirtualHost configuration:

Default server: localhost
On port 8181 Virtual Host: localhost
On port 8181 Virtual Host: iseppL
On port 8181 Virtual Host: testisep2

Options: ReplyQuote
Re: Virtual website cannot be displayed - Check if there is a typo in iseppl
Posted by: Otomatic (Moderator)
Date: May 18, 2022 09:28AM

Hi,

> Port 80 is used by Server: Microsoft-HTTPAPI/2.0 as shown below:
See item 08 of TROUBLESHOOTING TIPS

And then you can use port 80 which is the default port for the http(s) protocol.

Your VirtualHost iseppL was not created by the Wampserver integrated tool, it has syntax errors.

> DocumentRoot "D:\wamp64\www\iseppL"
> <Directory "D:\wamp64\www\iseppL/">

Do not use backslashes (\) but only slashes (/):
DocumentRoot "D:/wamp64/www/iseppL"
<Directory "D:/wamp64/www/iseppL/">

------------------------------------------------------------------------------------------------------------
Wampserver 3.2.10 32 bit - Apache 2.4.54 - PHP 8.2.0…5.6.40 - MySQL 5.7.39 - MariaDB 10.5.13/10.6.5
Wampserver 3.2.10 64 bit - Apache 2.4.54 - PHP 8.2.0…5.6.40 - MySQL 5.7.39/8.0.30 - MariaDB 10.5.17/10.9.2
PhPMyadmin 5.2.0 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: Virtual website cannot be displayed - Check if there is a typo in iseppl
Posted by: AngelaP2 (137.132.119.---)
Date: May 18, 2022 11:27AM

Hi,

I cannot login using my username AngelaP and there is no email sent to me for the reset of my password.
Hence, I created another username AngelaP2.


> Port 80 is used by Server: Microsoft-HTTPAPI/2.0 as shown below:

See item 08 of TROUBLESHOOTING TIPS

And then you can use port 80 which is the default port for the http(s) protocol.

- i have checked and I do not have IIS installed.



> DocumentRoot "D:\wamp64\www\iseppL"
> <Directory "D:\wamp64\www\iseppL/">

- I have changed the slashes to slashes (/) but still cannot access the virtual host on 8181.


Does the virtual hosts need to have port 80?


Thanks.

Options: ReplyQuote
Re: Virtual website cannot be displayed - Check if there is a typo in iseppl
Posted by: Otomatic (Moderator)
Date: May 18, 2022 01:30PM

Hi,

> I do not have IIS installed.
You must have some IIS installed, otherwise port 80 would be free.

Since you have the -Indexes option for your VirtualHost, do you have an index.php file in the D:/wamp64/www/iseppL/ folder?

In the address bar of Chrome, it says 'http://iseppL:8081/' ?

Because if 'http://localhost:8081/' works, there is no reason why 'http://iseppL:8081/' should not work.

I just did a full-scale test by changing the listening port 80 to 8081 via :
Right-click -> Tools -> Use a port other than 80 and all my VirtualHost work, even with Chrome.

Check with another browser like Firefox.

Note: You may need to clear the browser cache with Ctrl-F5

------------------------------------------------------------------------------------------------------------
Wampserver 3.2.10 32 bit - Apache 2.4.54 - PHP 8.2.0…5.6.40 - MySQL 5.7.39 - MariaDB 10.5.13/10.6.5
Wampserver 3.2.10 64 bit - Apache 2.4.54 - PHP 8.2.0…5.6.40 - MySQL 5.7.39/8.0.30 - MariaDB 10.5.17/10.9.2
PhPMyadmin 5.2.0 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: Virtual website cannot be displayed - Check if there is a typo in iseppl
Posted by: RiggsFolly (Moderator)
Date: May 18, 2022 02:02PM

1. There is no email server on a windows system, unless you installed one!

-- i have checked and I do not have IIS installed.
There are other things that report as `Server: Microsoft-HTTPAPI/2.0`
Have a lok at this Why Port 80 is Being Used by System Process ID 4

Something will need dtopping or removing.

-- but still cannot access the virtual host on 8181.
Are you adding the port number to the url?

'http://iseppL:8181' would be required to run the site via that port

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.2.8 32bit & 64bit) Aestan Tray Menu 3.2.4.7
<Apache versions MULTIPE> <PHP versions MULTIPLE> <MySQL Versions MULTIPLE>
<MariaDB versions MULTIPLE> <phpMyAdmin versions MULTIPLE> <MySQL Workbench 8.0.23>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-



Edited 1 time(s). Last edit at 05/18/2022 02:03PM by RiggsFolly.

Options: ReplyQuote


Sorry, only registered users may post in this forum.