Composer detected issues in your platform: Your Composer dependencies require the following PHP extensions to be installed: openssl
Posted by: codeslayer2010 (---.res.spectrum.com)
Date: December 01, 2021 02:15PM

I was getting PHP debug errors after upgrading Wampserver to use PHP version 7.4, so I could test arrow functions. After researching, I found that updating my phpMyAdmin was required. So I downloaded and installed the Phpmyadmin 5.1.1 file (https://wampserver.aviatechno.net/files/apps/wampserver3_x86_x64_phpmyadmin5.1.1.exe) from Wampserver aviatechno website.

After installing the new version of Phpmyadmin all PHP debug errors disappeared, but now I get this error and Phpmyadmin index/main/start page doesn't even load. Instead, I get a white page with this error:

"Composer detected issues in your platform: Your Composer dependencies
require the following PHP extensions to be installed: openssl"

But, in PHP Extensions "openssl" is already checked.

How do I get phpMyAdmin 5.1.1 working?

Eric "CodeSlayer" Hepperle, Web Developer & WAMPServer enthusiast
[erichepperle.com]
[github.com]
[stackoverflow.com]



Edited 1 time(s). Last edit at 12/01/2021 02:21PM by codeslayer2010.

Options: ReplyQuote
Re: Composer detected issues in your platform: Your Composer dependencies require the following PHP extensions to be installed: openssl
Posted by: Otomatic (Moderator)
Date: December 01, 2021 02:42PM

Hi,

> After installing the new version of Phpmyadmin all PHP debug errors disappeared
PhpMyAdmin 4.9.7 doesn't support PHP 7.4
PhpMyAdmin 5.1.1 supports PHP 7.4

> I get this error and Phpmyadmin index/main/start page doesn't even load.
> Instead, I get a white page with this error:
Because you launch PhpMyAdmin via Composer and not from Wampmanager or via 'http://localhost/phpmyadmin/' and Composer does not use the PHP extensions and parameters defined by the PHP menu of Wampmanager.

> But, in PHP Extensions "openssl" is already checked.
It is for the use of PHP in WEB mode, what Wampserver is made for but Composer uses PHP in CLI mode.

If we use PHP in CLI, it is not the extensions and parameters seen in the PHP option of the Wampmanager menu that are used.
Indeed, Wampserver is an Apache, PHP, MySQL server for WEB development, so it is the extensions and parameters of PHP for the use in protocol 'http://' which are indicated.
Extensions and parameters for use in CLI mode cannot be modified by Wampmanager menus, it is necessary to do it "by hand" in the php.ini file of the used PHP CLI version.

------------------------------------------------------------------------------------------------------------
Wampserver 3.2.9 32 bit - Apache 2.4.53 - PHP 8.1.5…5.6.40 - MySQL 5.7.38 - MariaDB 10.5.13/10.6.5
Wampserver 3.2.9 64 bit - Apache 2.4.53 - PHP 8.1.5…5.6.40 - MySQL 5.7.38/8.0.29 - MariaDB 10.5.15/10.7.3
PhPMyadmin 5.1.3 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: Composer detected issues in your platform: Your Composer dependencies require the following PHP extensions to be installed: openssl
Posted by: codeslayer2010 (---.res.spectrum.com)
Date: December 01, 2021 02:45PM

@ottomatic

I appreciate your reply however,

> Because you launch PhpMyAdmin via Composer and not from Wampmanager or via 'http://localhost/phpmyadmin/'

isn't true. I am launching from the link on the localhost dashboard and getting this error about Composer. I don't even have composer installed so I'm not sure why I'm getting that error. I'm not using CLI, I'm just clicking a link on the localhost page.

Eric "CodeSlayer" Hepperle, Web Developer & WAMPServer enthusiast
[erichepperle.com]
[github.com]
[stackoverflow.com]

Options: ReplyQuote
Re: Composer detected issues in your platform: Your Composer dependencies require the following PHP extensions to be installed: openssl
Posted by: Otomatic (Moderator)
Date: December 01, 2021 04:35PM

Wampserver 3.2.6 - PHP 7.4.26 - PhpMyAdmin 5.1.1
If I disable the PHP openssl extension there is the error:
"Composer detected issues in your platform: Your Composer dependencies require the following PHP extensions to be installed: openssl"
when launching PhpMyAdmin.
This confirms that it is not due to any installation of Composer.
If I revalidate the openssl extension, this error disappears and PhpMyAdmin starts without problem.

To work properly, the PHP openssl extension requires the ability to access the dll file libeay32.dll, or, as of OpenSSL 1.1, libcrypto-*.dll
For PHP 7.4.26 32bit, it is libcrypto-1_1.dll
For PHP 7.4.26 64bit, it is libcrypto-1_1-x64.dll
and these files are present in the related php folder.

I don't see what could be causing this error unless it's another unloaded PHP extension.
Wampserver 3.2.6 has the possibility to display (and possibly copy to the clipboard) the list of PHP extensions actually loaded by :
Left-click -> PHP -> Show PHP loaded Extensions.
For me, it's :
-- PHP Loaded Extensions
 With function get_loaded_extensions()

 bcmath        bz2           calendar      com_dotnet    Core          ctype        
 curl          date          dom           exif          fileinfo      filter       
 gd            gettext       gmp           hash          iconv         imap         
 intl          json          ldap          libxml        mbstring      mysqli       
 mysqlnd       openssl       pcre          PDO           pdo_mysql     pdo_sqlite   
 Phar          readline      Reflection    session       SimpleXML     soap         
 sockets       SPL           sqlite3       standard      tokenizer     xdebug       
 xml           xmlreader     xmlrpc        xmlwriter     xsl           Zend OPcache 
 zip           zlib

------------------------------------------------------------------------------------------------------------
Wampserver 3.2.9 32 bit - Apache 2.4.53 - PHP 8.1.5…5.6.40 - MySQL 5.7.38 - MariaDB 10.5.13/10.6.5
Wampserver 3.2.9 64 bit - Apache 2.4.53 - PHP 8.1.5…5.6.40 - MySQL 5.7.38/8.0.29 - MariaDB 10.5.15/10.7.3
PhPMyadmin 5.1.3 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: Composer detected issues in your platform: Your Composer dependencies require the following PHP extensions to be installed: openssl
Posted by: codeslayer2010 (---.res.spectrum.com)
Date: December 02, 2021 12:20PM

Otomatic Wrote:
> To work properly, the PHP openssl extension
> requires the ability to access the dll file
> libeay32.dll, or, as of OpenSSL 1.1,
> libcrypto-*.dll
> For PHP 7.4.26 32bit, it is libcrypto-1_1.dll
> For PHP 7.4.26 64bit, it is libcrypto-1_1-x64.dll
> and these files are present in the related php
> folder.
>
> I don't see what could be causing this error
> unless it's another unloaded PHP extension.
> Wampserver 3.2.6 has the possibility to display
> (and possibly copy to the clipboard) the list of
> PHP extensions actually loaded by :
> Left-click -> PHP -> Show PHP loaded Extensions.

Thanks for the tip about loaded extensions Ottomatic!

I only recently (within last 2-3 months) updated to 3.2.5, but am taking your hint and installing 3.2.6 64-Bit. I will report back with my extensions set after.

Eric "CodeSlayer" Hepperle, Web Developer & WAMPServer enthusiast
[erichepperle.com]
[github.com]
[stackoverflow.com]

Options: ReplyQuote
Re: Composer detected issues in your platform: Your Composer dependencies require the following PHP extensions to be installed: openssl
Posted by: codeslayer2010 (---.res.spectrum.com)
Date: December 02, 2021 12:58PM

Yikes! I'm good with the PHP programming and MySQL, but it seems like whenever I have a blocker it is something to do with my web server/Apache ...

Here is what I"ve done:

1) Downloaded and ran check_vcredist.exe. It said I needed one 2008 redist.
2) Downloaded and unzipped wampserver_all_vc_redist_x86_x64.zip. Installed all the 2008 redists, always 32 bit first, then 64 bit.
3) Downloaded the newest full Wampserver wampserver3.2.6_x64.exe. When I tried to install it I got this error:

"The selected installation folder already contains an installation of Wampserver. Select another folder for this installation."

4) I found your reply on this user's post [forum.wampserver.com] and inferred that I needed to download an update to Wampserver instead ... um, but THERE IS NO UPDATE TO 3.2.6.

5) I even downloaded and installed the XDebug update Update xDebug 3.1.1 32 & 64bit, thinking that might solve the issue with the PHP debugging errors I mentioned in my previous post on stack overflow (https://stackoverflow.com/questions/70173876/php-errors-after-moving-mediawiki-to-subfolder-on-wampserver) to no avail.

So, I'm in a quandry. My time to work on this is very limited (only an hour or so each morn before I have to go to work). So, I need to know what all is involved in fixing these issues so that I can plan and budget my time appropriately:

A) What are the ramifications (répercussions) of uninstalling Wampserver 3.2.5 in order to install version 3.2.6? Will it break anything?

cool smiley If I uninstall the old version and install the new version, will the new version take care of automatically installing all the other files I had to manually download as extensions for the previous version? (phpmyadmin, aestantray, xdebug update, other versions of mysql, other versions of php, etc.)?

Thank you.

Eric "CodeSlayer" Hepperle, Web Developer & WAMPServer enthusiast
[erichepperle.com]
[github.com]
[stackoverflow.com]

Options: ReplyQuote
Re: Composer detected issues in your platform: Your Composer dependencies require the following PHP extensions to be installed: openssl
Posted by: Otomatic (Moderator)
Date: December 02, 2021 02:51PM

Hi,

> 4) I found your reply on this user's post [forum.wampserver.com] and inferred
> that I needed to download an update to Wampserver instead ... um, but THERE IS NO UPDATE TO 3.2.6.

And what is this?
Wampserver update 3.2.6
or this
Wampserver update 3.2.6
It would be necessary, nevertheless, from time to time, to go to read WAMPserver 3 - All you need to know where the explanations and the links are given.

------------------------------------------------------------------------------------------------------------
Wampserver 3.2.9 32 bit - Apache 2.4.53 - PHP 8.1.5…5.6.40 - MySQL 5.7.38 - MariaDB 10.5.13/10.6.5
Wampserver 3.2.9 64 bit - Apache 2.4.53 - PHP 8.1.5…5.6.40 - MySQL 5.7.38/8.0.29 - MariaDB 10.5.15/10.7.3
PhPMyadmin 5.1.3 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote


Sorry, only registered users may post in this forum.