PHP caching problem since WAMPServer 2.3.0
Posted by: pmanninger (---.dip0.t-ipconnect.de)
Date: February 14, 2020 12:37PM

Hey community,

I have a PHP caching problem since I've installed WAMPServer 2.3.0.
After installing TYPO3 9.5 LTS for example you get a long page load and an ERR_CONNECTION_REFUSED in Chrome. Apache Error Log and PHP Error Log say nothing.

Am I the only one detecting that? It even happens after a complete fresh Windows setup.

Thanks for any help.



Edited 1 time(s). Last edit at 02/14/2020 12:55PM by pmanninger.

Options: ReplyQuote
Re: PHP caching problem since WAMP 2.3.0
Posted by: RiggsFolly (Moderator)
Date: February 14, 2020 12:46PM

WAMPSevrer 2.3.0??

Also, try it with another borwser please, do you get the same?

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.2.0 32bit & 64bit)
<Apache versions MULTIPE> <PHP versions MULTIPLE> <MySQL Versions MULTIPLE>
<MariaDB versions MULTIPLE> <phpMyAdmin versions MULTIPLE> <MySQL Workbench 8.0.19>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-

Options: ReplyQuote
Re: PHP caching problem since WAMP 2.3.0
Posted by: pmanninger (---.dip0.t-ipconnect.de)
Date: February 14, 2020 12:55PM

Yes WampServer of course and yes also in Edge and Firefox.

In fact, project.local/typo3/install.php and all the actions there runs like charm. Only the - i guess here - the OP cached files aren't found. Or could there be a problem with read/write rights? But WAMP Server runs under administration.



Edited 1 time(s). Last edit at 02/14/2020 01:21PM by pmanninger.

Options: ReplyQuote
Re: PHP caching problem since WAMP 2.3.0
Posted by: RiggsFolly (Moderator)
Date: February 14, 2020 01:07PM

Did you mean WampServer 3.2.0?

Can you read and answer these questions please READ (and answer) BEFORE YOU ASK A QUESTION

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.2.0 32bit & 64bit)
<Apache versions MULTIPE> <PHP versions MULTIPLE> <MySQL Versions MULTIPLE>
<MariaDB versions MULTIPLE> <phpMyAdmin versions MULTIPLE> <MySQL Workbench 8.0.19>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-

Options: ReplyQuote
Re: PHP caching problem since WAMP 2.3.0
Posted by: pmanninger (---.dip0.t-ipconnect.de)
Date: February 14, 2020 01:30PM

If the WampServer icon is green:

8 - Do you have access to localhost (Homepage WampServer)?
=> Yes

8a - If so, is there an error message at the bottom of the page?
=> No, only the info: These are your folders in c:/wamp64/www - To use them as an http link, you must declare them as VirtualHost

9 - Do you have access to phpMyAdmin?
=> yes

10 - If you refer to an error message, please include the EXACT wording of the error in your post
=> php_error.log (is empty)

=> apache_error.log:

File created by Wampserver install[Fri Feb 14 13:12:57.907107 2020] [mpm_winnt:notice] [pid 1492:tid 616] AH00428: Parent: child process 8916 exited with status 3221225725 -- Restarting.
[Fri Feb 14 13:12:57.954011 2020] [mpm_winnt:notice] [pid 1492:tid 616] AH00455: Apache/2.4.41 (Win64) PHP/7.3.12 configured -- resuming normal operations
[Fri Feb 14 13:12:57.954011 2020] [mpm_winnt:notice] [pid 1492:tid 616] AH00456: Apache Lounge VS16 Server built: Aug 9 2019 16:46:32
[Fri Feb 14 13:12:57.954011 2020] [core:notice] [pid 1492:tid 616] AH00094: Command line: 'c:\\wamp64\\bin\\apache\\apache2.4.41\\bin\\httpd.exe -d C:/wamp64/bin/apache/apache2.4.41'
[Fri Feb 14 13:12:57.969616 2020] [mpm_winnt:notice] [pid 1492:tid 616] AH00418: Parent: Created child process 2496
[Fri Feb 14 13:12:58.282020 2020] [mpm_winnt:notice] [pid 2496:tid 732] AH00354: Child: Starting 64 worker threads.
[Fri Feb 14 13:12:59.891013 2020] [mpm_winnt:notice] [pid 1492:tid 616] AH00428: Parent: child process 2496 exited with status 3221225725 -- Restarting.
[Fri Feb 14 13:12:59.953502 2020] [mpm_winnt:notice] [pid 1492:tid 616] AH00455: Apache/2.4.41 (Win64) PHP/7.3.12 configured -- resuming normal operations
[Fri Feb 14 13:12:59.953502 2020] [mpm_winnt:notice] [pid 1492:tid 616] AH00456: Apache Lounge VS16 Server built: Aug 9 2019 16:46:32
[Fri Feb 14 13:12:59.953502 2020] [core:notice] [pid 1492:tid 616] AH00094: Command line: 'c:\\wamp64\\bin\\apache\\apache2.4.41\\bin\\httpd.exe -d C:/wamp64/bin/apache/apache2.4.41'
[Fri Feb 14 13:12:59.953502 2020] [mpm_winnt:notice] [pid 1492:tid 616] AH00418: Parent: Created child process 5660
[Fri Feb 14 13:13:00.281582 2020] [mpm_winnt:notice] [pid 5660:tid 740] AH00354: Child: Starting 64 worker threads.
[Fri Feb 14 13:13:01.796816 2020] [mpm_winnt:notice] [pid 1492:tid 616] AH00428: Parent: child process 5660 exited with status 3221225725 -- Restarting.
[Fri Feb 14 13:13:01.843676 2020] [mpm_winnt:notice] [pid 1492:tid 616] AH00455: Apache/2.4.41 (Win64) PHP/7.3.12 configured -- resuming normal operations
[Fri Feb 14 13:13:01.843676 2020] [mpm_winnt:notice] [pid 1492:tid 616] AH00456: Apache Lounge VS16 Server built: Aug 9 2019 16:46:32
[Fri Feb 14 13:13:01.843676 2020] [core:notice] [pid 1492:tid 616] AH00094: Command line: 'c:\\wamp64\\bin\\apache\\apache2.4.41\\bin\\httpd.exe -d C:/wamp64/bin/apache/apache2.4.41'
[Fri Feb 14 13:13:01.859339 2020] [mpm_winnt:notice] [pid 1492:tid 616] AH00418: Parent: Created child process 9032
[Fri Feb 14 13:13:02.187382 2020] [mpm_winnt:notice] [pid 9032:tid 740] AH00354: Child: Starting 64 worker threads.
[Fri Feb 14 13:13:03.749474 2020] [mpm_winnt:notice] [pid 1492:tid 616] AH00428: Parent: child process 9032 exited with status 3221225725 -- Restarting.
[Fri Feb 14 13:13:03.796338 2020] [mpm_winnt:notice] [pid 1492:tid 616] AH00455: Apache/2.4.41 (Win64) PHP/7.3.12 configured -- resuming normal operations
[Fri Feb 14 13:13:03.796338 2020] [mpm_winnt:notice] [pid 1492:tid 616] AH00456: Apache Lounge VS16 Server built: Aug 9 2019 16:46:32
[Fri Feb 14 13:13:03.796338 2020] [core:notice] [pid 1492:tid 616] AH00094: Command line: 'c:\\wamp64\\bin\\apache\\apache2.4.41\\bin\\httpd.exe -d C:/wamp64/bin/apache/apache2.4.41'
[Fri Feb 14 13:13:03.796338 2020] [mpm_winnt:notice] [pid 1492:tid 616] AH00418: Parent: Created child process 6600
[Fri Feb 14 13:13:04.124424 2020] [mpm_winnt:notice] [pid 6600:tid 776] AH00354: Child: Starting 64 worker threads.
[Fri Feb 14 13:13:05.717792 2020] [mpm_winnt:notice] [pid 1492:tid 616] AH00428: Parent: child process 6600 exited with status 3221225725 -- Restarting.
[Fri Feb 14 13:13:05.780279 2020] [mpm_winnt:notice] [pid 1492:tid 616] AH00455: Apache/2.4.41 (Win64) PHP/7.3.12 configured -- resuming normal operations
[Fri Feb 14 13:13:05.780279 2020] [mpm_winnt:notice] [pid 1492:tid 616] AH00456: Apache Lounge VS16 Server built: Aug 9 2019 16:46:32
[Fri Feb 14 13:13:05.780279 2020] [core:notice] [pid 1492:tid 616] AH00094: Command line: 'c:\\wamp64\\bin\\apache\\apache2.4.41\\bin\\httpd.exe -d C:/wamp64/bin/apache/apache2.4.41'
[Fri Feb 14 13:13:05.780279 2020] [mpm_winnt:notice] [pid 1492:tid 616] AH00418: Parent: Created child process 4720
[Fri Feb 14 13:13:06.217678 2020] [mpm_winnt:notice] [pid 4720:tid 744] AH00354: Child: Starting 64 worker threads.
[Fri Feb 14 13:13:07.795390 2020] [mpm_winnt:notice] [pid 1492:tid 616] AH00428: Parent: child process 4720 exited with status 3221225725 -- Restarting.
[Fri Feb 14 13:13:07.842253 2020] [mpm_winnt:notice] [pid 1492:tid 616] AH00455: Apache/2.4.41 (Win64) PHP/7.3.12 configured -- resuming normal operations
[Fri Feb 14 13:13:07.842253 2020] [mpm_winnt:notice] [pid 1492:tid 616] AH00456: Apache Lounge VS16 Server built: Aug 9 2019 16:46:32
[Fri Feb 14 13:13:07.842253 2020] [core:notice] [pid 1492:tid 616] AH00094: Command line: 'c:\\wamp64\\bin\\apache\\apache2.4.41\\bin\\httpd.exe -d C:/wamp64/bin/apache/apache2.4.41'
[Fri Feb 14 13:13:07.858063 2020] [mpm_winnt:notice] [pid 1492:tid 616] AH00418: Parent: Created child process 8744
[Fri Feb 14 13:13:08.295308 2020] [mpm_winnt:notice] [pid 8744:tid 724] AH00354: Child: Starting 64 worker threads.
[Fri Feb 14 13:13:09.966750 2020] [mpm_winnt:notice] [pid 1492:tid 616] AH00428: Parent: child process 8744 exited with status 3221225725 -- Restarting.
[Fri Feb 14 13:13:10.013614 2020] [mpm_winnt:notice] [pid 1492:tid 616] AH00455: Apache/2.4.41 (Win64) PHP/7.3.12 configured -- resuming normal operations
[Fri Feb 14 13:13:10.013614 2020] [mpm_winnt:notice] [pid 1492:tid 616] AH00456: Apache Lounge VS16 Server built: Aug 9 2019 16:46:32
[Fri Feb 14 13:13:10.013614 2020] [core:notice] [pid 1492:tid 616] AH00094: Command line: 'c:\\wamp64\\bin\\apache\\apache2.4.41\\bin\\httpd.exe -d C:/wamp64/bin/apache/apache2.4.41'
[Fri Feb 14 13:13:10.029234 2020] [mpm_winnt:notice] [pid 1492:tid 616] AH00418: Parent: Created child process 6848
[Fri Feb 14 13:13:10.451019 2020] [mpm_winnt:notice] [pid 6848:tid 740] AH00354: Child: Starting 64 worker threads.
[Fri Feb 14 13:13:12.075626 2020] [mpm_winnt:notice] [pid 1492:tid 616] AH00428: Parent: child process 6848 exited with status 3221225725 -- Restarting.
[Fri Feb 14 13:13:12.122490 2020] [mpm_winnt:notice] [pid 1492:tid 616] AH00455: Apache/2.4.41 (Win64) PHP/7.3.12 configured -- resuming normal operations
[Fri Feb 14 13:13:12.122490 2020] [mpm_winnt:notice] [pid 1492:tid 616] AH00456: Apache Lounge VS16 Server built: Aug 9 2019 16:46:32
[Fri Feb 14 13:13:12.122490 2020] [core:notice] [pid 1492:tid 616] AH00094: Command line: 'c:\\wamp64\\bin\\apache\\apache2.4.41\\bin\\httpd.exe -d C:/wamp64/bin/apache/apache2.4.41'
[Fri Feb 14 13:13:12.122490 2020] [mpm_winnt:notice] [pid 1492:tid 616] AH00418: Parent: Created child process 9496
[Fri Feb 14 13:13:12.450536 2020] [mpm_winnt:notice] [pid 9496:tid 724] AH00354: Child: Starting 64 worker threads.
[Fri Feb 14 13:13:14.028287 2020] [mpm_winnt:notice] [pid 1492:tid 616] AH00428: Parent: child process 9496 exited with status 3221225725 -- Restarting.
[Fri Feb 14 13:13:14.075190 2020] [mpm_winnt:notice] [pid 1492:tid 616] AH00455: Apache/2.4.41 (Win64) PHP/7.3.12 configured -- resuming normal operations
[Fri Feb 14 13:13:14.075190 2020] [mpm_winnt:notice] [pid 1492:tid 616] AH00456: Apache Lounge VS16 Server built: Aug 9 2019 16:46:32
[Fri Feb 14 13:13:14.075190 2020] [core:notice] [pid 1492:tid 616] AH00094: Command line: 'c:\\wamp64\\bin\\apache\\apache2.4.41\\bin\\httpd.exe -d C:/wamp64/bin/apache/apache2.4.41'
[Fri Feb 14 13:13:14.075190 2020] [mpm_winnt:notice] [pid 1492:tid 616] AH00418: Parent: Created child process 6856
[Fri Feb 14 13:13:14.508305 2020] [mpm_winnt:notice] [pid 6856:tid 720] AH00354: Child: Starting 64 worker threads.
[Fri Feb 14 13:13:16.049373 2020] [mpm_winnt:notice] [pid 1492:tid 616] AH00428: Parent: child process 6856 exited with status 3221225725 -- Restarting.
[Fri Feb 14 13:13:16.127480 2020] [mpm_winnt:notice] [pid 1492:tid 616] AH00455: Apache/2.4.41 (Win64) PHP/7.3.12 configured -- resuming normal operations
[Fri Feb 14 13:13:16.127480 2020] [mpm_winnt:notice] [pid 1492:tid 616] AH00456: Apache Lounge VS16 Server built: Aug 9 2019 16:46:32
[Fri Feb 14 13:13:16.127480 2020] [core:notice] [pid 1492:tid 616] AH00094: Command line: 'c:\\wamp64\\bin\\apache\\apache2.4.41\\bin\\httpd.exe -d C:/wamp64/bin/apache/apache2.4.41'
[Fri Feb 14 13:13:16.127480 2020] [mpm_winnt:notice] [pid 1492:tid 616] AH00418: Parent: Created child process 6432
[Fri Feb 14 13:13:16.455527 2020] [mpm_winnt:notice] [pid 6432:tid 756] AH00354: Child: Starting 64 worker threads.


11 - If you use an Antivirus and / or Firewall, please include the names of these
=> Windows Security (which comes by default)

12 - What is the full path to the installation of WampServer (eg D:\wamp\)
=> C:\wamp64\

13 - If you have one or more Virtual Hosts defined, please show their definition(s)
=> yes

#
<VirtualHost *:80>
	ServerName typo39
	DocumentRoot "c:/wamp64/www/typo39"
	<Directory  "c:/wamp64/www/typo39/">
		Options +Indexes +Includes +FollowSymLinks +MultiViews
		AllowOverride All
		Require local
	</Directory>
</VirtualHost>



Edited 2 time(s). Last edit at 02/14/2020 01:38PM by RiggsFolly.

Options: ReplyQuote
Re: PHP caching problem since WAMP 2.3.0
Posted by: RiggsFolly (Moderator)
Date: February 14, 2020 01:57PM

Is this happening only with TYPO3 sites?

I had a sniff around the internet about TYPO3 are you sure that PHP7.3 and TYPO3 9.5 are compatible

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.2.0 32bit & 64bit)
<Apache versions MULTIPE> <PHP versions MULTIPLE> <MySQL Versions MULTIPLE>
<MariaDB versions MULTIPLE> <phpMyAdmin versions MULTIPLE> <MySQL Workbench 8.0.19>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-

Options: ReplyQuote
Re: PHP caching problem since WAMPServer 2.3.0
Posted by: pmanninger (---.dip0.t-ipconnect.de)
Date: February 14, 2020 02:04PM

Is this happening only with TYPO3 sites?
=> Yes

I had a sniff around the internet about TYPO3 are you sure that PHP7.3 and TYPO3 9.5 are compatible
=> The same project (files and database) did work with WAMP Server with an older version (don't know the exact number) and the "not working" circumstances are the same in PHP 7.2 with WAMP Server.

Options: ReplyQuote
Re: PHP caching problem since WAMPServer 2.3.0
Posted by: Otomatic (Moderator)
Date: February 14, 2020 02:20PM

Hi,
Have you checked if you have activated the necessary modules or extensions?
Web Server Requirements
PHP extensions

------------------------------------------------------------------------------------------------------------
Wampserver 3.2.3 32 bit - Apache 2.4.46 - PHP 7.4.9…5.6.40 - MySQL 5.7.31 - MariaDB 10.5.5
Wampserver 3.2.3 64 bit - Apache 2.4.46 - PHP 7.4.9…5.6.40 - MySQL 5.7.31/8.0.21 - MariaDB 10.5.5
PhPMyadmin 5.0.2 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: PHP caching problem since WAMPServer 2.3.0
Posted by: Otomatic (Moderator)
Date: February 14, 2020 02:26PM

Hi,

> Apache exited with status 3221225725 -- Restarting.

In file httpd.conf just after :
AcceptFilter http none
AcceptFilter https none

Add:
# ThreadStackSize directive sets the size of the stack (for autodata)
# of threads which handle client connections and call modules to help process
# those connections. In most cases the operating system default for stack size
# is reasonable, but there are some conditions where it may need to be adjusted.
# Apache httpd may crash when using some third-party modules which use a
# relatively large amount of autodata storage or automatically restart with
# message like: child process 12345 exited with status 3221225725 -- Restarting.
# This type of crash is resolved by setting ThreadStackSize to a value higher
# than the operating system default.
ThreadStackSize 8388608‬

------------------------------------------------------------------------------------------------------------
Wampserver 3.2.3 32 bit - Apache 2.4.46 - PHP 7.4.9…5.6.40 - MySQL 5.7.31 - MariaDB 10.5.5
Wampserver 3.2.3 64 bit - Apache 2.4.46 - PHP 7.4.9…5.6.40 - MySQL 5.7.31/8.0.21 - MariaDB 10.5.5
PhPMyadmin 5.0.2 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: PHP caching problem since WAMPServer 2.3.0
Posted by: pmanninger (---.dip0.t-ipconnect.de)
Date: February 17, 2020 10:32AM

@Otomatic: wow thanks.

In earlier versions of WAMP Server TYPO3 always complains about the ThreadStackSize but the httpd setting never changed anything. Now it obviously works and has to be set.

Thank you very much smiling smiley

Options: ReplyQuote


Sorry, only registered users may post in this forum.