WAMP64 3.1.7 & CGIProxy 2.2.4 - Odd Redirect
Posted by: SaltyTilty (---.hsd1.mn.comcast.net)
Date: August 28, 2019 04:24AM

Greetings,

I am running a localhost WAMP 3.1.7 64-bit with James Marshall's CGIProxy 2.2.4. installed with Perl5 on Windows 10. I have followed the set up instructions to the best of my ability and have tried to configure everything correctly, but I believe there is a mistake somewhere.

I have set up SSL with a self-signed key & certificate with OpenSSL. I can execute the cgi script, which lands me on the CGI Proxy welcome screen. When I type a website into the search box and click "Begin Browsing" I am redirected back to my index.php page instead of the intended website.

I have tried to do some research on the subject but I haven't been able to find anything related to this type of occurrence. Does anyone have any ideas or insight as to why this is happening?

Thank you in advance

WAMP Icon is GREEN.
I have access to the localhost homepage. No error at the bottom of the page.
I have access to PHP MyAdmin.
Ports 80 and 443 have been forwarded. I am just using the Windows 10 firewall / and a Linksys router.
Install path for wamp is C:\wamp64\



Edited 2 time(s). Last edit at 08/28/2019 07:47PM by SaltyTilty.

Options: ReplyQuote
Re: WAMP64 3.1.7 & CGIProxy 2.2.4 - Odd Redirect
Posted by: RiggsFolly (Moderator)
Date: August 28, 2019 06:44PM

Hi,

Sorry, but this is most definitely not a WAMPServer issue. We cannot be experts on everyting that has the slightest thing to do with Apache.

If the install instructions for CGIProxy are wrong or not clear enough I suggest you folow James suggestion and drop him an email as suggested Here on his site

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.1.8 32bit & 64bit)
<Apache versions MULTIPE> <PHP versions MULTIPLE> <MySQL Versions MULTIPLE>
<MariaDB versions MULTIPLE> <phpMyAdmin versions MULTIPLE> <MySQL Workbench 8.0.16>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-

Options: ReplyQuote
Re: WAMP64 3.1.7 & CGIProxy 2.2.4 - Odd Redirect
Posted by: SaltyTilty (170.76.170.---)
Date: August 28, 2019 07:52PM

Thank you for your reply. I understand and appreciate your help in this matter. I am at least glad to hear that this isn't an issue with the WAMP install. I'll reach out to James and see if he has any advice.

Options: ReplyQuote
Re: WAMP64 3.1.7 & CGIProxy 2.2.4 - Odd Redirect
Posted by: hfittipaldi (---.virtua.com.br)
Date: August 30, 2019 02:00PM

Hi SaltyTilty, I know this is unrelated, but how do you set up SSL on your localhost? Do you have any link? I'm trying but I'm getting nowhere.

Thanks!

Options: ReplyQuote
Re: WAMP64 3.1.7 & CGIProxy 2.2.4 - Odd Redirect
Posted by: RiggsFolly (Moderator)
Date: August 30, 2019 03:54PM

hfittipaldi

Yes, there is a search function of this site!

But failing that please try this How TO How to Configure WAMPServer to use HTTPS SSL

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.1.8 32bit & 64bit)
<Apache versions MULTIPE> <PHP versions MULTIPLE> <MySQL Versions MULTIPLE>
<MariaDB versions MULTIPLE> <phpMyAdmin versions MULTIPLE> <MySQL Workbench 8.0.16>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-

Options: ReplyQuote


Sorry, only registered users may post in this forum.