wamp3x64 ssl certificate does not exist or is empty
Posted by: matake (---.red-88-23-27.staticip.rima-tde.net)
Date: June 29, 2016 06:01AM


I have installed wamp3 x64
I have installed Win64OpenSSL-1_0_2h

have found some help in the web for configuring apache and ssl and have fallow this steps:

1 open cmd console with admin privileges
2 cd C:\wamp64\bin\apache\apache2.4.17\bin

3 openssl genrsa -aes256 -out private.key 2048
I have this error: The ordinal 968 could not be located in dynamic link library LIBEAY32.dll

I found some help on the web and I have replaced the libeay32.dll the ssleay.dll and openssl.exe from apache bin with the originals copied from Openssl installation folder

Again step 3
openssl genrsa -aes256 -out private.key 2048
Ok ask for passphrase 2 times OK

4 openssl rsa -in private.key -out private.key
5 openssl req -new -x509 -nodes -sha1 -key private.key -out certificate.crt -days 36500 -config C:\wamp64\bin\apache\apache2.4.17\conf\openssl.cnf

Now y have certificate.cert and private.key in apache.../bin

6 I have copied both in apache.../conf/key

7 I have uncoment this in httpd.conf
LoadModule ssl_module modules/mod_ssl.so
Include conf/extra/httpd-ssl.conf
LoadModule socache_shmcb_module modules/mod_socache_shmcb.so

8 uncoment in php.ini

9 In httpd-ssl.conf
<VirtualHost _default_:443>

modify (edit)
DocumentRoot "C:/wamp64/www"
ServerName localhost:443
ServerAdmin admin@mi_site.com
ErrorLog "C:/wamp64/bin/apache/apache2.4.17/logs/ssl_error.log"
TransferLog "C:/wamp64/bin/apache/apache2.4.17/logs/ssl_access.log"

SSLCertificateFile "C:/wamp64/bin/apache/apache2.4.17/conf/key/certificate.cert"
SSLCertificateKeyFile "C:/wamp64/bin/apache/apache2.4.17/conf/key/private.key"

CustomLog CustomLog "C:/wamp64/bin/apache/apache2.4.17/logs/ssl_request.log" ...

10 Try to check if evrithig ok
httpd -t

Have this error:
AH00526: Syntax error on line 144 of C:/wamp64/bin/apache/apache2.4.17/conf/extra/httpd-ssl.conf:
SSLCertificateFile: file 'C:/wamp64/bin/apache/apache2.4.17/conf/key/certificate.cert' does not exist or is empty

Someone know how I can to solve this ? What I does wrong ?

Thank you

Edited 1 time(s). Last edit at 06/29/2016 06:03AM by matake.

Options: ReplyQuote
Re: wamp3x64 ssl certificate does not exist or is empty
Posted by: RiggsFolly (Moderator)
Date: June 29, 2016 11:31AM

Here is my HOWTO, its a little old now but it should still work

How to Configure WAMPServer to use HTTPS SSL

This is not a trivial process. This tutorial will, hopefully, get SSL working for you.
However getting it configured to match your secific requirements once it is working is TOTALLY DOWN TO YOU.

Additional reading for all who travel this road
Remember this is Apache and PHP we are configuring here and not WAMPServer, so it is all documented on the Apache and PHP sites if you get any issues or have any specific requirements.


I have based this tutorial on the creation of a site called www.wamphelpers.dev So whereever you see that name change it to the site name you are trying to secure.

I started by creating a unsecured site, in \wamp\www\wamphelpers

added a Virtual Host for that site, in httpd-vhosts.conf

<VirtualHost *:80>
    DocumentRoot "c:/wamp/www"
    ServerName localhost
    ServerAlias localhost
    <Directory  "c:/wamp/www">
        AllowOverride All
        Require local

<VirtualHost *:80>
    DocumentRoot "c:/wamp/www/wamphelpers"
    ServerName wamphelpers.dev
    ServerAlias www.wamphelpers.dev
    <Directory  "c:/wamp/www/wamphelpers">
        AllowOverride All
        Require local

Added its name to the C:\windows\system32\drivers\etc\hosts wamphelpers.dev www.wamphelpers.dev
::1       wamphelpers.dev www.wamphelpers.dev

Now restart the dnscache as follows from a command windows launched using 'Run as Administrator'

net stop dnscache
net start dnscache

Then created a simple script in \wamp\www\wamphelpers\index.php

    echo 'Hello, this is the WAMPHELPERS.DEV site homepage';

Now restart Apache and make sure that your simple unsecured site is working before continuing

---------- The openssl toolkit. ----------

The openssl.exe, ssleay32.dll and libeay32.dll come with, and are located in, the C:\wamp\bin\apache\apachex.y.z\bin folder
This should be all you need to create your self signed certificate !!

**HOWEVER:** These did not work for me on any of the versions of Apache that I had installed.
I always got this error message.

Where the ordinal number changed depending on the apache version folder I was in.

If you get this error dont worry this is what you need to do.

**install the latest version of the OPENSSL TOOLKIT**

This can be obtained from here

Pick the Latest version of 'Win32 OpenSSLv xxx Light' as this is all you need.

This will download an .exe file which you can run to install this toolkit.

It will ask the following question, I suggest you answer it like this so you dont end up installing something into C:\windows\system32.
Afterall this is a toolkit and it changes reasonably often. Best to keep these things seperate and not make them system global.

openssl install suggestion

Once that is installed ( to whichever folder you specified in the install )you should be ready to start the process of generating keys and certificates!


---------- Generate keys and Certificates. ----------

STEP 1: Generate an RSA Private Key

First we need to create ourselves a certificate.
The normal (paid for) process is to create your certificate and then pass it to a signing authority.
This is why it costs money, as they have to do, due dilligence, to check that you are who you say you are and that site that you will use the certificate on is real and legitimate.

The openssl toolkit is used to generate an RSA Private Key and CSR (Certificate Signing Request) to be used for our Certificate.
The first step is to create your RSA Private Key.
This key is a 1024 bit RSA key which is encrypted using Triple-DES and stored in a PEM format so that it is readable as ASCII text.

Open up a Command window (Dos box) using Run as Administrator
Change Directory to where you installed the OpenSSL Toolkit above.
In my case this is

set openssl_conf=c:\wamp\bin\apache\apache{apache_version}\conf\openssl.cnf
CD c:\wamp\bin\apache\apache{apache_version}\bin

Make a folder for the output to be put in ( to keep the bin folder tidy ) I used website
md wamphelpers

Now enter this command:
openssl genrsa -out wamphelpers\server.key 2048

This should have created a file in the 'wamphelpers' folder called server.key, without a pass phrase key, check it exists.

Step 2: Generate a CSR (Certificate Signing Request)

During the generation of the CSR, you will be prompted for several pieces of information.
These are the X.509 attributes of the certificate.
One of the prompts will be for "Common Name (e.g. server FQDN or YOUR name) []:".
It is important that this field be filled in with the fully qualified domain name of the server to be protected by SSL.
So if the website to be protected will be `[www.wamphelpers.dev]`, then enter `www.wampheplers.dev` at this prompt.

Do not enter anything to the question: A challenge password []:] - Just press Enter.
If you do enter a passphrase here when you come to start Apache with SSL configured Apache will not start and will give this error message :-

*[error] Init: SSLPassPhraseDialog builtin is not supported on Win32*

Basically if you do enter a passphrase Apache is supposed to challenge you for that passphrase each time it starts.
This is obviously not going to make your life any easier but primarily on windows it does not actually work and will
cause Apache to crash when it attempts to ask for the passphrase, with the above error.

The command to generate the CSR is as follows:
openssl req -new -key wamphelpers\server.key -out wamphelpers\server.csr

Example question and answers:
    Country Name (2 letter code) [AU]:GB
    State or Province Name (full name) [Some-State]: Hampshire
    Locality Name (eg, city) []: Portsmouth
    Organization Name (eg, company) [Internet Widgits Pty Ltd]: Wamp Helpers Ltd
    Organizational Unit Name (eg, section) []: Information Technology
    Common Name (e.g. server FQDN or YOUR name) []: www.wamphelpers.dev
    Email Address []: me@wamphelpers.dev

    Please enter the following 'extra' attributes
    to be sent with your certificate request
    A challenge password []: ( leave blank just hit the enter key )
    An optional company name []: ( leave blank just hit the enter key )

Step 3: Generating a Self-Signed Certificate

At this point you will need to generate a self-signed certificate because you either don't plan on having your certificate signed by a CA, or you wish to test
your new SSL implementation while the CA is signing your certificate.

openssl x509 -req -days 365 -in wamphelpers\server.csr -signkey wamphelpers\server.key -out wamphelpers\server.crt

Because we are not getting this certificate signed by a Certificate Authority, this certificate will generate an error in the client browser to the effect that
the signing certificate authority is unknown and not trusted.
This is unavoidable as we are signing the certificate ourselves, but of course the web of trust does not know who we are.
See example later in this document showing how to tell your browser that you actually trust this certificate

Example output:
Loading 'screen' into random state - done
Signature ok
subject=/C=GB/ST=Hampshire/L=Portsmouth/O=WampHelpers Ltd/OU=Information Technology/CN=www.wamphelpers.dev/emailAddress=riggsfolly@wamphelpers.dev
Getting Private key

Step 4: Installing the Private Key and Certificate

Create these 2 directories under the version of Apache you are using.

md c:\wamp\bin\apache\apachex.y.z\conf\ssl.key
md c:\wamp\bin\apache\apachex.y.z\conf\ssl.crt

And copy the file we have just generated into them like so:
copy website\server.crt c:\wamp\bin\apache\apachex.y.z\conf\ssl.crt
copy website\server.key c:\wamp\bin\apache\apachex.y.z\conf\ssl.key

Step 5: Configure Apache to activate SSL

Edit httpd.conf, Check that this line is uncommented
LoadModule ssl_module modules/mod_ssl.so

Remove the comment '#' from this line also
Include conf/extra/httpd-ssl.conf

Then move that line after this block <IfModule ssl_module>.... </IfModule> like so

<IfModule ssl_module>
SSLRandomSeed startup builtin
SSLRandomSeed connect builtin

# Secure (SSL/TLS) connections
Include conf/extra/httpd-ssl.conf

Step 6: Configure PHP to activate SSL

Edit your php.ini ( use the wampmanager menus so you edit the correct one )

Remove the comment ';' from this line

Step 7: Configure your secure sites Virtual Host

Yup for all you Virtual Host nay sayers, now you cannot avoid the process.

Edit "\wamp\bin\apache\apachex.y.z\conf\httpd-ssl.conf"

This file is released by Apache and contains some default file location.
We can leave most of this file as it is, but we need to configure the virtual host in here to match our actual sites location and a few other things so:

find these lines
DocumentRoot "c:/Apache2/htdocs"
ServerName www.example.com:443
ServerAdmin admin@example.com
ErrorLog "c:/Apache2/logs/error.log"
TransferLog "c:/Apache2/logs/access.log"

and change them to
    DocumentRoot "c:/wamp/www/wamphelpers"
    ServerName wamphelpers.dev:443
    ErrorLog "c:/wamp/logs/ssl_error.log"
    TransferLog "c:/wamp/logs/ssl_access.log"

SSLCertificateFile "c:/Apache2/conf/server.crt"

and change to
SSLCertificateFile "c:/wamp/bin/apache/apachex.y.x/conf/ssl.crt/server.crt"

SSLCertificateKeyFile "c:/Apache2/conf/server.key"

and change to
SSLCertificateKeyFile "c:/wamp/bin/apache/apache2.2.26/conf/ssl.key/server.key"

<Directory "c:/Apache2/cgi-bin">
    SSLOptions +StdEnvVars

and change to
<Directory "c:/wamp/www/wamphelpers">
    SSLOptions +StdEnvVars
    Options Indexes FollowSymLinks MultiViews
    AllowOverride All
    Require local

SSLSessionCache        "shmcb:c:/Apache2/logs/ssl_scache(512000)"
SSLSessionCacheTimeout  300

and change it to
SSLSessionCache        "shmcb:c:/wamp/logs/ssl_scache(512000)"
SSLSessionCacheTimeout  300
<Directory "c:/Apache2/cgi-bin">
    SSLOptions +StdEnvVars

and change to
CustomLog "c:/wamp/logs/ssl_request.log" \
          "%t %h %{SSL_PROTOCOL}x %{SSL_CIPHER}x \"%r\" %b"

Basically look through the conf file and any command that is not commented out, but has a reference to a file or folder
should be changed to reference the WAMPServer folder structure and not 'C:/Apache2....'

Now make sure all these files we have changed are saved, and restart Apache using the wampmanager menus.

First test that the unprotected site is still working.

Then try using your new protected site by adding the 'https://' to the front of the domain name
i.e. `[www.wamphelpers.dev]` without the single quotes of course.

If Apache does not restart you have probably spelt something wrong. Test the configs like so :-

Open a command window
cd \wamp\bin\apache\apachex.y.z\bin
httpd -t

This will parse all the config files and should give you a file name and a line number where an error has been found.

Fix it and try again.

First access to your site will generate a message page something like this.
This is using FireFox, others will be slightly different, but the concept it the same.

This is because your certificate is not signed by a trusted authority, DONT PANIC, this is supposed to happen.

Click on, 'I Understand the risk' and that will show you a button saying 'Add Exception'
Press the Add Exception button, after checking that the certificates site details are in fact yours,
and you will not see this message again unless you clear the exception list.

As of Apache v2.2.12 and OpenSSL v0.9.8j it is now possible to secure more than one site per Apache instance.
This tutorial does not cover that process.
See here for more details:


And here

And here

And like I said at the top, now you need to do some reseach on all the options available in the SSL config and make thing work as you want rather than using the default.

(Windows 10 Pro 64bit) (Wampserver 3.2.8 32bit & 64bit) Aestan Tray Menu
<Apache versions MULTIPE> <PHP versions MULTIPLE> <MySQL Versions MULTIPLE>
<MariaDB versions MULTIPLE> <phpMyAdmin versions MULTIPLE> <MySQL Workbench 8.0.23>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-

Edited 1 time(s). Last edit at 10/06/2016 01:24PM by RiggsFolly.

Options: ReplyQuote
Re: wamp3x64 ssl certificate does not exist or is empty
Posted by: matake (---.red-88-23-27.staticip.rima-tde.net)
Date: June 29, 2016 05:41PM

Thank you for answer

"This is not a trivial process" ... smiling smiley ... You are right

Finally I solved mi problem

I have two big errors in mi steps

1 one writing error:
certificate.cert ..... must be certificate.crt
Is for this why httpd go on the error which I have written this post

2. I have forgotten in httpd-ssl.conf to change <Directory "c:/Apache24/cgi-bin"> ... with mi path
This i have find it in your tutorial ( thank you )

Nevertheless when I try to generate key I have had the same error like before
So when I tried genrsa -out private.key 2048 (whit a new clean installed Windows and wamp3 ) i have this error:
The ordinal 968 could not be located in dynamic link library LIBEAY32.dll

This error I have also in the past with wamp2.5

The solution ( if someone have the same error ) is to download the last OpenSSL installer (install it) , copy this files libeay32.dll the ssleay.dll and openssl.exe from installed folder of OpenSSL and paste them in apache ..../bin folder

Thank you for helping

Edited 1 time(s). Last edit at 06/29/2016 05:45PM by matake.

Options: ReplyQuote
Re: wamp3x64 ssl certificate does not exist or is empty
Posted by: ClaudioJunior10 (200.237.96.---)
Date: August 14, 2017 10:30PM

Good Afternoon Friends
I'm using Openssl 1.0 as my certificate and my WampServer is version 2.4.9. My goal is to install the https certificate on localhost, as I perform testing on the localhost environment. Since I want to test an application that works with bar code, you need the https protocol. In the settings, I followed this tutorial: [www.gigasystems.com.br] very similar to the tutotail of the friend RiggsFolly. The installation does not show any errors, I test with the command httpd -t and the answer is Ok, but in Chrome the error presented is NET :: ERR_CERT_COMMON_NAME_INVALID.
Appreciate your attention.

Options: ReplyQuote

Sorry, only registered users may post in this forum.