Phpmyadmin https issue
Posted by: sidj1981 (---.torhost.net)
Date: January 01, 2019 04:11PM

I have installed wamp ver 3.1.4 and getting an issue in using phpmyadmin. The error message is "There is mismatch between HTTPS indicated on the server and client. This can lead to non working phpMyAdmin or a security risk. Please fix your server configuration to indicate HTTPS properly."
I have updated the VC runtimes. There are no errors reports in the Apache, PHP or MySQL log. I am able to log into MYSql using MYSQL workbench though. The PHP ver I am using is 5.6.38.
After entering the username as root without any password, I get the "ERR_CONNECTION_RESET" . I have tried reinstalling WAMP but not seems to work. Appreciate the help of this forum in helping me resolve this issue. Thanks a ton

Options: ReplyQuote
Re: Phpmyadmin https issue
Posted by: RiggsFolly (Moderator)
Date: January 01, 2019 04:44PM

Try using a browser other than Chrome, see if it works with that!

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.1.8 32bit & 64bit)
<Apache versions MULTIPE> <PHP versions MULTIPLE> <MySQL Versions MULTIPLE>
<MariaDB versions MULTIPLE> <phpMyAdmin versions MULTIPLE> <MySQL Workbench 8.0.16>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-

Options: ReplyQuote
Re: Phpmyadmin https issue
Posted by: Otomatic (Moderator)
Date: January 01, 2019 06:17PM

Hi,

> The error message is "There is mismatch between HTTPS indicated on the server and client.

PhpMyAdmin from Wampserver is not launched as HTTPS : 'http://localhost/phpmyadmin/'

It seems that more and more Chrome (Google) wants to behave like a web boss and wants to force the use of https, in the same way that it hijacked the tld ".dev"

Supposedly for our safety, but ultimately to be the Internet dictator.

@RiggsFolly : Happy New Year .... for everyone as well.

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.9 32 bit - Apache 2.4.41 - PHP 7.3.8/7.2.21/7.1.31/7.0.33/5.6.40 - MySQL 5.7.27 - MariaDB 10.3.16
Wampserver 3.1.9 64 bit - Apache 2.4.41 - PHP 7.3.8/7.2.21/7.1.31/7.0.33/5.6.40 - MySQL 5.7.27/8.0.17 - MariaDB 10.3.16
PhPMyadmin 4.9.0.1 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: Phpmyadmin https issue
Posted by: sidj1981 (---.235.201.106.airtelbroadband.in)
Date: January 02, 2019 09:25AM

I have used chrome, IE and firefox. And the result is same. I believe the problem is the "ERR_CONNECTION_RESET" message. I get the same message for my website. To debug, I ran my website without the DB and I get the DB access error. Then I created the schema but there were no tables. and so I get the "missing ci_session table" error. I created the tables and if I access my website, I get the "ERR_CONNECTION_RESET" error. I am using codeigniter in my project.

Options: ReplyQuote
Re: Phpmyadmin https issue
Posted by: Otomatic (Moderator)
Date: January 02, 2019 10:35AM

Hi,

Try to disable php_xdebug and php_opcache zend extensions:

Left-Click tray icon -> PHP -> PHP extensions -> Zend extensions -> php_opcache (To uncheck it)
Left-Click tray icon -> PHP -> PHP extensions -> Zend extensions -> php_xdebug (To uncheck it)

It may also be a problem generated by codeigniter.

And, to know more about your configuration, it is essential to READ (and answer) BEFORE YOU ASK A QUESTION

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.9 32 bit - Apache 2.4.41 - PHP 7.3.8/7.2.21/7.1.31/7.0.33/5.6.40 - MySQL 5.7.27 - MariaDB 10.3.16
Wampserver 3.1.9 64 bit - Apache 2.4.41 - PHP 7.3.8/7.2.21/7.1.31/7.0.33/5.6.40 - MySQL 5.7.27/8.0.17 - MariaDB 10.3.16
PhPMyadmin 4.9.0.1 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: Phpmyadmin https issue
Posted by: sidj1981 (---.torhost.net)
Date: January 05, 2019 05:54PM

Disabled both the extensions but no difference. I read the installation guide and tried the options suggested, but couldnt get my issue resolved. Thanks a ton for your patience and time.

Options: ReplyQuote
Re: Phpmyadmin https issue
Posted by: Otomatic (Moderator)
Date: January 05, 2019 06:12PM

And, to know more about your configuration, it is essential to READ (and answer) BEFORE YOU ASK A QUESTION

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.9 32 bit - Apache 2.4.41 - PHP 7.3.8/7.2.21/7.1.31/7.0.33/5.6.40 - MySQL 5.7.27 - MariaDB 10.3.16
Wampserver 3.1.9 64 bit - Apache 2.4.41 - PHP 7.3.8/7.2.21/7.1.31/7.0.33/5.6.40 - MySQL 5.7.27/8.0.17 - MariaDB 10.3.16
PhPMyadmin 4.9.0.1 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: Phpmyadmin https issue
Posted by: sidj1981 (---.torhost.net)
Date: January 05, 2019 09:34PM

I was able to solve the problem following the solution given in this thread - [forum.wampserver.com]. Its about changing the port. I changed to port 5000 and it works now. Thanks.

Options: ReplyQuote


Sorry, only registered users may post in this forum.