Error 404 localhost in Wampserver 2018
Posted by: Pisco (---.dynamic.dsl.as9105.com)
Date: October 16, 2018 11:31PM

Hi guys, I recently downloaded WAMP. I installed it on my WIN10 and I had lots of problems. The icon is green but I can't connect to my local host. It shows me a white page with the message; HTTP ERROR 404 page not found. To turn the icon green I changed ports in Apache going to Wamp server -> Apache -> httpd.conf using 8080 instead of the default 80.

I also downloaded the last version of Visual C ++ (I have 2015 for x64 and for x86) Shall I delete the old versions of C++? I have 2005, 2012 and 2013 only for x64.
I also stopped Skype that was using the same port as Apache. I changed as well, the port 80 of phpmyadmin, howerver, I have to type on my browser :8080 just after localhost every time I want to connect it. Could anybody please help me out. I am not an IT expert so if anybody knows what should I do, I would appreciate if I could be guided step by step to fix these problems, as the icon is green but I can only connect to PHPmyadmin but in an annoying way. Thanks

Options: ReplyQuote
Re: Error 404 localhost in Wampserver 2018
Posted by: Otomatic (Moderator)
Date: October 17, 2018 09:36AM

Hi,

- 1 - Verify that all VC ++ packages are installed and with the latest versions.
To do this, use the tool:
Checks VC++ packages installed
Do not use a previously loaded tool. Make a new download to make sure you are using the correct version.
To download missing packages, do not rely on Microsoft links, they are not reliable, download packages on http://wampserver.aviatechno.net in section Visual C++ Redistribuable Packages
Do not forget that if you have a 64 bit Windows, you must install both 32 and 64 bit versions of each package.
You must install each package "as an administrator", so right-click the exe file and then run as Administrator.

- 2 - Apply items 03 and 08 of TROUBLESHOOTING TIPS and you are very strongly encouraged to read and check everything.

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.4 32 bit - Apache 2.4.37 - PHP 7.2.12/7.1.24/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.10
Wampserver 3.1.4 64 bit - Apache 2.4.37 - PHP 7.2.12/7.1.24/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.10
PhPMyadmin 4.8.3 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: Error 404 localhost in Wampserver 2018
Posted by: Pisco (---.dynamic.dsl.as9105.com)
Date: October 22, 2018 08:35PM

Hi Otomatic,
Thanks for your answer although I managed to sort it, or at least, WAMP is running so far. My problem now is I can't log in to my WordPress Admin Dashboard. It never has been directly through WAMP. I named my wordpress database 'mysite' but when I click this folder located in the WAMP landing page under 'Your Profject',it shows me this:

message.ERR_CONNECTION_TIMED_OUT

If I try to type on my url - localhost:8080/mysite (this is how I used to log in to WordPress since I installed for the first time. Now I no longer can do it anymore, it shows me this message:

Index of /mysite
Name Last modified Size Description
Parent Directory -
wordpress/ 2013-09-25 00:18 -
Apache/2.4.35 (Win64) PHP/7.2.10 Server at localhost Port 8080

If I click in Parent Dierctory, I go back to WAMP localhost landing page. When I click on WordPress folder, before I could access to it but now shows me this other message:
ERR_CONNECTION_REFUSED and my url change to [localhost]

If I try to type anything on my url like ' localhost:8080/mysite/wp-admin or wp-login.php', is shows me a messages like this:

Not Found
The requested URL /mysite/wp-login.php was not found on this server.
Apache/2.4.35 (Win64) PHP/7.2.10 Server at localhost Port 8080


In order to run WAMP I downloaded the Visual C++ from Microsoft website, following a video tutorial on Youtube. It run well, the only thing I had to do was change the ports of Apache, which can be changed automatically from WAMP- and it gave me the 8080 ports.
Could you please explain me what's going on? What did I do wrong or what I didn't do properly?
Thanks

Options: ReplyQuote
Re: Error 404 localhost in Wampserver 2018
Posted by: Otomatic (Moderator)
Date: October 22, 2018 09:10PM

Hi,

> In order to run WAMP I downloaded the Visual C++ from Microsoft website,
> following a video tutorial on Youtube.

Why go to see a video on Youtube when I gave you the GOOD procedure to follow:
- The tool to check that all packages are installed:
Checks VC++ packages installed
- The link where you will find ALL packages to install:
http://wampserver.aviatechno.net in section Visual C++ Redistribuable Packages

There are times when I wonder why I spend time giving instructions when they are not being followed.

Why do you want to use port 8080 when the port reserved for the http protocol is port 80?
Again, you did not follow the instructions in points 03 and 08 of TROUBLESHOOTING TIPS

It's to be despaired of!

For CMS and WEB applications it is necessary to do as all hosts do, i.e. install them in a VirtualHost and mainly for WordPress.
So, see The need for Virtual Host and Wampserver 3 - Create or add a VirtualHost

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.4 32 bit - Apache 2.4.37 - PHP 7.2.12/7.1.24/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.10
Wampserver 3.1.4 64 bit - Apache 2.4.37 - PHP 7.2.12/7.1.24/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.10
PhPMyadmin 4.8.3 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: Error 404 localhost in Wampserver 2018
Posted by: Pisco (---.dynamic.dsl.as9105.com)
Date: October 24, 2018 09:19AM

Hi,
Apologise for not coming back to you quicker. I appreciate a lot your help.
The reason I tried the Youtube' tutorials was that I was looking some kind of guidance before I decided to seek help in this forum. I just didn't think I would be answered so soon. I'm following your advise: I downloaded the VC++ packages from the link you passed me. I also verified the VC++ packages using the Checks VC++ packages installed tool. It showed me I need the other packages. The downside of this tool is that when the windows pops out I can't closed it at all. The only think I can do is minimise it. I uninstalled WAMP server and the old VC++. I am starting from scratch. I also followed the TROUBLESHOOTING TIPS link you gave me. The only issue on Item 08 is that when I Turn Windows features on or off, I'm not sure if the box I uncheck is the right one. I found one box it says Internet Information Services. It has subfolders boxes that when I unchecked the main one, the others are unchecked automatically. I am still hesitating if I completed right the Item 8:
(uncheck Windows10
The Main instance Web of Internet Information Services (IIS) and All items of the branch : Internet Information Services.
It also says in Item 20b at the end of it: You must install each package "as an administrator", so right-click the exe file and then run as Administrator. I tried to do that but the option it doesn't show up. I just downloaded them but when I tried to follow this step it doesn't appear. What should i do? I should try one by one or there is another way?

Options: ReplyQuote
Re: Error 404 localhost in Wampserver 2018
Posted by: neliomesquita (177.8.81.---)
Date: October 24, 2018 08:09PM

Guys,

I'm desperate. I installed wampserver and a bug is happening and I don't know what to do. When I click the Localhost menu instead of be redirect to wampserver homepage, i got Apache Debian homepage.

When I click the menu phpMyAdmin I got the message 404 eror.

I don´t know what´s going on. Everything is fine and suddenly wampserver start to do that.

Any ideias?

Options: ReplyQuote
Re: Error 404 localhost in Wampserver 2018
Posted by: Otomatic (Moderator)
Date: October 24, 2018 08:48PM

Hi,

READ (and answer) BEFORE YOU ASK A QUESTION

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.4 32 bit - Apache 2.4.37 - PHP 7.2.12/7.1.24/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.10
Wampserver 3.1.4 64 bit - Apache 2.4.37 - PHP 7.2.12/7.1.24/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.10
PhPMyadmin 4.8.3 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: Error 404 localhost in Wampserver 2018
Posted by: Pisco (---.dynamic.dsl.as9105.com)
Date: October 25, 2018 12:37AM

Hi Otomatic,
I downloaded this version: All Visual C++ Redistribuable Packages (x86_x64) (32 & 64bits). I had to install them one by one. There weren't any automatic setup. Some, I couldn't install them. It didn't show me any error only pointed out that another new version was already installed and I had to fix it. Unfortunately, it didn't give any reference so no clue.I deleted all VC++ packages I had before, I would appreciate to get some guidance. I run the Checks VC++ packages installed tool and show me all the packages that the troubleshooting list mention, although I am not sure if I have them all, as some were not accepted. At least I can close the windows.

Options: ReplyQuote


Sorry, only registered users may post in this forum.