wamp64 localhost “Unable to connect”
Posted by: ProPokerUK (---.15-3.cable.virginm.net)
Date: October 28, 2017 04:03AM

Apologies if this is a repeated query; but no solution found in last 4 days.

Windows 10 ... Wamp64 ... needing to create Virtual hosts to practice my HTML/CSS/PHP and Grid Layouts.

Below is what I THINK might be the problem file (wamp64\bin\apache\apache2.4.27\conf\extra\httpd-vhosts.conf) ...

# Virtual Hosts
#
<VirtualHost *:80>
		ServerName localhost
		ServerAlias localhost
		DocumentRoot "${INSTALL_DIR}/www"
		<Directory "${INSTALL_DIR}/www">
				Options +Indexes +FollowSymLinks +MultiViews
				AllowOverride All
				require all granted
		</Directory>
		ErrorLog "logs/localhost-error.log"
		CustomLog "logs/localhost-access.log" common
		LogLevel debug
</VirtualHost>
#
#
<VirtualHost *:80>
   DocumentRoot "c:/wamp64/www/propokeruk"
   ServerName propokeruk
   <Directory "c:/wamp64/www/propokeruk">
	    Options +Indexes +Includes +FollowSymLinks +MultiViews   
		AllowOverride All
		Require local
   </Directory>
   ErrorLog "c:/wamp64/logs/propokeruk-error.log"
   AccessLog "c:/wamp64/logs/propokeruk-access.log" common
   LogLevel debug
</VirtualHost>
#
#
<VirtualHost *:80>
   DocumentRoot "c:/wamp64/www/tester"
   ServerName tester
   <Directory "c:/wamp64/www/tester">
	    Options +Indexes +Includes +FollowSymLinks +MultiViews   
		AllowOverride All
		Require local
   </Directory>
   ErrorLog "c:/wamp64/logs/tester-error.log"
   AccessLog "c:/wamp64/logs/tester-access.log" common
   LogLevel debug
</VirtualHost>
#
not running SKYPE or IIS

Is there anything else I should be looking at ?



Edited 1 time(s). Last edit at 10/28/2017 03:00PM by RiggsFolly.

Options: ReplyQuote
Re: wamp64 localhost “Unable to connect”
Posted by: Otomatic (Moderator)
Date: October 28, 2017 10:33AM

Hi,

Already, the "unable to connect", it would be nice to know exactly how it occurs; in addition the exact and complete message would not be too much.
Then, READ (and answer) BEFORE YOU ASK A QUESTION

VirtualHost was not created with the built-in Wampserver tool. You have modified the original VirtualHost "localhost", modifying it in a bad way, why ?

- What is the contents of the C:\Windows\System32\drivers\etc\hosts file?
- What is the result of:
Right-Click wampmanager tray icon -> Tools -> Show VirtualHost examined by Apache

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.1 32 bit - Apache 2.4.29 - PHP 7.1.11/7.0.25/5.6.32 - MySQL 5.7.20 - MariaDB 10.2.9
Wampserver 3.1.1 64 bit - Apache 2.4.29 - PHP 7.1.11/7.0.25/5.6.32 - MySQL 5.7.20 - MariaDB 10.2.9
PhPMyAdmin 4.7.5 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote


Sorry, only registered users may post in this forum.