Installing Wamp on Windows Server 2012 R2, Icon Orange
Posted by: Jinfiltration (122.11.141.---)
Date: March 23, 2016 07:58AM

Hi,

I'm trying to install Wamp into Widows Server 2012 R2 Version
The icon stuck at orange, it says 1 of 2 services running.

I had uninstalled IIS from Programs and Features.
Photo: [postimg.org]


I had download Wamp Server 3 64bit version.
But my Wamp server 3, I don't see Apache and MySQL at the menu.
Do I need to install them?

Here is the photo of the difference:
Photo: [postimg.org]

Please help, I want to install ownCloud 8 on it.

Options: ReplyQuote
Re: Installing Wamp on Windows Server 2012 R2, Icon Orange
Posted by: Otomatic (Moderator)
Date: March 23, 2016 10:09AM

Hi,

All prerequisites ans how to install Wampserver 3.0.4 are here : Wampserver 3 - All you need to know

The "photo of the difference" shows Right-Click Wampmanager Tray icon, you should use Left-Click !

- Uninstall Wampserver
- Delete install folder
- Apply all prerequisites as mentionned in the link above.
- Install Wampserver 3.0.4 "as an administrator"

------------------------------------------------------------------------------------------------------------
Wampserver 3.2.7 32 bit - Apache 2.4.51 - PHP 8.1.0…5.6.40 - MySQL 5.7.36 - MariaDB 10.5.13/10.6.5
Wampserver 3.2.7 64 bit - Apache 2.4.51 - PHP 8.1.0…5.6.40 - MySQL 5.7.36/8.0.27 - MariaDB 10.5.13/10.6.5
PhPMyadmin 5.1.1 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: Installing Wamp on Windows Server 2012 R2, Icon Orange
Posted by: luk911 (---.broadband.corbina.ru)
Date: October 02, 2021 05:36PM

I have installed the program. But when I click on the icon, nothing happens. The menu does not appear. The icon is lit green

Windows Server 2012 R2 + wampserver 3.2.3 from sourceforge

Options: ReplyQuote
Re: Installing Wamp on Windows Server 2012 R2, Icon Orange
Posted by: Otomatic (Moderator)
Date: October 02, 2021 07:29PM

Hi,

Have you applied the prerequisites and mainly the VC++ packages BEFORE installation?

- Verify that all VC ++ packages are installed and with the latest versions.
To do this, use the tool:
Checks VC++ packages installed
Do not use a previously loaded tool. Make a new download to make sure you are using the correct version.[/u)
To download missing packages, do not rely on Microsoft links, they are not reliable, download packages on http://wampserver.aviatechno.net in section Visual C++ Redistribuable Packages
Do not forget that if you have a 64 bit Windows, you must install both 32 and 64 bit versions of each package.
You must install each package "as an administrator", so right-click the exe file and then run as Administrator.

If all the packages were not installed, you have to uninstall Wampserver then install the missing packages and reinstall Wampserver.

------------------------------------------------------------------------------------------------------------
Wampserver 3.2.7 32 bit - Apache 2.4.51 - PHP 8.1.0…5.6.40 - MySQL 5.7.36 - MariaDB 10.5.13/10.6.5
Wampserver 3.2.7 64 bit - Apache 2.4.51 - PHP 8.1.0…5.6.40 - MySQL 5.7.36/8.0.27 - MariaDB 10.5.13/10.6.5
PhPMyadmin 5.1.1 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: Installing Wamp on Windows Server 2012 R2, Icon Orange
Posted by: malith (123.231.107.---)
Date: November 02, 2021 05:37PM

Verifyed that all VC ++ packages

Install Wampserver correctly but light is orange?

what should I do?

Options: ReplyQuote
Re: Installing Wamp on Windows Server 2012 R2, Icon Orange
Posted by: RiggsFolly (Moderator)
Date: November 02, 2021 06:15PM

This means one of the services has not started, identify which and if you canot work things out for yourself ask a more specific queston.

Start by reading Troubleshooting tips

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.2.5 32bit & 64bit)
<Apache versions MULTIPE> <PHP versions MULTIPLE> <MySQL Versions MULTIPLE>
<MariaDB versions MULTIPLE> <phpMyAdmin versions MULTIPLE> <MySQL Workbench 8.0.23>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-

Options: ReplyQuote
Re: Installing Wamp on Windows Server 2012 R2, Icon Orange
Posted by: malith (123.231.107.---)
Date: November 02, 2021 06:59PM

I use Windows 11

I check these error

Your port 80 is actually used by :

Server: Apache/2.4.46 (Win64) PHP/7.3.21

Cannot install the Apache service, please stop this application and try again.

Press Enter to exit...



***** Test which uses port 80 *****

===== Tested by command netstat filtered on port 80 =====


Test for TCP
Your port 80 is used by a processus with PID = 6672
The processus of PID 6672 is 'httpd.exe' Session: Services
The service of PID 6672 for 'httpd.exe' is 'wampapache64'
This service is from Wampserver - It is correct

Test for TCPv6
Your port 80 is used by a processus with PID = 6672
The processus of PID 6672 is 'httpd.exe' Session: Services
The service of PID 6672 for 'httpd.exe' is 'wampapache64'
This service is from Wampserver - It is correct

===== Tested by attempting to open a socket on port 80 =====

Your port 80 is actually used by :

Server: Apache/2.4.46 (Win64) PHP/7.3.21

--- Do you want to copy the results into Clipboard?
--- Type 'y' to confirm - Press ENTER to continue...

Options: ReplyQuote
Re: Installing Wamp on Windows Server 2012 R2, Icon Orange
Posted by: RiggsFolly (Moderator)
Date: November 02, 2021 07:32PM

Ok so apahce is working,

Please do right click wampmanager -> Toosl-> Create wampserver configuration report

and post the result here, thank you

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.2.5 32bit & 64bit)
<Apache versions MULTIPE> <PHP versions MULTIPLE> <MySQL Versions MULTIPLE>
<MariaDB versions MULTIPLE> <phpMyAdmin versions MULTIPLE> <MySQL Workbench 8.0.23>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-

Options: ReplyQuote
Re: Installing Wamp on Windows Server 2012 R2, Icon Orange
Posted by: malith (123.231.121.---)
Date: November 03, 2021 01:53PM

1635942317
------ Wampserver configuration report
Wed, 03 Nov 2021 12:25:17 +0000
- Windows NT 10.0 build 22000 (Windows 10)
- Windows Charset: Windows-1252
- Wampserver version 3.2.3 - 64bit
- Wampserver install version 3.2.3
- Install directory: c:/wamp64
- Default browser: C:/Program Files (x86)/Internet Explorer/iexplore.exe
- Default text editor: C:/Windows/system32/notepad.exe
- Default log viewer: C:/Windows/system32/notepad.exe
- Apache 2.4.46 - Port 80
- Additional Apache listening ports:
- PHP 7.3.21
- MySQL 5.7.31 Port 3306
MySQL basedir = c:/wamp64/bin/mysql/mysql5.7.31
MySQL datadir = c:/wamp64/bin/mysql/mysql5.7.31/data
- MariaDB 10.4.13 Port 3307
MariaDB basedir = c:/wamp64/bin/mariadb/mariadb10.4.13
MariaDB datadir = c:/wamp64/bin/mariadb/mariadb10.4.13/data
- PHP 5.6.40 for CLI (Internal Wampserver PHP scripts)
- PhpMyAdmin 5.0.2 - Adminer 4.7.7
------ Wampserver configuration ------
AliasSubmenu = off - NotCheckVirtualHost = on
NotCheckDuplicate = off - VirtualHostSubMenu = on
HomepageAtStartup = off - VhostAllLocalIp = off
SupportMySQL = on - SupportMariaDB = on
ShowphmyadMenu = on - ShowadminerMenu = on
NotVerifyPATH = off - HostsLinesLimit = 5000
NotVerifyHosts = off - NotVerifyTLD = off
AutoCleanLogs = on - AutoCleanLogsMax = 1000
AutoCleanLogsMin = 50 - AutoCleanTmp = on
AutoCleanTmpMax = 1000 - CreateSymlink = symlink
BackupHosts = off - TraceProcess = off
------ C:/Windows/system32/drivers/etc/hosts file contents ------
------ Limited to the first 30 lines ------
#
127.0.0.1 localhost
::1 localhost
----------------------------------------------
-- c:/wamp64/bin/apache/apache2.4.46/conf/extra/httpd-vhosts.conf file contents --
------ Limited to the first 40 lines ------
# Virtual Hosts
#
<VirtualHost *:80>
ServerName localhost
ServerAlias localhost
DocumentRoot "${INSTALL_DIR}/www"
<Directory "${INSTALL_DIR}/www/">
Options +Indexes +Includes +FollowSymLinks +MultiViews
AllowOverride All
Require local
</Directory>
</VirtualHost>
----------------------------------------------
--------- wampmanager.ini (Last 4 lines) --------
[Options]
AeTrayMode=64 Bits
AeTrayOldMode=64bit
AeTrayVersion=3.2.3.3
--------------------------------------------------
State of services:
The service 'wampapache64' is started
Service Session : LocalSystem
The service 'wampmysqld64' is NOT started
EXIT error code:1067
Help message for error code 1067 is:The process terminated unexpectedly.
The service 'wampmariadb64' is started
Service Session : LocalSystem
WampServer (Apache, PHP and MySQL) will not function properly if any service
'wampapache64'
'wampmysqld64'
'wampmariadb64'
is not started.
all services BINARY_PATH_NAME are OK
--------------------------------------------------
*** Checking the DNS search order ***
Values of registry keys for
HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\ServiceProvider
are in correct order
--------------------------------------------------
Wampmanager (Aestan Tray Menu) 3.2.3.3 - 64bit
Compiler Visual C++ versions used:
PHP 5.6.40 Compiler => MSVC11 (Visual C++ 2012)
Architecture => x64
is compatible with Apache 2.4.46
PHP 7.3.21 Compiler => MSVC15 (Visual C++ 2017)
Architecture => x64
is compatible with Apache 2.4.46
PHP 7.4.9 Compiler => Visual C++ 2017
Architecture => x64
is compatible with Apache 2.4.46
MySQL Ver 5.7.31 for Win64 on x86_64 (MySQL Community Server (GPL))
MariaDB Ver 10.4.13-MariaDB for Win64 on AMD64 (mariadb.org binary distribution)
Apache 2.4.46 Apache Lounge VS16 Server built: Aug 2 2020 10:21:32
Architecture: 64-bit
--------------------------------------------------
VirtualHost configuration:
Virtual Host: localhost
--------------------------------------------------
***** Check symbolic links *****
All symbolic links are OK
--------------------------------------------------
***** Test which uses port 80 *****
===== Tested by command netstat filtered on port 80 =====
Test for TCP
Your port 80 is used by a processus with PID = 16548
The processus of PID 16548 is 'httpd.exe' Session: Services
The service of PID 16548 for 'httpd.exe' is 'wampapache64'
This service is from Wampserver - It is correct
Test for TCPv6
Your port 80 is used by a processus with PID = 16548
The processus of PID 16548 is 'httpd.exe' Session: Services
The service of PID 16548 for 'httpd.exe' is 'wampapache64'
This service is from Wampserver - It is correct
===== Tested by attempting to open a socket on port 80 =====
Your port 80 is actually used by :
Server: Apache/2.4.46 (Win64) PHP/7.3.21
--------------------------------------------------
***** Test which uses port 3306 *****
===== Tested by command netstat filtered on port 3306 =====
Port 3306 is not found associated with TCP protocol
Port 3306 is not found associated with TCP protocol
--------------------------------------------------
***** Test which uses port 3307 *****
===== Tested by command netstat filtered on port 3307 =====
Test for TCP
Your port 3307 is used by a processus with PID = 17920
The processus of PID 17920 is 'mysqld.exe' Session: Services
The service of PID 17920 for 'mysqld.exe' is 'wampmariadb64'
This service is from Wampserver - It is correct
Test for TCPv6
Your port 3307 is used by a processus with PID = 17920
The processus of PID 17920 is 'mysqld.exe' Session: Services
The service of PID 17920 for 'mysqld.exe' is 'wampmariadb64'
This service is from Wampserver - It is correct
--------------------------------------------------
-------- Apache error log (Last 30 lines) --------
[Tue Nov 02 23:25:21.568084 2021] [mpm_winnt:notice] [pid 12868:tid 724] AH00430: Parent: Child process 840 exited successfully.
[Tue Nov 02 23:25:28.260644 2021] [mpm_winnt:notice] [pid 8224:tid 464] AH00455: Apache/2.4.46 (Win64) PHP/7.3.21 configured -- resuming normal operations
[Tue Nov 02 23:25:28.260644 2021] [mpm_winnt:notice] [pid 8224:tid 464] AH00456: Apache Lounge VS16 Server built: Aug 2 2020 10:21:32
[Tue Nov 02 23:25:28.260644 2021] [core:notice] [pid 8224:tid 464] AH00094: Command line: 'c:\\wamp64\\bin\\apache\\apache2.4.46\\bin\\httpd.exe -d C:/wamp64/bin/apache/apache2.4.46'
[Tue Nov 02 23:25:28.276275 2021] [mpm_winnt:notice] [pid 8224:tid 464] AH00418: Parent: Created child process 8680
[Tue Nov 02 23:25:28.729536 2021] [mpm_winnt:notice] [pid 8680:tid 664] AH00354: Child: Starting 64 worker threads.
[Tue Nov 02 23:27:04.360429 2021] [mpm_winnt:notice] [pid 8224:tid 464] AH00422: Parent: Received shutdown signal -- Shutting down the server.
[Tue Nov 02 23:27:06.376721 2021] [mpm_winnt:notice] [pid 8680:tid 664] AH00364: Child: All worker threads have exited.
[Tue Nov 02 23:27:06.407978 2021] [mpm_winnt:notice] [pid 8224:tid 464] AH00430: Parent: Child process 8680 exited successfully.
[Tue Nov 02 23:27:11.237585 2021] [mpm_winnt:notice] [pid 11240:tid 688] AH00455: Apache/2.4.46 (Win64) PHP/7.3.21 configured -- resuming normal operations
[Tue Nov 02 23:27:11.237585 2021] [mpm_winnt:notice] [pid 11240:tid 688] AH00456: Apache Lounge VS16 Server built: Aug 2 2020 10:21:32
[Tue Nov 02 23:27:11.237585 2021] [core:notice] [pid 11240:tid 688] AH00094: Command line: 'c:\\wamp64\\bin\\apache\\apache2.4.46\\bin\\httpd.exe -d C:/wamp64/bin/apache/apache2.4.46'
[Tue Nov 02 23:27:11.237585 2021] [mpm_winnt:notice] [pid 11240:tid 688] AH00418: Parent: Created child process 3576
[Tue Nov 02 23:27:11.628327 2021] [mpm_winnt:notice] [pid 3576:tid 820] AH00354: Child: Starting 64 worker threads.
[Wed Nov 03 13:39:56.214038 2021] [mpm_winnt:notice] [pid 11240:tid 688] AH00422: Parent: Received shutdown signal -- Shutting down the server.
[Wed Nov 03 13:39:58.246122 2021] [mpm_winnt:notice] [pid 3576:tid 820] AH00364: Child: All worker threads have exited.
[Wed Nov 03 13:39:58.308640 2021] [mpm_winnt:notice] [pid 11240:tid 688] AH00430: Parent: Child process 3576 exited successfully.
[Wed Nov 03 17:53:54.749307 2021] [mpm_winnt:notice] [pid 17780:tid 804] AH00455: Apache/2.4.46 (Win64) PHP/7.3.21 configured -- resuming normal operations
[Wed Nov 03 17:53:54.749307 2021] [mpm_winnt:notice] [pid 17780:tid 804] AH00456: Apache Lounge VS16 Server built: Aug 2 2020 10:21:32
[Wed Nov 03 17:53:54.749307 2021] [core:notice] [pid 17780:tid 804] AH00094: Command line: 'c:\\wamp64\\bin\\apache\\apache2.4.46\\bin\\httpd.exe -d C:/wamp64/bin/apache/apache2.4.46'
[Wed Nov 03 17:53:54.753316 2021] [mpm_winnt:notice] [pid 17780:tid 804] AH00418: Parent: Created child process 19452
[Wed Nov 03 17:53:55.213574 2021] [mpm_winnt:notice] [pid 19452:tid 664] AH00354: Child: Starting 64 worker threads.
[Wed Nov 03 17:54:22.836620 2021] [mpm_winnt:notice] [pid 17780:tid 804] AH00422: Parent: Received shutdown signal -- Shutting down the server.
[Wed Nov 03 17:54:24.853455 2021] [mpm_winnt:notice] [pid 19452:tid 664] AH00364: Child: All worker threads have exited.
[Wed Nov 03 17:54:24.898300 2021] [mpm_winnt:notice] [pid 17780:tid 804] AH00430: Parent: Child process 19452 exited successfully.
[Wed Nov 03 17:54:52.193470 2021] [mpm_winnt:notice] [pid 16548:tid 708] AH00455: Apache/2.4.46 (Win64) PHP/7.3.21 configured -- resuming normal operations
[Wed Nov 03 17:54:52.193470 2021] [mpm_winnt:notice] [pid 16548:tid 708] AH00456: Apache Lounge VS16 Server built: Aug 2 2020 10:21:32
[Wed Nov 03 17:54:52.193470 2021] [core:notice] [pid 16548:tid 708] AH00094: Command line: 'c:\\wamp64\\bin\\apache\\apache2.4.46\\bin\\httpd.exe -d C:/wamp64/bin/apache/apache2.4.46'
[Wed Nov 03 17:54:52.196105 2021] [mpm_winnt:notice] [pid 16548:tid 708] AH00418: Parent: Created child process 8800
[Wed Nov 03 17:54:52.683632 2021] [mpm_winnt:notice] [pid 8800:tid 672] AH00354: Child: Starting 64 worker threads.
--------------------------------------------------
-------- Apache access log (Last 30 lines) --------
- Wampserver trace report -
File created by Wampserver install
::1 - - [02/Nov/2021:21:53:35 +0530] "GET / HTTP/1.1" 200 6032
::1 - - [02/Nov/2021:21:53:35 +0530] "GET /wampthemes/classic/style.css HTTP/1.1" 200 3952
::1 - - [02/Nov/2021:21:53:35 +0530] "GET /wampthemes/classic/img/gifLogo1.gif HTTP/1.1" 200 2681
::1 - - [02/Nov/2021:21:53:35 +0530] "GET /wampthemes/classic/img/pngPlugin.png HTTP/1.1" 200 140
::1 - - [02/Nov/2021:21:53:35 +0530] "GET /wampthemes/classic/img/pngWrench.png HTTP/1.1" 200 741
::1 - - [02/Nov/2021:21:53:35 +0530] "GET /wampthemes/classic/img/pngFolderGo.png HTTP/1.1" 200 694
::1 - - [02/Nov/2021:21:53:35 +0530] "GET /favicon.ico HTTP/1.1" 200 202575
::1 - - [02/Nov/2021:21:53:58 +0530] "GET / HTTP/1.1" 200 6032
::1 - - [02/Nov/2021:21:54:02 +0530] "GET /adminer/ HTTP/1.1" 200 4600
::1 - - [02/Nov/2021:21:54:02 +0530] "GET /adminer/?file=default.css&version=4.7.7 HTTP/1.1" 200 6811
::1 - - [02/Nov/2021:21:54:02 +0530] "GET /adminer/?file=functions.js&version=4.7.7 HTTP/1.1" 200 27515
::1 - - [02/Nov/2021:21:54:04 +0530] "POST /adminer/?script=version HTTP/1.1" 200 -
::1 - - [02/Nov/2021:21:54:04 +0530] "GET /adminer/?file=favicon.ico&version=4.7.7 HTTP/1.1" 200 318
127.0.0.1 - - [02/Nov/2021:22:56:56 +0530] "GET / HTTP/1.1" 200 6032
127.0.0.1 - - [02/Nov/2021:23:03:08 +0530] "GET / HTTP/1.1" 200 6032
::1 - - [03/Nov/2021:08:49:56 +0530] "GET / HTTP/1.1" 200 6032
::1 - - [03/Nov/2021:08:50:56 +0530] "-" 408 -
127.0.0.1 - - [03/Nov/2021:17:55:16 +0530] "GET / HTTP/1.1" 200 6032
--------------------------------------------------
-------- PHP error log (Last 30 lines) --------
- Wampserver trace report -
File created by Wampserver install
--------------------------------------------------
-------- MySQL error log (Last 30 lines) --------
2021-11-03T03:19:46.903380Z 0 [Warning] Can't create test file c:\wamp64\bin\mysql\mysql5.7.31\data\Malith-Induranga-??????.lower-test
2021-11-03T03:19:46.907252Z 0 [Warning] Can't create test file c:\wamp64\bin\mysql\mysql5.7.31\data\Malith-Induranga-??????.lower-test
2021-11-03T03:19:46.907737Z 0 [Warning] Can't create test file c:\wamp64\bin\mysql\mysql5.7.31\data\Malith-Induranga-??????.lower-test
InnoDB: Progress in percent: 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99
2021-11-03T03:19:47.746442Z 0 [ERROR] InnoDB: Cannot open 'c:\wamp64\bin\mysql\mysql5.7.31\data\ib_buffer_pool' for reading: No such file or directory
wampmysqld64: Table 'mysql.plugin' doesn't exist
2021-11-03T03:19:47.747581Z 0 [ERROR] Can't open the mysql.plugin table. Please run mysql_upgrade to create it.
2021-11-03T03:19:47.749220Z 0 [Warning] Gtid table is not ready to be used. Table 'mysql.gtid_executed' cannot be opened.
2021-11-03T03:19:47.752699Z 0 [ERROR] wampmysqld64: Can't create/write to file 'c:\wamp64\bin\mysql\mysql5.7.31\data\Malith-Induranga-??????.pid' (Errcode: 2 - No such file or directory)
2021-11-03T03:19:47.754107Z 0 [ERROR] Can't start server: can't create PID file: No such file or directory
2021-11-03T12:23:54.643205Z 0 [Warning] Can't create test file c:\wamp64\bin\mysql\mysql5.7.31\data\Malith-Induranga-??????.lower-test
2021-11-03T12:23:54.652757Z 0 [Warning] Can't create test file c:\wamp64\bin\mysql\mysql5.7.31\data\Malith-Induranga-??????.lower-test
2021-11-03T12:23:54.654398Z 0 [Warning] Can't create test file c:\wamp64\bin\mysql\mysql5.7.31\data\Malith-Induranga-??????.lower-test
InnoDB: Progress in percent: 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99
2021-11-03T12:23:55.514835Z 0 [ERROR] InnoDB: Cannot open 'c:\wamp64\bin\mysql\mysql5.7.31\data\ib_buffer_pool' for reading: No such file or directory
wampmysqld64: Table 'mysql.plugin' doesn't exist
2021-11-03T12:23:55.516891Z 0 [ERROR] Can't open the mysql.plugin table. Please run mysql_upgrade to create it.
2021-11-03T12:23:55.520175Z 0 [Warning] Gtid table is not ready to be used. Table 'mysql.gtid_executed' cannot be opened.
2021-11-03T12:23:55.527698Z 0 [ERROR] wampmysqld64: Can't create/write to file 'c:\wamp64\bin\mysql\mysql5.7.31\data\Malith-Induranga-??????.pid' (Errcode: 2 - No such file or directory)
2021-11-03T12:23:55.530245Z 0 [ERROR] Can't start server: can't create PID file: No such file or directory
2021-11-03T12:24:52.180227Z 0 [Warning] Can't create test file c:\wamp64\bin\mysql\mysql5.7.31\data\Malith-Induranga-??????.lower-test
2021-11-03T12:24:52.186785Z 0 [Warning] Can't create test file c:\wamp64\bin\mysql\mysql5.7.31\data\Malith-Induranga-??????.lower-test
2021-11-03T12:24:52.187576Z 0 [Warning] Can't create test file c:\wamp64\bin\mysql\mysql5.7.31\data\Malith-Induranga-??????.lower-test
InnoDB: Progress in percent: 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99
2021-11-03T12:24:53.074490Z 0 [ERROR] InnoDB: Cannot open 'c:\wamp64\bin\mysql\mysql5.7.31\data\ib_buffer_pool' for reading: No such file or directory
wampmysqld64: Table 'mysql.plugin' doesn't exist
2021-11-03T12:24:53.078183Z 0 [ERROR] Can't open the mysql.plugin table. Please run mysql_upgrade to create it.
2021-11-03T12:24:53.087608Z 0 [Warning] Gtid table is not ready to be used. Table 'mysql.gtid_executed' cannot be opened.
2021-11-03T12:24:53.105019Z 0 [ERROR] wampmysqld64: Can't create/write to file 'c:\wamp64\bin\mysql\mysql5.7.31\data\Malith-Induranga-??????.pid' (Errcode: 2 - No such file or directory)
2021-11-03T12:24:53.107663Z 0 [ERROR] Can't start server: can't create PID file: No such file or directory
--------------------------------------------------
-------- MariaDB error log (Last 30 lines) --------
2021-11-03 17:54:22 0 [Note] Event Scheduler: Purging the queue. 0 events
2021-11-03 17:54:22 0 [Note] InnoDB: Starting shutdown...
2021-11-03 17:54:22 0 [Note] InnoDB: Dumping buffer pool(s) to c:\wamp64\bin\mariadb\mariadb10.4.13\data\ib_buffer_pool
2021-11-03 17:54:22 0 [Note] InnoDB: Buffer pool(s) dump completed at 211103 17:54:22
2021-11-03 17:54:23 0 [Note] InnoDB: Shutdown completed; log sequence number 61578; transaction id 22
2021-11-03 17:54:23 0 [Note] InnoDB: Removed temporary tablespace data file: "ibtmp1"
2021-11-03 17:54:23 0 [Note] wampmariadb64: Shutdown complete
InnoDB: using atomic writes.
2021-11-03 17:54:52 0 [Note] InnoDB: Mutexes and rw_locks use Windows interlocked functions
2021-11-03 17:54:52 0 [Note] InnoDB: Uses event mutexes
2021-11-03 17:54:52 0 [Note] InnoDB: Compressed tables use zlib 1.2.11
2021-11-03 17:54:52 0 [Note] InnoDB: Number of pools: 1
2021-11-03 17:54:52 0 [Note] InnoDB: Using SSE2 crc32 instructions
2021-11-03 17:54:52 0 [Note] InnoDB: Initializing buffer pool, total size = 256M, instances = 1, chunk size = 128M
2021-11-03 17:54:52 0 [Note] InnoDB: Completed initialization of buffer pool
2021-11-03 17:54:52 0 [Note] InnoDB: 128 out of 128 rollback segments are active.
2021-11-03 17:54:52 0 [Note] InnoDB: Creating shared tablespace for temporary tables
2021-11-03 17:54:52 0 [Note] InnoDB: Setting file '.\ibtmp1' size to 12 MB. Physically writing the file full; Please wait ...
2021-11-03 17:54:52 0 [Note] InnoDB: File '.\ibtmp1' size is now 12 MB.
2021-11-03 17:54:52 0 [Note] InnoDB: Waiting for purge to start
2021-11-03 17:54:52 0 [Note] InnoDB: 10.4.13 started; log sequence number 61578; transaction id 21
2021-11-03 17:54:52 0 [Note] InnoDB: Loading buffer pool(s) from c:\wamp64\bin\mariadb\mariadb10.4.13\data\ib_buffer_pool
2021-11-03 17:54:52 0 [Note] Plugin 'FEEDBACK' is disabled.
2021-11-03 17:54:52 0 [Note] InnoDB: Buffer pool(s) load completed at 211103 17:54:52
2021-11-03 17:54:52 0 [Note] Server socket created on IP: '::'.
2021-11-03 17:54:52 0 [Note] Reading of all Master_info entries succeeded
2021-11-03 17:54:52 0 [Note] Added new Master_info '' to hash table
2021-11-03 17:54:52 0 [Note] wampmariadb64: ready for connections.
Version: '10.4.13-MariaDB' socket: '' port: 3307 mariadb.org binary distribution
--------------------------------------------------

Options: ReplyQuote
Re: Installing Wamp on Windows Server 2012 R2, Icon Orange
Posted by: Otomatic (Moderator)
Date: November 03, 2021 03:10PM

Hi,

You don't have to post the same result six times to find out that the wampmysqla64 service can't start.

> The service 'wampmysqld64' is NOT started
> EXIT error code:1067
> Help message for error code 1067 is:The process terminated unexpectedly.

And the service can't start because one or more of your tables and/or pid are "rogue" and can't be rebuilt.

In this case, what I recommend is not to use MySQL and to use MariaDB instead.

- 1 - Right-Click -> Tools -> Invert default DBMS MySQL <-> MariaDB
wait for end of process even icon is not green
- 2 - Right-Click -> Wamp settings -> Allow MySQL to uncheck it

------------------------------------------------------------------------------------------------------------
Wampserver 3.2.7 32 bit - Apache 2.4.51 - PHP 8.1.0…5.6.40 - MySQL 5.7.36 - MariaDB 10.5.13/10.6.5
Wampserver 3.2.7 64 bit - Apache 2.4.51 - PHP 8.1.0…5.6.40 - MySQL 5.7.36/8.0.27 - MariaDB 10.5.13/10.6.5
PhPMyadmin 5.1.1 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote


Sorry, only registered users may post in this forum.