Cannot load modules/mod_ssl.so into server. The specified module could not be found.
Posted by: cdebel2005 (---.mc.derytele.com)
Date: March 03, 2016 09:49PM

I've this error message in the Event Viewer when i try to start all servers from the systray icon. But i've checked at the folder and files, and both are ok... mod_ssl.so exist, within the modules directory.

"The Apache service named reported the following error:
>>> httpd.exe: Syntax error on line 175 of C:/wamp64/bin/apache/apache2.4.17/conf/httpd.conf: Cannot load modules/mod_ssl.so into server: The specified module could not be found. .". Error ID 3299

Any idea why i'm getting this error?

It run on Windows Server 2008 std 64 bit, it is wamp3 with apache 2.4.17, mysql5.7.9, php 5.6.16 and 7 (but only 5.6.16 seems active), all 64 bits version.

I took a look at c:\wamp64\logs, and there's no error in it.

It worked perfectly on port 80 of this server. It has it's own IP, and IIS is set to NOT listen to all IP but only the IP it should be listening (i'm not talking about the binding, but really IIS on Windows Server 2008 is listening to everything, and we took care of that already).

As soon as i setup the SSL, when it refuse to restart (orange icon).

Our virtual host look like this and we have a listen 443 for this ip of course.

<VirtualHost 10.192.9.14:443>
DocumentRoot "c:/wamp64/www/wordpress"
ServerName adminblog.oudomain.com:443

SSLEngine on
SSLCertificateFile "C:/wamp64/bin/apache/apache2.4.17/conf/ssl.crt/ourdomain.cer"
SSLCertificateKeyFile "C:/wamp64/bin/apache/apache2.4.17/conf/ssl.key/ourdomain.key"

ErrorLog "C:/wamp64/logs/adminblog.ourdomain.com-error_log"
CustomLog "C:/wamp64/logs/adminblog.ourdomain.com-access_log" common

<Directory />
Options Indexes FollowSymLinks Includes ExecCGI
Require all granted
</Directory>

<Directory "c:/wamp64/www/wordpress">
Options Indexes FollowSymLinks MultiViews
AllowOverride None
Order allow,deny
allow from all
</Directory>

DirectoryIndex wp-login.php
</VirtualHost>

I've checked at other logs like MySQL and PHP but i find nothing about this.

Notes:
- Service wampmysqld64 seems to be started, but not wampapache64.
- Skype is not running on this machine
- Did a netstat -ano | findstr ":443" and found nothing about it on This specific IP.
- I tried to restart all services thru the wampmanager with IIS turned off, but the problem still occur.
- Our SSL is not a self-signed, it's a wildcard SSL bought at godaddy.

Thanks for your help

Options: ReplyQuote
Re: Cannot load modules/mod_ssl.so into server. The specified module could not be found.
Posted by: cdebel2005 (---.mc.derytele.com)
Date: March 04, 2016 02:47AM

I went further. I've copied ssleay32.dll & libeay32.dll from php7.0.0 folder to c:\windows\system32.


Once i did that and tried to restart, i had this error:
"The Apache service named reported the following error:
>>> SSLSessionCache: 'shmcb' session cache not supported (known names: ). Maybe you need to load the appropriate socache module (mod_socache_shmcb?). ."

So in httpd.conf i've found this line and uncommented it:
LoadModule socache_shmcb_module modules/mod_socache_shmcb.so

Now the icon is green and everything is ok. I just had to change my wordpress configuration to point to https instead of http, and port 443 instead of port 80. Same for httpd.conf...

Our certificate is also well recognized.

Options: ReplyQuote
Re: Cannot load modules/mod_ssl.so into server. The specified module could not be found.
Posted by: Otomatic (Moderator)
Date: March 04, 2016 09:44AM

Hi,

> 've copied ssleay32.dll & libeay32.dll from php7.0.0 folder to c:\windows\system32.
NO When you change version of PHP, it will be these old dll that will be taken into account not those of the new version of PHP.

> <Directory "c:/wamp64/www/wordpress">
> Options Indexes FollowSymLinks MultiViews
> AllowOverride None
> Order allow,deny
> allow from all
> </Directory>
It is Apache 2.4, not Apache 2.2.

Before trying to use ssl, it is imperative that everything works correctly and without any errors: READ BEFORE YOU ASK A QUESTION

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.9 32 bit - Apache 2.4.39 - PHP 7.3.5/7.2.18/7.1.29/7.0.33/5.6.40 - MySQL 5.7.26 - MariaDB 10.3.15
Wampserver 3.1.9 64 bit - Apache 2.4.39 - PHP 7.3.5/7.2.18/7.1.29/7.0.33/5.6.40 - MySQL 5.7.26/8.0.16 - MariaDB 10.3.15
PhPMyadmin 4.8.5 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: Cannot load modules/mod_ssl.so into server. The specified module could not be found.
Posted by: anamuricel (---.dynamic.dsl.as9105.com)
Date: February 14, 2017 10:40AM

Hi Folks

I wanted to spare you all the agony that i have been going through.

I spent a day struggling with the error Cannot load modules/mod_ssl.so into server. The specified module could not be found - or Cannot load modules/mod_ssl.so into server. operating system error - or Cannot load modules/mod_ssl.so into server. The specified module cannot be loaded --- take your pick of error messages but they all are basically unhelpful and dont really explain what is happening....


If you are installing WAMP Server X64 version 3 in the Windows Server 2012 x64 environment then you need to do the following

1. Install all the VCREdist C++ runtimes from Microsoft first - i installed 2008, 2010, 2012 and 2015 both x86 and x64 versions (better to be safe than sorry) then --- Install Wamp Server x64 v3 on the server as normal

2. Get the OpenSSL x64 version 1.02 (NOT ANY OTHERS) light package from the slproweb.com DONT install the 32 bit versions or the 1.1D versions NONE OF THEM WILL WORK --- it must be v1.02 x64

3. Select the default option install the dlls into the BIN directory in Windows when you run the openssl installer

4. Generate your certificate and key as per usual (see this awesome youtube video by Ankit [www.youtube.com] for all that follows)

5. Make the changes to httpd.conf to uncomment the mod_ssl line and the socache_shmbc lines and include the httpd-ssl file

6. Make changes to the httpd-ssl.conf in the extras folder

(NOTE be careful to change ALL of the references to c:/apache24 in the conf file , you need to change them to c:/wamp --- Ankits video doesnt mention this but it is important otherwise wamp will not start)

8. Restart WAMP and VOILA you will now see that Apache will restart just fine and your SSL settings will be working

I wasted so much time installing all the wrong versions of SSL , and copying DLL files all over the place, none of that stuff will work , PLUS the SSleay32.dll and Libseay32.dll that come with wamp 3 x64 are useless and will not work.

Hope that this helps you guys out.

Options: ReplyQuote
Re: Cannot load modules/mod_ssl.so into server. The specified module could not be found.
Posted by: Alex Khimich (31.128.85.---)
Date: May 12, 2019 03:18PM

This error message is not quite descriptive, actually nothing is wrong with "so" file.

To be a little more short about previous life-saving answer:

1. Download exactly Win64OpenSSL-1_0_2r.exe (Newer 1.1 versions don't work)
2. Install it somewhere with the option about local bin folder
3. Copy contents of its bin folder to Apache's bin folder
4. Restart Apache service.
5. If Apache didn't start, look in Windows event log, error message already should be different about other minor problem. Better run it from command line like "httpd.exe -k start" in cli these errors are more verbose.
6. If you still keep getting error, try double click and run openssl.exe dicertly, it may need some dlls like "MSVCR120.dll" to run. These can be found and copied into same bin directory.

Works for Apache 2.4.39 on Windows Server 2008 R1 (and SP1) x64 EN as of May 2019.



Edited 4 time(s). Last edit at 05/20/2019 11:50PM by Alex Khimich.

Options: ReplyQuote


Sorry, only registered users may post in this forum.