not accessible over LAN
Posted by: tripplec (41.77.12.---)
Date: July 30, 2015 12:05PM

I am trying to set up Wamp on a network, i have managed to install it on 1 desktop and i have hosted some systems which i want to be accessed over the LAN

The problem is i am not able to access it from other machines, but locally i am able to do that using the machines ip address

snapshot of the httpd.conf

#
#ServerName www.example.com:80
ServerName 172.31.9.251:8081
#
# Deny access to the entirety of your server's filesystem. You must
# explicitly permit access to web content directories in other
# <Directory> blocks below.
#
<Directory />
Options FollowSymLinks
AllowOverride None
Order allow,deny
Allow from all
#Require all denied
</Directory>

i don't know what to do now.. please help
I am using Apache 2.3.14, and the WaMP ICON is green



Edited 1 time(s). Last edit at 07/30/2015 12:08PM by tripplec.

Options: ReplyQuote
Re: not accessible over LAN
Posted by: RiggsFolly (---.as43234.net)
Date: July 30, 2015 01:32PM

Change this
<Directory />
Options FollowSymLinks
AllowOverride None
Order allow,deny
Allow from all
#Require all denied
</Directory>

back to
<Directory />
   Options FollowSymLinks
   AllowOverride None
   Order Deny,Allow
   Deny from all
</Directory>


You have 2 options to allow access

1. Using the wampmanager menus do "Put Online" this will change the httpd.conf and set "Allow from all"

Thats a bit global, so you may be better to do this instead :

2. Find the section of httpd.conf that starts

#   onlineoffline tag - don't remove
    Order Deny,Allow
    Deny from all
    Allow from localhost 127.0.0.1

And change it to add the ip addresses, or ranges or ip addresses that you LAN users are using
#   onlineoffline tag - don't remove
    Order Deny,Allow
    Deny from all
    Allow from localhost 127.0.0.1
    Allow from 192.168.1                               <-- see note

Note: Use the first 3 quartiles of the lan subnet and every ip address starting 192.168.1 will be allowed access.
You can add as many "Allow from ?.?.?" as you may need to use


Question: What version of WAMPServer are you using? Just double click the wampmanager icon in the system try and a dialog will tell you the version number.

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.2.0 32bit & 64bit)
<Apache versions MULTIPE> <PHP versions MULTIPLE> <MySQL Versions MULTIPLE>
<MariaDB versions MULTIPLE> <phpMyAdmin versions MULTIPLE> <MySQL Workbench 8.0.19>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-

Options: ReplyQuote
Re: not accessible over LAN
Posted by: tripplec (41.77.12.---)
Date: July 30, 2015 02:07PM

Hi RiggsFolly

I have reverted the changes, however i cant find this section in my WAMPs httpd.conf
# onlineoffline tag - don't remove
Order Deny,Allow
Deny from all
Allow from localhost 127.0.0.1

I am using WAMPServer Version 2.3

Thanks

Options: ReplyQuote
Re: not accessible over LAN
Posted by: RiggsFolly (---.as43234.net)
Date: July 30, 2015 03:09PM

Hi

Then you or someone has done some serious messing with the httpd.conf file.


Post you complete httpd.conf file, or send me a Private message if you dont want it to be seen by everyone

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.2.0 32bit & 64bit)
<Apache versions MULTIPE> <PHP versions MULTIPLE> <MySQL Versions MULTIPLE>
<MariaDB versions MULTIPLE> <phpMyAdmin versions MULTIPLE> <MySQL Workbench 8.0.19>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-

Options: ReplyQuote
Re: not accessible over LAN
Posted by: RiggsFolly (---.as43234.net)
Date: July 30, 2015 04:10PM

Yes someone has made MAJOR changes to the httpd.conf file.

Not least of which is that you are using FASTCGI for your PHP environment.

This was the section I was looking for

DocumentRoot "c:/wamp/www/"
<Directory "c:/wamp/www/">
Options Indexes FollowSymLinks ExecCGI
Order allow,deny
Allow from all
AllowOverride All
</Directory>


But this appears to be set to "Allow from all" so it should be usable from anywhere.


I would be tempted to change this line
Listen 172.31.9.251:8081

to
Listen 0.0.0.0:80
Listen [::0]:80

So that it would listen on any ipaddress rather than just 172.31.9.251 It cannot do any harm

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.2.0 32bit & 64bit)
<Apache versions MULTIPE> <PHP versions MULTIPLE> <MySQL Versions MULTIPLE>
<MariaDB versions MULTIPLE> <phpMyAdmin versions MULTIPLE> <MySQL Workbench 8.0.19>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-

Options: ReplyQuote
Re: not accessible over LAN
Posted by: tripplec (41.77.12.---)
Date: July 30, 2015 04:22PM

If i add these lines

Listen 0.0.0.0:80
Listen [::0]:80

My Wamp server shows an Amber icon and Not the green icon

I tried removing the Listen [::0]:80

The wamps server icon becomes green, but still i cant access the Wamp page from any other machine

Options: ReplyQuote


Sorry, only registered users may post in this forum.