WAMP 2.4 - PC is running very slow
Posted by: nika (---.customers.adc.am)
Date: September 26, 2013 12:33PM

After installig Wamserver 2.4, the PC stars wark to slow. mysqld.exe memory usage is too big.

Options: ReplyQuote
Re: WAMP 2.4 - PC is running very slow
Posted by: RiggsFolly (---.as13285.net)
Date: September 27, 2013 11:53AM

I see what you mean, mysqld does grab a lot more memory that previous versions.


Strange as it may seem I reduced the memory usage by uncommenting some of the INNODB setting in the my.ini
( I guess the defaults are larger that the settings in the ini file )

Be careful,

innodb_additional_mem_pool_size - is deprecated and gives a warning in the log
innodb_log_arch_dir - is no longer a valid parameter

There is only one way to get mysqld's memory footprint reduced and that will be to hit the books/web and do some research on what paramters control memory size, and play with them until you reduce the size bit by bit while checking you dont damage the functionality.


EDIT:

I just found a magic parameter that reduced memory usage from 400,000+ kb down to 105,000kb

Add this parameter to your my.ini

table_definition_cache = 400


400 is the minimum allowed but I guess that default is a lot higher.


You had better check that you site still runs well as this effects MYISAM file and if you use a LOT it may need to be higher.

I changed mine to 800 and now using 151,000 kb of memory.


PS. I also saw something about MySQL5.6.x being incompatible with XP, so if you are an XP user you may want to check that out on the MySQL website



Edited 2 time(s). Last edit at 09/27/2013 12:12PM by RiggsFolly.

Options: ReplyQuote
Re: WAMP 2.4 - PC is running very slow
Posted by: Otomatic (Moderator)
Date: September 27, 2013 04:45PM

Hi,

Another way to speed up connections to MySQL is to choose "127.0.0.1" in place of "localhost" as host for MySQL.

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.9 32 bit - Apache 2.4.41 - PHP 7.3.9/7.2.22/7.1.32/7.0.33/5.6.40 - MySQL 5.7.27 - MariaDB 10.4.7
Wampserver 3.1.9 64 bit - Apache 2.4.41 - PHP 7.3.9/7.2.22/7.1.32/7.0.33/5.6.40 - MySQL 5.7.27/8.0.17 - MariaDB 10.4.7
PhPMyadmin 4.9.0.1 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: WAMP 2.4 - PC is running very slow
Posted by: nika (---.customers.adc.am)
Date: September 30, 2013 02:03PM

I added table_definition_cache = 400, and it decreased the memery about a half.



Edited 2 time(s). Last edit at 09/30/2013 02:03PM by nika.

Options: ReplyQuote
Re: WAMP 2.4 - PC is running very slow
Posted by: RiggsFolly (---.ppp.as43234.net)
Date: September 30, 2013 02:19PM

So thats a good thing, right?

Options: ReplyQuote


Sorry, only registered users may post in this forum.