Wampserver isn't working, localhost not working. Urgent help!
Posted by: Priyashini (202.12.94.---)
Date: December 13, 2012 06:46AM

First of all, sorry that my post is very wordy. I have listed every detail so that my problem can be fixed asap.

I downloaded wampserver installation pkg from the wampserver.com/en site. I right-clicked it and 'run as administrator' to download the wampserver.

I followed all the default settings in the setup wizard. Didn't change anything. I only accepted the terms of license and agreement. While installation, it prompt "Firefox has been detected on your computer. Would you like to use it as the default browser with Wampserver 2?" So i clicked 'Yes'. For the php mail parameters, I went with the default one as well.

Once the installation completed, i clicked 'start wampserver'. And the icon is 'orange', it shows server offline. I clicked 'Put Online' and the icon is still orange but the server is online. My Apache service is running. I tested the port 80 just in case, and it states 'Your port 80 is run by Server Apache/2.2.22<win 32> PHP/5.4.3". MySQL service states 'Start/Resume Service.'

I also tried opening localhost and the 'IIS 7' logo is shown. However, i have already turned IIS feature off in my pc --- Control Panel -> Uninstall a Program --> Turn Windows features on or off --> Unchecked 'IIS'.

When trying to open phpmyadmin, it says "Access denied'. MySQL said: Documentation
#1045 - Access denied for user 'root'@'localhost' (using password: NO). phpMyAdmin tried to connect to the MySQL server, and the server rejected the connection. You should check the host, username and password in your configuration and make sure that they correspond to the information given by the administrator of the MySQL server."

I also opened my hosts file to check and this is what i see in the hosts file: localhost localhost localhost localhost localhost

Is there something wrong with my host file? Do i have to add smth? Or is there anything else wrong? I need your help pls. It's really urgent. Thanks.

Options: ReplyQuote

Sorry, only registered users may post in this forum.