Can't get my server accessible from outside
Posted by: dan40 (
Date: March 25, 2023 10:07PM

I just set up a virtual server for Wamp, running on 192.168.0.xx and I CAN get to it from my other computer, but only after opening an Incoming Connection for 80 and 443 on my firewall. However, I would like to be able to open this new server on port 80 for the world to see, but everything is 'localhost' this and 'localhost' that, and doesn't specify (unless I'm missing it) how to access it as a normal web page, eg. []. I already have an IIS server hosting some of my online sites that I would eventually like to migrate over to my Wamp server, but if I'm having this much trouble with Wamp and there is so much documentation to go through I get confused and need to take a break. If someone could direct me to some documentation that explains in the simplest of details how to get my server to go to my website, then that would really help.

I have a unique environment though. Two virtual machines, one hosting IIS and this new Wamp with Apache, and I'd like for it to be accessible on the Internet while having the IIS machine be accessible as it is now. I've created a Joomla site and configured it that I can get to on the local IP, as mentioned above, at 192.168.0.xx so no trouble there. Can I have my Wamp server running on the same IP and network segment as my IIS machine? Just have 1 Joomla site on the new server? If I can get that working then I'll be able to migrate the rest of my stuff over to the Wamp server. I can export my databases using PHPmyAdmin, and websites I can simply copy from one location to the other.

I have set up port forwarding on my router, and port 80 and 443 (pending SSL install) are open. So far Wamp is very stable on Windows Server 2019, and I have looked at the httpd.conf etc files but not sure how to do virtual hosts and so forth.

Thanks to anyone who can help point me in the right direction.

Options: ReplyQuote
Re: Can't get my server accessible from outside
Posted by: dan40 (
Date: March 26, 2023 01:45AM

I figured out what my problem was! The DEFAULT WEBSITE on IIS was enabled. As soon as I disabled that, and set my router on port 80 to the 192.168.0.x address, it worked just fine!

Options: ReplyQuote

Sorry, only registered users may post in this forum.