20+ Firefox processes running after WAMP install?
Posted by: xl97 (---.wi.rr.com)
Date: October 11, 2022 04:02PM

I am noob to WAMP server.

I just downloaded and installed WAMP Server 3.2.6.

During the install I chose Firefox and Notepadd++ as my choices.

After install is complete.. my PC is running very slow.. and I noticed roughly 20 or Firefox processes now running in task manager. This was after a fresh reboot as well and WAMP server not even running?

Before the install.. the only number of Firefox processes running would match the tabs I had open?

How can I fix this?

Thanks

Options: ReplyQuote
Re: 20+ Firefox processes running after WAMP install?
Posted by: Otomatic (Moderator)
Date: October 11, 2022 04:44PM

This is not due to the installation of Wampserver.

The Wampserver 3.2.6 installer file, where did you download it ?

Is it digitally signed ? Under which name ?

------------------------------------------------------------------------------------------------------------
Wampserver 3.3.0 32 bit - Apache 2.4.54.2 - PHP 8.2.0…5.6.40 - MySQL 5.7.39 - MariaDB 10.5.13/10.6.5
Wampserver 3.3.0 64 bit - Apache 2.4.54.2 - PHP 8.2.0…5.6.40 - MySQL 5.7.39/8.0.30 - MariaDB 10.5.17/10.9.2
PhPMyadmin 5.2.0 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: 20+ Firefox processes running after WAMP install?
Posted by: xl97 (---.wi.rr.com)
Date: October 11, 2022 05:17PM

Odd.. as that is the only major change/install on my PC as of lately. (And since it asked if I want to use another browser I did select Firefox/Notepad++)


File name:
wampserver3.2.6_x64.exe

I -believe I downloaded it from either:

[www.wampserver.com]

or

[wampserver.aviatechno.net] (as I was first looking to do an update from an old v2.4 install)

Right clicking on .exe

Digital Sig -

Dominique Otello
sha256
Sunday March 6th 2022



Edited 1 time(s). Last edit at 10/11/2022 05:29PM by xl97.

Options: ReplyQuote
Re: 20+ Firefox processes running after WAMP install?
Posted by: Otomatic (Moderator)
Date: October 11, 2022 07:46PM

Sorry, but the installation of Wampserver does not launch any hidden process whatsoever.
There is just the creation of three services, the first one via httpd.exe of the installed Apache version, the second via mysqld.exe of the installed mysql version, the third via mysqld.exe of the installed MariaDB version.

Once the services are installed, the creation processes are stopped and no other process is started by the default browser.

Currently with Wampserver running and two tabs in Firefox, I have 10 Firefox processes with between 0.1% and 1.2% CPU usage.

You have to look at what these extra Firefox processes are.

I can't tell you anything else.

------------------------------------------------------------------------------------------------------------
Wampserver 3.3.0 32 bit - Apache 2.4.54.2 - PHP 8.2.0…5.6.40 - MySQL 5.7.39 - MariaDB 10.5.13/10.6.5
Wampserver 3.3.0 64 bit - Apache 2.4.54.2 - PHP 8.2.0…5.6.40 - MySQL 5.7.39/8.0.30 - MariaDB 10.5.17/10.9.2
PhPMyadmin 5.2.0 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: 20+ Firefox processes running after WAMP install?
Posted by: xl97 (---.wi.rr.com)
Date: October 12, 2022 07:01AM

OK, thanks.

My last hurdle is trying to get back my old mysql tables/data, from my backed up (old) wamp directory.

New version installed under wamp64.

I searched, and read to just copy/paste the old wamp/bin/mysql/mysql5.6.12

to:

wamp64/bin/mysql/mysql5.6.12

and then select that version after restarting.

I tried that and it never fully started all 3 services again. I could also never 'un-select' it and go back to the default version (an error/window pop-up would say something about service wasnt started so cant change?)


so I had to re-install 3.2.6 to get a basic/default version working again. (I have added some of my old project files, made my normal php.ini edits, added a couple virtual hosts now (which is new to me?)...etc.. )

so I'm hoping to -not- have to get stuck in that loop again?

This PC runs Windows 7 for some background info,

To clarify, I do not care about running any older versions of MySQL.. that was just to be able to get into PHPMyAdmin and export things to load back in the newer/default MySQL version.


Any alternate ways to get some of my old databases/tables/data imported into the new WAMP install?

Thanks!

Options: ReplyQuote
Re: 20+ Firefox processes running after WAMP install?
Posted by: Otomatic (Moderator)
Date: October 12, 2022 09:11AM

Hi,

> This PC runs Windows 7…
Windows 7 is obsolete and is not supported since January 2020
It is well indicated, during the installation of Wampserver under Windows 7 :
Installation under Windows 7 sp1 is allowed
Without guarantee of correct installation.
Without guarantee of correct operation.
Windows 7 is obsolete and is no longer supported since January 2020


Important Reminder: The transfer of databases between different versions of MySQL or MariaDB should be performed by EXPORT / IMPORT of SQL files using phpMyAdmin or a similiar tools of your choice. Do not copy the data folder between different versions of MYSQL or MariaDB. Databases from different versions of MYSQL or MariaDB are VERY unlikely to be compatible!

In order for a copy of a MySQL data folder to have any chance of success, several criteria are imperative:
- Exactly the same versions of MySQL
- Both versions in 32bit or both versions in 64bit

There is no MySQL 5.6.12 version at 'https://wampserver.aviatechno.net' but there is at Sourceforge:
- 5.6.12 32bit : [sourceforge.net]
which was the version used in Wampserver 2.4

You have to install this addons on your Wampserver 3.2.6 32bit version, switch to this MySQL 5.6.12 version, check that it works:
- Access to the MySQL console
- Access to PhpMyAdmin (Not sure if PhpMyAdmin 5.2.0 works with this version of MySQL)
both with root user and blank password.
- Quit Wampserver
- Edit the my.ini file of MySQL 5.6.12
- Replace it:
;Path to data directory
datadir="C:/wamp/bin/mysql/mysql5.6.12/data"
by
;Path to data directory
;datadir="C:/wamp/bin/mysql/mysql5.6.12/data"
datadir="C:/oldfolder/mysql5.6.12/data"

------------------------------------------------------------------------------------------------------------
Wampserver 3.3.0 32 bit - Apache 2.4.54.2 - PHP 8.2.0…5.6.40 - MySQL 5.7.39 - MariaDB 10.5.13/10.6.5
Wampserver 3.3.0 64 bit - Apache 2.4.54.2 - PHP 8.2.0…5.6.40 - MySQL 5.7.39/8.0.30 - MariaDB 10.5.17/10.9.2
PhPMyadmin 5.2.0 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote


Sorry, only registered users may post in this forum.