PhpMyAdmin 5.1.1 error- compatibility with php v.8.1.0 and 8.1.1
Posted by: Dragos (---.workpage.ro)
Date: January 12, 2022 05:42PM

When i try to change php version in one of the 2 php versions (8.1.0 and 8.1.1) the following error is displayed


PhpMyAdmin 5.1.1 not compatible with PHP 8.1.0
You must use a version of PhpMyAdmin from 5.1.2 to 5.1.2

Options: ReplyQuote
Re: PhpMyAdmin 5.1.1 error- compatibility with php v.8.1.0 and 8.1.1
Posted by: RiggsFolly (Moderator)
Date: January 12, 2022 06:00PM

That is right. As yet phpMyAdmin has not released a version of itself that is compatible with PHP8.1.

Please remember, if you want to be at the breeding edge of technology, sometimes you have to waut for the other people to catch up.

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.2.5 32bit & 64bit)
<Apache versions MULTIPE> <PHP versions MULTIPLE> <MySQL Versions MULTIPLE>
<MariaDB versions MULTIPLE> <phpMyAdmin versions MULTIPLE> <MySQL Workbench 8.0.23>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-

Options: ReplyQuote
Re: PhpMyAdmin 5.1.1 error- compatibility with php v.8.1.0 and 8.1.1
Posted by: Otomatic (Moderator)
Date: January 13, 2022 12:27PM

Hi,

With Wampserver 3.2.8 (in the course of finalization), it will be possible to use the Apache external module fcgid_module and thus to be able to use different PHP versions for the VirtualHost and the Alias.

It will be possible to test a local site under PHP 8.1.1 but to launch PhpMyAdmin 5.1.1 under PHP 7.4.27 without compatibility problem.

Of course, provided that the addons of the versions of PHP were installed beforehand on Wampserver.

------------------------------------------------------------------------------------------------------------
Wampserver 3.2.8 32 bit - Apache 2.4.52 - PHP 8.1.2…5.6.40 - MySQL 5.7.37 - MariaDB 10.5.13/10.6.5
Wampserver 3.2.8 64 bit - Apache 2.4.52 - PHP 8.1.2…5.6.40 - MySQL 5.7.37/8.0.28 - MariaDB 10.5.13/10.6.5
PhPMyadmin 5.1.2 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: PhpMyAdmin 5.1.1 error- compatibility with php v.8.1.0 and 8.1.1
Posted by: Otomatic (Moderator)
Date: January 15, 2022 10:20AM

Hi,

I already explained how, with Apache 2.4.52fcgi, to use another version of PHP than the default one of Wampserver for VirtualHost.

See : [forum.wampserver.com]

For Alias, it's a little bit different.
Let's suppose that we want to launch PhpMyAdmin 5.1.1 with PHP 7.4.27 while the PHP version of Wampserver is 8.1.1.
The alias must be modified as follows:
Alias /phpmyadmin "${INSTALL_DIR}/apps/phpmyadmin5.1.1/"
<IfModule fcgid_module>
  Define FCGIPHPVERSION "7.4.27"
  FcgidInitialEnv PHPRC ${PHPROOT}${FCGIPHPVERSION}
</IfModule>
<Directory "${INSTALL_DIR}/apps/phpmyadmin5.1.1/">
  Options +Indexes +FollowSymLinks +MultiViews
  AllowOverride all
  Require local
  <IfModule fcgid_module>
    <Files ~ "\.php$">
      Options +Indexes +Includes +FollowSymLinks +MultiViews +ExecCGI
      AddHandler fcgid-script .php
      FcgidWrapper "${PHPROOT}${FCGIPHPVERSION}/php-cgi.exe" .php
    </Files>
  </IfModule>

# To import big file you can increase values
  php_admin_value upload_max_filesize 128M
  php_admin_value post_max_size 128M
  php_admin_value max_execution_time 360
  php_admin_value max_input_time 360
</Directory>

------------------------------------------------------------------------------------------------------------
Wampserver 3.2.8 32 bit - Apache 2.4.52 - PHP 8.1.2…5.6.40 - MySQL 5.7.37 - MariaDB 10.5.13/10.6.5
Wampserver 3.2.8 64 bit - Apache 2.4.52 - PHP 8.1.2…5.6.40 - MySQL 5.7.37/8.0.28 - MariaDB 10.5.13/10.6.5
PhPMyadmin 5.1.2 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: PhpMyAdmin 5.1.1 error- compatibility with php v.8.1.0 and 8.1.1
Posted by: Dragos (---.workpage.ro)
Date: January 15, 2022 10:47AM

Thank you very much sir.

===========================
thank you,
Dragos
===========================
I use:
windows 10 x64 bit
wampserver 3.2.7
php 7.4.27
mysql 8.0.27
phpmyadmin 5.1.1/4.9.7
apache 2.4.51

Options: ReplyQuote
Re: PhpMyAdmin 5.1.1 error- compatibility with php v.8.1.0 and 8.1.1
Posted by: Otomatic (Moderator)
Date: January 15, 2022 11:52AM

Hi,

With Wampserver 3.2.7, there will always be the warning message:

PhpMyAdmin 5.1.1 not compatible with PHP 8.1.0

but PhpMyAdmin 5.1.1 will be launched under PHP 7.4.27.

The management of this message if PhpMyAdmin is in fcgi mode will be effective with Wampserver 3.2.8.

------------------------------------------------------------------------------------------------------------
Wampserver 3.2.8 32 bit - Apache 2.4.52 - PHP 8.1.2…5.6.40 - MySQL 5.7.37 - MariaDB 10.5.13/10.6.5
Wampserver 3.2.8 64 bit - Apache 2.4.52 - PHP 8.1.2…5.6.40 - MySQL 5.7.37/8.0.28 - MariaDB 10.5.13/10.6.5
PhPMyadmin 5.1.2 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote


Sorry, only registered users may post in this forum.