Eparse error - PHP 8.1.0
Posted by: mskocik (---.cust.nbox.cz)
Date: December 03, 2021 03:06PM

Hi, I got the same error - it was related to (probably outdated) phpMyAdmin 4.9.2. When I removed it from apps and alias and repaired wampserver.ini, it started to work correctly.

I am just mentioning it for anybody else, who could have the same or similar issue.



Edited 1 time(s). Last edit at 12/03/2021 03:33PM by Otomatic.

Re: Eparse error - PHP 8.1.0
Posted by: Otomatic (Moderator)
Date: December 03, 2021 03:36PM

Hi,

Please don't interfere in a conversation, even if you think the topic is right.

Please explain clearly what exactly your problem is and do so after reading and responding to:
READ (and answer) BEFORE YOU ASK A QUESTION

------------------------------------------------------------------------------------------------------------
Wampserver 3.2.9 32 bit - Apache 2.4.53 - PHP 8.1.5…5.6.40 - MySQL 5.7.38 - MariaDB 10.5.13/10.6.5
Wampserver 3.2.9 64 bit - Apache 2.4.53 - PHP 8.1.5…5.6.40 - MySQL 5.7.38/8.0.29 - MariaDB 10.5.15/10.7.3
PhPMyadmin 5.1.3 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Eparse error - PHP 8.1.0
Posted by: ciprianmp (---.131-242-81.adsl-dyn.isp.belgacom.be)
Date: November 29, 2021 11:25PM

This is all I have Otomatic, 14 lines:
[BigMenu]
BigKey0=NC,0,0
[TextMenu]
TextKey0=NC,0,8,$000ff9f2,$00D77800,NC,NC
[PromptCustom]
PromptKey0=Default,10,$00FCFDFE,$00000000,$00FCFDFE,$00000000
PromptKey1=NC,10,$00F0F0F0,$00000000,$00FCFDFE,$00000000
[Timer]
NumberStart=2
CountStart=2
[Options]
AeTrayMode=64 Bits
AeTrayOldMode=64bit
AeTrayVersion=3.2.4.2

Ciprian M.



Edited 1 time(s). Last edit at 11/30/2021 09:53AM by Otomatic.

Re: Eparse error - PHP 8.1.0
Posted by: Otomatic (Moderator)
Date: November 30, 2021 10:00AM

Hi,

This shows a completely corrupted wampmanager.ini file.

You need to download and run the tool to repair this file:

Repair tool for wampmanager.ini file if it is corrupted or missing. You can download at any time, but install this tool only if you need it, because it takes into account the current configuration of Wampserver. A wampmamanger.ini corrupted file is reflected mostly by errors like "[EparseError]" or "Could not execute run action" when launching Wampserver.

Wampmanager.ini repair

------------------------------------------------------------------------------------------------------------
Wampserver 3.2.9 32 bit - Apache 2.4.53 - PHP 8.1.5…5.6.40 - MySQL 5.7.38 - MariaDB 10.5.13/10.6.5
Wampserver 3.2.9 64 bit - Apache 2.4.53 - PHP 8.1.5…5.6.40 - MySQL 5.7.38/8.0.29 - MariaDB 10.5.15/10.7.3
PhPMyadmin 5.1.3 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Re: Eparse error - PHP 8.1.0
Posted by: ciprianmp (---.131-242-81.adsl-dyn.isp.belgacom.be)
Date: November 30, 2021 12:24PM

Thank you Otomatic, that fixed my ErrorParse for Tray icon. Everything runs smooth now, including in php8.1.

I also checked the language files I sent you last night, everything looks good, so they are ready for publishing in next update.

I noticed a few untranslated lines:
Changelog (in PHP tray menu)
WARNING
and
Warning d:/wamp or PHP in PATH (on left click, last line on the bottom)

Ciprian M.



Edited 1 time(s). Last edit at 12/05/2021 02:02AM by ciprianmp.

Re: Eparse error - PHP 8.1.0
Posted by: ciprianmp (---.131-242-81.adsl-dyn.isp.belgacom.be)
Date: November 30, 2021 12:26PM

OFF TOPIC:
For some reason, I don't get notifications anymore of new replies/posts on this forum.
Is there a setting I could change for that?

Ciprian M.

Re: Eparse error - PHP 8.1.0
Posted by: Otomatic (Moderator)
Date: November 30, 2021 02:19PM

Hi,

> Warning d:/wamp or PHP in PATH (on left click, last line on the bottom)
Almost all error or warning messages internal to Wampserver are generated by the php verification scripts. These messages are displayed via Aestan Tray Menu and wampmanager.ini which is extremely strict on the syntax to use. A small syntax defect will generate an error [Eparse...] and the non starting of Wampserver.
That's why these error or warning messages are in English and set in stone, without going through language variables.

> For some reason, I don't get notifications anymore of new replies/posts on this forum.
This forum is more than sixteen years old, has not been modified since its origin - except after a total database crash around 2012 and the switch to utf-8 - and still runs under PHP 5.2.
The "Follow this thread" option still exists but the mail() function of PHP 5.2 not having evolved does not correspond to the criteria of today.

Note : I don't have the hand nor the access keys to the wampserver.com site

------------------------------------------------------------------------------------------------------------
Wampserver 3.2.9 32 bit - Apache 2.4.53 - PHP 8.1.5…5.6.40 - MySQL 5.7.38 - MariaDB 10.5.13/10.6.5
Wampserver 3.2.9 64 bit - Apache 2.4.53 - PHP 8.1.5…5.6.40 - MySQL 5.7.38/8.0.29 - MariaDB 10.5.15/10.7.3
PhPMyadmin 5.1.3 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Re: Eparse error - PHP 8.1.0
Posted by: ciprianmp (---.131-242-81.adsl-dyn.isp.belgacom.be)
Date: November 30, 2021 10:03PM

Hi Otomatic
-------------------------------------------------------
> That's why these error or warning messages are in English and set in stone, without going through language variables.
I understand. I was thinking mostly of the menu item WARNING and the Changelog word, those can be added for localization, right?

> This forum is more than sixteen years old, has not been modified since its origin - except after a total database crash around 2012 and the switch to
No problem, my server has phpmail issues as well. Many applications got deprecated because of it.

Ciprian M.

Sorry, only registered users may post in this forum.