PHP Warning: PHP Startup: Unable to load dynamic library 'curl'
Posted by: DennisReynolds (---.nwrknj.fios.verizon.net)
Date: November 12, 2021 05:55AM

Hello,

I am currently stumped by this issue. I have installed the PHP update package and I am trying to use php7.4.18

extension_dir="c:/wamp/bin/php/php7.4.18/ext/"

extension=curl


The php.ini config file looks good to me and the above directory exists and has the extensions in it.

But for some reason, I keep getting the below error and curl is not loaded.

[12-Nov-2021 03:51:16 UTC] PHP Warning: PHP Startup: Unable to load dynamic library 'curl' (tried: c:/wamp/bin/php/php7.4.18/ext/curl (The specified module could not be found.), c:/wamp/bin/php/php7.4.18/ext/php_curl.dll (The specified procedure could not be found.)) in Unknown on line 0


c:/wamp/bin/php/php7.4.18/ext/php_curl.dll ---> File exists


c:/wamp/bin/php/php7.4.18/ext/curl ---> Why is it trying to load this when the full filename is php_curl.dll ?


Also, what is the difference between module and procedure here?


I have looked at this many times, and I can't see the problem.

Thanks

Options: ReplyQuote
Re: PHP Warning: PHP Startup: Unable to load dynamic library 'curl'
Posted by: Otomatic (Moderator)
Date: November 12, 2021 09:30AM

Hi,

Please READ (and answer) BEFORE YOU ASK A QUESTION

> Why is it trying to load this when the full filename is php_curl.dll ?

Just look at the file itself!
; Note : The syntax used in previous PHP versions ('extension=<ext>.so' and
; 'extension='php_<ext>.dll') is supported for legacy reasons and may be
; deprecated in a future PHP major version. So, when it is possible, please
; move to the new ('extension=<ext>' ) syntax.

> Also, what is the difference between module and procedure here?
Il faut le demander à PHP !
It's just a matter of syntax to avoid repeating the same word.

Try :
- Right-Click -> Tools -> Empty logs -> Empty all logs -> Y
- Right-Click -> Refresh

------------------------------------------------------------------------------------------------------------
Wampserver 3.2.7 32 bit - Apache 2.4.51 - PHP 8.1.0…5.6.40 - MySQL 5.7.36 - MariaDB 10.5.13/10.6.5
Wampserver 3.2.7 64 bit - Apache 2.4.51 - PHP 8.1.0…5.6.40 - MySQL 5.7.36/8.0.27 - MariaDB 10.5.13/10.6.5
PhPMyadmin 5.1.1 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: PHP Warning: PHP Startup: Unable to load dynamic library 'curl'
Posted by: DennisReynolds (---.nwrknj.fios.verizon.net)
Date: November 12, 2021 10:41PM

Thanks for the response. But it seems like I am already using the new syntax.

I am specifying,

extension=curl


And extension_dir is the correct directory. So what do I have to change?

Options: ReplyQuote
Re: PHP Warning: PHP Startup: Unable to load dynamic library 'curl'
Posted by: Otomatic (Moderator)
Date: November 13, 2021 09:15AM

Hi,

To load or not load a PHP extension, there is nothing to change "by hand"!
All extensions of the active PHP version are accessible via Left-Click -> PHP -> PHP extensions.
And the "curl" extension is enabled by default.

You did not respond to READ (and answer) BEFORE YOU ASK A QUESTION

------------------------------------------------------------------------------------------------------------
Wampserver 3.2.7 32 bit - Apache 2.4.51 - PHP 8.1.0…5.6.40 - MySQL 5.7.36 - MariaDB 10.5.13/10.6.5
Wampserver 3.2.7 64 bit - Apache 2.4.51 - PHP 8.1.0…5.6.40 - MySQL 5.7.36/8.0.27 - MariaDB 10.5.13/10.6.5
PhPMyadmin 5.1.1 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: PHP Warning: PHP Startup: Unable to load dynamic library 'curl'
Posted by: DennisReynolds (---.nwrknj.fios.verizon.net)
Date: November 14, 2021 05:29AM

Yes, I have tried it that way also. But, I keep getting the same error for curl, even after trying a newer PHP version. I tried php7.4.25, and again the same error.

[14-Nov-2021 01:15:41 UTC] PHP Warning: PHP Startup: Unable to load dynamic library 'curl' (tried: c:/wamp/bin/php/php7.4.25/ext/curl (The specified module could not be found.), c:/wamp/bin/php/php7.4.25/ext/php_curl.dll (The specified procedure could not be found.)) in Unknown on line 0

Is this some kind of bug? The PHP version that I have been using before this upgrade is php 5.6.35. When I revert back to this version, curl gets loaded successfully.

My Apache version is 2.4.33

Options: ReplyQuote
Re: PHP Warning: PHP Startup: Unable to load dynamic library 'curl'
Posted by: Otomatic (Moderator)
Date: November 14, 2021 10:29AM

Hi,

You still haven't answered READ (and answer) BEFORE YOU ASK A QUESTION

If you want to get help, you have to start by helping yourself and making the tiny effort to answer the questions you are asked.

If you had answered the questions from the beginning, we (you) would have saved a lot of time!

- 1 - Verify that all VC ++ packages are installed and with the latest versions.
To do this, use the tool:
Checks VC++ packages installed
Do not use a previously loaded tool. Make a new download to make sure you are using the correct version.[/u)
To download missing packages, do not rely on Microsoft links, they are not reliable, download packages on http://wampserver.aviatechno.net in section Visual C++ Redistribuable Packages
Do not forget that if you have a 64 bit Windows, you must install both 32 and 64 bit versions of each package.
You must install each package "as an administrator", so right-click the exe file and then run as Administrator.

- 2 - Apply Update 3.2.5 to your version of Wampserver
Wampserver update 3.2.5

- 3 - Install a newer version of Apache — a priori, you have Wampserver 32bit (If only you had answered the questions!), so : Apache 2.4.51 32bit

------------------------------------------------------------------------------------------------------------
Wampserver 3.2.7 32 bit - Apache 2.4.51 - PHP 8.1.0…5.6.40 - MySQL 5.7.36 - MariaDB 10.5.13/10.6.5
Wampserver 3.2.7 64 bit - Apache 2.4.51 - PHP 8.1.0…5.6.40 - MySQL 5.7.36/8.0.27 - MariaDB 10.5.13/10.6.5
PhPMyadmin 5.1.1 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote


Sorry, only registered users may post in this forum.