Cannot turn off SSL
Posted by: gpinzino (---.lightspeed.cicril.sbcglobal.net)
Date: October 08, 2021 08:28PM

Cannot turn off SSL

I have installed a different version of WampServer after experiencing an anomaly in version 3.2.3 which I was not able to resolve. I uninstalled the old version and installed version 3.0.6. I confirmed that all VC packages are installed correctly and feel reasonably comfortable that WampServer installed correctly. I am using Adobe Dreamweaver v. 10.0, Build 4117. Prior to this problem, I used WampServer for years without any serious issues.

When I try to access the website using Firefox or Chrome, the page fails to load. Chrome gives me the error message, “localhost refused to connect.” Firefox gives me the error message, “Unable to connect” which, by itself, is not very helpful, but it also shows the full URL which contains the “https” SSL protocol indication. Based on what I see in Firefox, it appears something, somewhere is forcing a SSL connection. Localhost is not set up for it, nor do I want to do so.

The website has a .htaccess file so I checked it and confirmed that it is not configured for secure connections. I have no virtual host settings and relevant httpd.config ssl settings are commented out.

The local setup needs php 5.6 to be compatible with the production site.

Where do we go from here?

1 - Windows version used (Specify version number AND whether 32 or 64 bit) Edition
Windows 10 Pro x64
Version 20H2
Installed on ‎8/‎11/‎2020
OS build 19042.1237
2 - Version WampServer (Specify version number AND whether 32 or 64 bit) 3.0.6 x64
3 - Apache Version 2.4.23
4 - PHP Version 5.6.40
5 - MySQL Version 5.7.3
6 - What color is the WampServer icon: Green
7 - In the file c:\Windows\System32\drivers\etc\hosts, what are the active lines?
127.0.0.1 localhost
::1 localhost
0.0.0.1 mssplus.mcafee.com
8 - Do you have access to localhost (Homepage WampServer)?
No. It just displays a link to the website (CCS_Online).
9 - Do you have access to phpMyAdmin?
Yes. Looks fully functional.
10 - If you refer to an error message, please include the EXACT wording of the error in your post
Chrome error message: localhost refused to connect.
11 - If you use an Antivirus and / or Firewall, please include the names of these
McAfee Antivirus
12 - What is the full path to the installation of WampServer (eg D:\wamp\)
C:\wamp\
13 - If you have one or more Virtual Hosts defined, please show their definition(s)
No virtual hosts defined.

Options: ReplyQuote
Re: Cannot turn off SSL
Posted by: Otomatic (Moderator)
Date: October 09, 2021 11:52AM

Hi,

It is not by passing on an old version of Wampserver that will allow you to solve your problem, on the contrary.

Wampserver, whatever the version, doesn't do ANY http -> https redirection, NEVER.

This is a problem from your browser configuration or .htaccess file or your system or anti-virus configuration that is totally unnecessary with Windows 10.

On the other hand :
- 1 -: 0.0.0.1 mssplus.mcafee.com has nothing to do in the hosts file
- 2 -: for your local sites you must use the VirtualHost

See:
The need for Virtual Host
and
Wampserver 3 - Create or add a VirtualHost
and
Why to create a VirtualHost BEFORE installing a CMS

------------------------------------------------------------------------------------------------------------
Wampserver 3.2.6 32 bit - Apache 2.4.51 - PHP 8.0.11…5.6.40 - MySQL 5.7.35 - MariaDB 10.5.12/10.6.4
Wampserver 3.2.6 64 bit - Apache 2.4.51 - PHP 8.0.11…5.6.40 - MySQL 5.7.35/8.0.26 - MariaDB 10.5.12/10.6.4
PhPMyadmin 5.1.1 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote


Sorry, only registered users may post in this forum.