since today 7.12.2020 wampmariadb does not start
Posted by: manarak (---.204.223-46.dynamic.3bb.co.th)
Date: December 07, 2020 10:20AM

wampserver64 on Windows 10

problem occured today, I made no changes to wampserver

wampserver icon in taskbar is orange.

mariadb does not start

mariadb log says:

yesterday (started OK):
2020-12-06 9:32:09 0 [Note] InnoDB: Loading buffer pool(s) from c:\wamp64\bin\mariadb\mariadb10.4.10\data\ib_buffer_pool
2020-12-06 9:32:09 0 [Note] Plugin 'FEEDBACK' is disabled.
2020-12-06 9:32:09 0 [Note] Server socket created on IP: '::'.
2020-12-06 9:32:09 0 [Note] Reading of all Master_info entries succeeded
2020-12-06 9:32:09 0 [Note] Added new Master_info '' to hash table
2020-12-06 9:32:09 0 [Note] wampmariadb64: ready for connections.
Version: '10.4.10-MariaDB' socket: '' port: 3306 mariadb.org binary distribution
2020-12-06 9:32:10 0 [Note] InnoDB: Buffer pool(s) load completed at 201206 9:32:10

today (problem):
2020-12-07 15:38:18 0 [Note] InnoDB: Loading buffer pool(s) from c:\wamp64\bin\mariadb\mariadb10.4.10\data\ib_buffer_pool
2020-12-07 15:38:18 0 [Note] Plugin 'FEEDBACK' is disabled.
2020-12-07 15:38:18 0 [Note] Server socket created on IP: '::'.
2020-12-07 15:38:18 0 [ERROR] Can't start server: Bind on TCP/IP port. Got error: 10013: An attempt was made to access a socket in a way forbidden by its access permissions.
2020-12-07 15:38:18 0 [ERROR] Do you already have another mysqld server running on port: 3306 ?
2020-12-07 15:38:18 0 [ERROR] Aborting

I checked netstat -a -b -n
There is no other process listening on port 3306

tried using another port - no change

tried turning windows firewall off - no change

tried updating to latest wampserver64 version - no change

I cannot start the service wampmariadb64 manually, it aborts

what can I do, please?

Options: ReplyQuote
Re: since today 7.12.2020 wampmariadb does not start
Posted by: RiggsFolly (Moderator)
Date: December 07, 2020 10:45AM

I assume you are running WAMPServer as an Administrator i.e. answering the UAC dialog with a YES?

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.2.5 32bit & 64bit)
<Apache versions MULTIPE> <PHP versions MULTIPLE> <MySQL Versions MULTIPLE>
<MariaDB versions MULTIPLE> <phpMyAdmin versions MULTIPLE> <MySQL Workbench 8.0.23>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-

Options: ReplyQuote
Re: since today 7.12.2020 wampmariadb does not start
Posted by: Otomatic (Moderator)
Date: December 07, 2020 10:46AM

Hi,

Results of:

- Right-Click -> Tools -> Check state of services
- Right-Click -> Tools -> Test port 3306

> I made no changes to wampserver
But Windows has probably made some updates, therefore:
- Verify that all VC ++ packages are installed and with the latest versions.
To do this, use the tool:
Checks VC++ packages installed
Do not use a previously loaded tool. Make a new download to make sure you are using the correct version.
To download missing packages, do not rely on Microsoft links, they are not reliable, download packages on http://wampserver.aviatechno.net in section Visual C++ Redistribuable Packages
Do not forget that if you have a 64 bit Windows, you must install both 32 and 64 bit versions of each package.
You must install each package "as an administrator", so right-click the exe file and then run as Administrator.

------------------------------------------------------------------------------------------------------------
Wampserver 3.2.7 32 bit - Apache 2.4.51 - PHP 8.1.0…5.6.40 - MySQL 5.7.36 - MariaDB 10.5.13/10.6.5
Wampserver 3.2.7 64 bit - Apache 2.4.51 - PHP 8.1.0…5.6.40 - MySQL 5.7.36/8.0.27 - MariaDB 10.5.13/10.6.5
PhPMyadmin 5.1.1 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: since today 7.12.2020 wampmariadb does not start
Posted by: manarak (---.204.223-46.dynamic.3bb.co.th)
Date: December 07, 2020 10:55AM

thank you for your replies.


- Right-Click -> Tools -> Check state of services
CMD window briefly flickers in, but nothing happens

- Right-Click -> Tools -> Test port 3306
same, CMD window briefly flickers, nothing happens

I will check the VC++ now



Edited 1 time(s). Last edit at 12/07/2020 10:56AM by manarak.

Options: ReplyQuote
Re: since today 7.12.2020 wampmariadb does not start
Posted by: manarak (---.204.223-46.dynamic.3bb.co.th)
Date: December 07, 2020 10:58AM

results of check_vcredist.exe:

WTF ??
I had all these installed, where did they go?


VC_2008_SP1_ATL_SEC_UPD_REDIST_X86 ID={1F1C2DFC-2D24-3E06-BCB8-725134ADF989}
Visual C++ 2008 SP1 ATL Security (x86)
**** NOT INSTALLED ****
Installation file is on: [wampserver.aviatechno.net]
VC 2008 SP1 ATL Package (x86)
----------------------------------------
*** VC_2008 (VC9) is needed to use PHP 5.3 or 5.4 ***
VC_2013_REDIST_X86_MIN ID={8122DAB1-ED4D-3676-BB0A-CA368196543E}
Visual C++ 2013 x86 Minimum Runtime - 12.0.40664
**** NOT INSTALLED ****
Installation file is on: [wampserver.aviatechno.net]
VC 2013 Package Up 5 (x86)
----------------------------------------
VC_2019_REDIST_X86 ID={EE2E15BB-54C8-4DB0-B1F3-026E3C166991}
Visual C++ 2015-2019 x86 Minimum Runtime - 14.28.29325
**** NOT INSTALLED ****
Installation file is on: [wampserver.aviatechno.net]
VC 2015-2019 (VC16 x86) 14.28.29325
----------------------------------------
VC_2008_SP1_ATL_SEC_UPD_REDIST_X64 ID={4B6C7001-C7D6-3710-913E-5BC23FCE91E6}
Visual C++ 2008 SP1 ATL Security Update (x64)
**** NOT INSTALLED ****
Installation file is on: [wampserver.aviatechno.net]
VC 2008 SP1 ATL Package (x64)
----------------------------------------
VC_2008_SP1_MFC_SEC_UPD_REDIST_X64 ID={5FCE6D76-F5DC-37AB-B2B8-22AB8CEDB1D4}
Visual C++ 2008 SP1 MFC Security (x64)
**** NOT INSTALLED ****
Installation file is on: [wampserver.aviatechno.net]
VC 2008 SP1 MFC Package (x64)
----------------------------------------
*** VC_2008 (VC9) is needed to use PHP 5.3 or 5.4 ***
VC_2013_REDIST_X64_MIN ID={53CF6934-A98D-3D84-9146-FC4EDF3D5641}
Visual C++ 2013 x64 Minimum Runtime Update 5 - 12.0.40664
**** NOT INSTALLED ****
Installation file is on: [wampserver.aviatechno.net]
VC 2013 Up 5 (x64)
----------------------------------------
VC_2019_REDIST_X64 ID={7D0362D5-C699-4403-BC09-0C1DAD1D93AB}
Visual C++ 2015-2019 x64 Minimum Runtime - 14.28.29325
**** NOT INSTALLED ****
Installation file is on: [wampserver.aviatechno.net]
VC 2015-2019 (VC16 x64) 14.28.29325
----------------------------------------



Edited 1 time(s). Last edit at 12/07/2020 10:58AM by manarak.

Options: ReplyQuote
Re: since today 7.12.2020 wampmariadb does not start
Posted by: manarak (---.204.223-46.dynamic.3bb.co.th)
Date: December 07, 2020 11:10AM

many thanks for your help, wampserver has now started all services. status green.

but I cannot understand why all these VC redists disappeared from my system ??
this is nuts

Options: ReplyQuote
Re: since today 7.12.2020 wampmariadb does not start
Posted by: manarak (---.204.223-46.dynamic.3bb.co.th)
Date: December 07, 2020 11:18AM

by the way, "test port 3306" and "check state of services" still don't do anything else than make the CMD window briefly flicker

Options: ReplyQuote
Re: since today 7.12.2020 wampmariadb does not start
Posted by: Otomatic (Moderator)
Date: December 07, 2020 12:06PM

Hi,

> but I cannot understand why all these VC redists disappeared from my system ??
Windows update.

------------------------------------------------------------------------------------------------------------
Wampserver 3.2.7 32 bit - Apache 2.4.51 - PHP 8.1.0…5.6.40 - MySQL 5.7.36 - MariaDB 10.5.13/10.6.5
Wampserver 3.2.7 64 bit - Apache 2.4.51 - PHP 8.1.0…5.6.40 - MySQL 5.7.36/8.0.27 - MariaDB 10.5.13/10.6.5
PhPMyadmin 5.1.1 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: since today 7.12.2020 wampmariadb does not start
Posted by: Otomatic (Moderator)
Date: December 07, 2020 02:40PM

Hi,

Put the complete c:\wamp(64) folder as well as the C:\Windows\System32\drivers\etc\hosts file in exclusion of Windows Defender or your anti-virus and other anti-things.

------------------------------------------------------------------------------------------------------------
Wampserver 3.2.7 32 bit - Apache 2.4.51 - PHP 8.1.0…5.6.40 - MySQL 5.7.36 - MariaDB 10.5.13/10.6.5
Wampserver 3.2.7 64 bit - Apache 2.4.51 - PHP 8.1.0…5.6.40 - MySQL 5.7.36/8.0.27 - MariaDB 10.5.13/10.6.5
PhPMyadmin 5.1.1 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: since today 7.12.2020 wampmariadb does not start
Posted by: manarak (---.204.223-46.dynamic.3bb.in.th)
Date: December 07, 2020 10:31PM

well, the problem came back after I started the system again.

this time, the VC check says all the VC are there.

Windows security does not let me set exclusions, nothing happens when I add an exception, very strange.

Options: ReplyQuote
Re: since today 7.12.2020 wampmariadb does not start
Posted by: manarak (182.232.141.---)
Date: December 08, 2020 05:27AM

ok, i found this, maybe it will solve my problem? (i hope so)
[stackoverflow.com]

Options: ReplyQuote
Re: since today 7.12.2020 wampmariadb does not start
Posted by: manarak (---.204.223-46.dynamic.3bb.co.th)
Date: December 08, 2020 11:52AM

okay thisn is totally nuts - just started my system again and wampserver and apache and mariadb started just fine ???

what the hell?

Options: ReplyQuote


Sorry, only registered users may post in this forum.