phpMyAdmin timeout not respecting PHP.ini max_execution_time
Posted by: SRD (---.spintel.net.au)
Date: November 29, 2020 10:09AM

Trying to import a 150MB .sql.zip file into WAMP phpMyAdmin using the method @ [stackoverflow.com] (saving the import file in c:/wamp/sql, and editing C:\wamp\apps\phpmyadmin5.0.2\config.inc.php to include $cfg['UploadDir'] = 'C:\wamp\sql'; at the end, then an option to import the file save to C:\wamp\sql during the import process.

However, I keep receiving a timeout error in phpMyAdmin, with advice to rerun the import selecting the same file, but on the 2nd run I always receive SQL errors.

So, I've set max_execution_time = 4500 in Wamp's PHP.ini (4500 seconds equals 75 minutes) and restarted Apache and MySQL.

However, the same timeout error occurs when using the same import process. The timeout error occurs after about 5 minutes.

Why is the timeout error occurring within 5 minutes and not within the time set by PHP.ini max_execution_time = 4500 ?

Options: ReplyQuote
Re: phpMyAdmin timeout not respecting PHP.ini max_execution_time
Posted by: Otomatic (Moderator)
Date: November 29, 2020 10:46AM

Hi,

See c:\wamp(64)\alias\phpmyadmin.conf file

------------------------------------------------------------------------------------------------------------
Wampserver 3.2.5 32 bit - Apache 2.4.46d - PHP 8.0.3…5.6.40 - MySQL 5.7.33 - MariaDB 10.5.9
Wampserver 3.2.5 64 bit - Apache 2.4.46d - PHP 8.0.3…5.6.40 - MySQL 5.7.33/8.0.23 - MariaDB 10.5.9
PhPMyadmin 5.0.4 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote


Sorry, only registered users may post in this forum.