Virtual hosts cannot find local cgi-bin
Posted by: Dandello2000 (---.bvtn.or.frontiernet.net)
Date: January 30, 2020 03:24PM

I have several Vhosts set up, but none of them can find their local cgi-bin but default to the localhost/cgi-bin instead. If I access the sites using 'localhost/mysite', 'localhost/mysite/cgi-bin' is found. (+ExecCGI has been added to the Options, so that's not the problem.)

What am I missing regarding Vhosts and cgi-bin?

Options: ReplyQuote
Re: Virtual hosts cannot find local cgi-bin
Posted by: Dandello2000 (---.bvtn.or.frontiernet.net)
Date: January 30, 2020 04:42PM

Additional note: this is on Win10 home.

Options: ReplyQuote
Re: Virtual hosts cannot find local cgi-bin
Posted by: Otomatic (Moderator)
Date: January 30, 2020 04:48PM

Hi,

See [httpd.apache.org]

and #AddHandler cgi-script .cgi and the comments before in the file httpd.conf

------------------------------------------------------------------------------------------------------------
Wampserver 3.2.3 32 bit - Apache 2.4.46 - PHP 7.4.9…5.6.40 - MySQL 5.7.31 - MariaDB 10.5.5
Wampserver 3.2.3 64 bit - Apache 2.4.46 - PHP 7.4.9…5.6.40 - MySQL 5.7.31/8.0.21 - MariaDB 10.5.5
PhPMyadmin 5.0.2 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: Virtual hosts cannot find local cgi-bin
Posted by: Dandello2000 (---.bvtn.or.frontiernet.net)
Date: January 30, 2020 06:30PM

The apache config was copied from a Win7 machine - both machines have the same file structures regarding the website files, the same version of Wamp server and the same version of Perl - the only functional difference is the OS. The Vhosts config files are identical. The Windows hosts files are identical.

On the Win10 machine, the .htaccess files are ignored AND pages called using the vhost address default to looking for the cgi-bin in the wamp install directory.

I am thinking this is a Win10 Home issue.

Options: ReplyQuote
Re: Virtual hosts cannot find local cgi-bin
Posted by: RiggsFolly (Moderator)
Date: January 30, 2020 07:00PM

Please show us your vhost definitions, they shoudl be in`httpd-vhosts.conf`

.htaccess files require AllowOverride to be set to something in the <Directory ....> of your Vhost

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.2.0 32bit & 64bit)
<Apache versions MULTIPE> <PHP versions MULTIPLE> <MySQL Versions MULTIPLE>
<MariaDB versions MULTIPLE> <phpMyAdmin versions MULTIPLE> <MySQL Workbench 8.0.19>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-

Options: ReplyQuote
Re: Virtual hosts cannot find local cgi-bin
Posted by: Otomatic (Moderator)
Date: January 30, 2020 07:24PM

Hi,

You can try by launching the wampapache service (or wampapache64 according to wampserver 32 or 64 bit) in administrator account connection and not local system.
This is what I do to be able to access my VirtualHost located on a LAN NAS.

I'll explain how to do it, but it may be that the translation of the terms is a bit "weird" since I use a French Windows 10 Pro 64 bit and I don't know the actual terms used in English.

Launch Service Manager. This can be done by :
Right-Click wampmanager tray icon -> Tools -> Command Windows -> Service Control Panel

Right-Click on the service name wampapache or wampapache64 then Properties.

- Connection Tab
- Check the radio button This Account
- Browse button
- Advanced Button
- Search Button
- Double-Click on your account name (Must be an administrator account)
(For me, it's "dominique" folder "DOMI"winking smiley
You are now in the Select a user window with, in the field "Enter the name of the object to be selected" DOMI\dominique
- OK button
You must then fill in the two fields "Password" and "Confirm password" with the password of the chosen account.
- Apply button
Popup to say that the new login name will only take effect with a stop and restart of the service.
- Popup OK button
- OK button

There you go!

You must then stop Wampserver and restart it (Restarting the Wampapache64 service alone is not enough).

------------------------------------------------------------------------------------------------------------
Wampserver 3.2.3 32 bit - Apache 2.4.46 - PHP 7.4.9…5.6.40 - MySQL 5.7.31 - MariaDB 10.5.5
Wampserver 3.2.3 64 bit - Apache 2.4.46 - PHP 7.4.9…5.6.40 - MySQL 5.7.31/8.0.21 - MariaDB 10.5.5
PhPMyadmin 5.0.2 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote


Sorry, only registered users may post in this forum.