MYSQL problem after successfully install wampserver 3.1.9
Posted by: metysoriano (---.alliance.com.ph)
Date: October 14, 2019 03:51AM

After successfully installed my wampserver 3.1.9 with SSL certificate and restoration my old database from wampserver 2.2, a lot of MYSQL errors occur.

1. It did not add/append record anymore
2. when I add records error appears (Notice: undefined index)

These errors were not occur on my previous version of wampserver 2.2

Please help me, where is the problem on this.

Thank you so much

Options: ReplyQuote
Re: MYSQL problem after successfully install wampserver 3.1.9
Posted by: RiggsFolly (Moderator)
Date: October 14, 2019 04:34AM

Hi

Notice undefined index sounds like a PHP error rmessage to me. This is caused by poor code usually.
It is quite possible that the errors have become apparent in the new release of WAMPServer, because as a development tool it comes configured to diaply PHP error message that exist.

Quite possibly you had turned Off error reporting in your old system therefore allowing you to ignore all the bad code.

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.1.9 32bit & 64bit)
<Apache versions MULTIPE> <PHP versions MULTIPLE> <MySQL Versions MULTIPLE>
<MariaDB versions MULTIPLE> <phpMyAdmin versions MULTIPLE> <MySQL Workbench 8.0.16>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-

Options: ReplyQuote


Sorry, only registered users may post in this forum.