Upgraded Apache from 2.4.37 to 2.4.41 kills web server
Posted by: tytechnolust (128.230.105.---)
Date: September 09, 2019 10:10PM

Good afternoon all.

Currently on
WAMP 3.1.9
MariaDB 10.3.12
MySQL 5.7.24
PHP 7.2.22
Apache 2.4.41

I recently upgraded Apache from 2.4.37 to 2.4.41. After doing so, local host via the browser provides the following error:

This site can’t be reached
xxxx.xxxxx.com refused to connect.
Try:

Checking the connection
Checking the proxy and the firewall
ERR_CONNECTION_REFUSED

When I push the Apache version back to 2.4.37 (via the WAMP GUI) everything works as expected. Looking for directions to help get everything working with Apache 2.4.41.

Thank you all.

Options: ReplyQuote
Re: Upgraded Apache from 2.4.37 to 2.4.41 kills web server
Posted by: Otomatic (Moderator)
Date: September 10, 2019 09:13AM

Hi,

Changing Apache version sets up a new Apache version with the basic configuration.
It is your responsibility to attach all the configuration changes you made to the previous version.
It is also your responsibility to allow this new version in your firewall and to clean up caches or other browser settings that were used for the previous version.

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.9 32 bit - Apache 2.4.41 - PHP 7.3.12/7.2.23/7.1.32/7.0.33/5.6.40 - MySQL 5.7.28 - MariaDB 10.4.9
Wampserver 3.1.9 64 bit - Apache 2.4.41 - PHP 7.3.12/7.2.23/7.1.32/7.0.33/5.6.40 - MySQL 5.7.28/8.0.18 - MariaDB 10.4.9
PhPMyadmin 4.9.1 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: Upgraded Apache from 2.4.37 to 2.4.41 kills web server
Posted by: yanker (---.122.14.37.dynamic.jazztel.es)
Date: October 09, 2019 09:23AM

The same thing happened to me. I can access locally with all browsers but remotely with Chrome and Firefox it happens to me.

With iexplorer or safari without it works.

I don't understand anything, could you solve it?

Options: ReplyQuote
Re: Upgraded Apache from 2.4.37 to 2.4.41 kills web server
Posted by: yanker (---.122.14.37.dynamic.jazztel.es)
Date: October 09, 2019 12:51PM

In chrome or firefox
ERR_CONNECTION_CLOSED

In iexplorer or safari load pages

Options: ReplyQuote
Re: Upgraded Apache from 2.4.37 to 2.4.41 kills web server
Posted by: RiggsFolly (Moderator)
Date: October 09, 2019 12:55PM

Hi yanker

If you mean that Safari and internet explorer load the pages that Chrome and Firefox do not load. Then it is quite obviously nothing to do with WAMPServer.

We are not browser experts, but if you start by clearing the browser cache (CTRL+F5)

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.1.9 32bit & 64bit)
<Apache versions MULTIPE> <PHP versions MULTIPLE> <MySQL Versions MULTIPLE>
<MariaDB versions MULTIPLE> <phpMyAdmin versions MULTIPLE> <MySQL Workbench 8.0.16>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-

Options: ReplyQuote
Re: Upgraded Apache from 2.4.37 to 2.4.41 kills web server
Posted by: yanker (---.122.14.37.dynamic.jazztel.es)
Date: October 10, 2019 08:59AM

The problem comes with SSL, through port 80 everything comes in but when I try to do it by SSL in firefox and chome there is no way I don't reject the connection since I'm crazy I've tried everything

Options: ReplyQuote


Sorry, only registered users may post in this forum.