exec command fails in php
Posted by: phiratio (---.lisco.net)
Date: July 18, 2019 08:03PM

1: Windows 7 Home Premium
2: Wamp 3.1.9 64 bit
3: Apache 2.4.33
4: PHP 7.2.4
5: MySQL 5.7.21
6: Green
7: hosts: localhost vedicchart
::1 localhost
::1 vedicchart local.skyfonts.com
8: yes
8a: no
9: yes
12: C:\wamp64

<VirtualHost *:80>
ServerName vedicchart
DocumentRoot "${INSTALL_DIR}/www/vedicchart"
<Directory "${INSTALL_DIR}/www/vedicchart">
Options +Indexes +Includes +FollowSymLinks +MultiViews
AllowOverride All
Require local

The php code I use is using the exec command to call an external program that returns planetary information.
It works fine the first time I run the code but doesn't work on subsequent calls. I have been trying to resolve this problem for quite a while now.

Everything works find when I run the code from the web host. I only have this problem when running the code in WAMP on my computer. I tried recently to install WAMP to a Windows 10 computer and I got the exact samer results.

It's as if WAMP times out. Nothing is returned from one of the exec commands. There is a number of calls made with exec and when it works (on the first call) takes about 5 seconds. Always fail when I run the code the second time!

I'm out of ideas on what could be causing this.
Thanks for your help

Options: ReplyQuote

Sorry, only registered users may post in this forum.