Getting lost with new WampServer 3
Posted by: dejudicibus (---.cust.vodafonedsl.it)
Date: April 09, 2019 11:07AM

I am really getting lost with the new version of WampServer. I read the documentation but there is still something that I do not understand.

First of all when I open localhost I get the message at the bottom

It's a bad idea to add localhost in the url of launching projects. It is best to define VirtualHost in
wamp/bin/apache/apache2.4.37/conf/extra/httpd-vhosts.conf
file and not add localhost in the url.

I created VirtualHost for each project but I cannot find which option should I enable or disable to avoid that message.

Second, I created the following VirtualHost

<VirtualHost *:80>
ServerName portfolio
ServerAlias portfolio
DocumentRoot "${INSTALL_DIR}/www/portfolio"
<Directory "${INSTALL_DIR}/www/portfolio/">
Options +Indexes +Includes +FollowSymLinks +MultiViews
AllowOverride All
Require local
</Directory>
</VirtualHost>

but when I open portfolio/ (a wordpress site) I get that all images are like

http ://portfolio/portfolio/wp-content/gallery/glamour/thumbs/thumbs_image.jpg

rather than

http ://portfolio/wp-content/gallery/glamour/thumbs/thumbs_image.jpg

and all links are like

http ://portfolio/localhost/portfolio/page/example/

rather than

http ://portfolio/page/example/

Any idea of what I did wrong?

PS the space after http is used here to avoid that this editor convert the string to a link.



Edited 1 time(s). Last edit at 04/09/2019 11:10AM by dejudicibus.

Options: ReplyQuote
Re: Getting lost with new WampServer 3
Posted by: RiggsFolly (Moderator)
Date: April 09, 2019 11:49AM

Hi

Start by unsetting the option to add `localhost` to your urls.

right click on wampmanager-> Wamp Settings -> add localhost in url
If it has a green Tick, click that menu option and it wil be unset

You must have set this yourself as WAMPServer does not come with this option set

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.1.8 32bit & 64bit)
<Apache versions MULTIPE> <PHP versions MULTIPLE> <MySQL Versions MULTIPLE>
<MariaDB versions MULTIPLE> <phpMyAdmin versions MULTIPLE> <MySQL Workbench 8.0.16>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-

Options: ReplyQuote
Re: Getting lost with new WampServer 3
Posted by: dejudicibus (---.cust.vodafonedsl.it)
Date: April 09, 2019 12:42PM

OK, I removed "add localhost". The message is gone, but the links are still wrong:


http ://portfolio/portfolio/wp-content/gallery/glamour/thumbs/thumbs_image.jpg

rather than

http ://portfolio/wp-content/gallery/glamour/thumbs/thumbs_image.jpg

and all links are like

http ://portfolio/localhost/portfolio/page/example/

rather than

http ://portfolio/page/example/

Furthermore, if I try to login into WP admin panel, if I use url

http ://portfolio/wp-admin

I get

http: //portfolio/wp-admin/portfolio/wp-login.php?redirect_to=http%3A%2F%2Fportfolio%2Fwp-admin%2F&reauth=1

and error message

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator at xxxxxxxx@gmail.com to inform them of the time this error occurred, and the actions you performed just before this error.

More information about this error may be available in the server error log.

Options: ReplyQuote
Re: Getting lost with new WampServer 3
Posted by: RiggsFolly (Moderator)
Date: April 09, 2019 12:50PM

More information about this error may be available in the server error log.

So did you look in the server logs?

\wamp64\logs

Also is this a newly installed WP site i.e. you installed it on wampserver, or is this a site copied down from another site?

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.1.8 32bit & 64bit)
<Apache versions MULTIPE> <PHP versions MULTIPLE> <MySQL Versions MULTIPLE>
<MariaDB versions MULTIPLE> <phpMyAdmin versions MULTIPLE> <MySQL Workbench 8.0.16>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-

Options: ReplyQuote
Re: Getting lost with new WampServer 3
Posted by: dejudicibus (---.cust.vodafonedsl.it)
Date: April 09, 2019 01:38PM

Got it.... the was still localhost in site url in wp settings... solved... thank you for your support.

Options: ReplyQuote


Sorry, only registered users may post in this forum.