Pages: Previous12
Current Page: 2 of 2
Re: 443 not a Listen Port
Posted by: Otomatic (Moderator)
Date: May 29, 2019 04:18PM

Hi,

Getting the error "443 not a listen port" indicates that in the httpd-vhosts.conf file you have a VirtualHost on port 443.
VirtualHosts port 443 must be defined in the wamp(64)\bin\apache\apache2.4.xy\conf\extra\httpd-ssl.conf file.

------------------------------------------------------------------------------------------------------------
Wampserver 3.2.0 32 bit - Apache 2.4.41 - PHP 7.4.2/7.3.14/..../5.6.40 - MySQL 5.7.29 - MariaDB 10.4.12
Wampserver 3.2.0 64 bit - Apache 2.4.41 - PHP 7.4.2/7.3.14/..../5.6.40 - MySQL 5.7.29/8.0.19 - MariaDB 10.4.12
PhPMyadmin 5.0.1 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »



Edited 1 time(s). Last edit at 05/29/2019 06:43PM by Otomatic.

Options: ReplyQuote
Re: 443 not a Listen Port
Posted by: vincentdemers (---.qc.cable.ebox.net)
Date: May 30, 2019 02:18PM

Hi Otomatic

You are right, I moved my ssl enabled virtual hosts from the httpd-vhosts.conf to the httpd-ssl.conf and it fixed the issue.

Thanks a lot for your help, Sincerely Vincent

Options: ReplyQuote
Re: 443 not a Listen Port
Posted by: yanker (---.122.14.37.dynamic.jazztel.es)
Date: October 11, 2019 09:40AM

Hello, could someone solve it? I have apache 2.4.39 and I can access my SSL by iexplorer but by chrome I reject the connection, you know why it can be ?? Thank you

Options: ReplyQuote
Re: 443 not a Listen Port
Posted by: RiggsFolly (Moderator)
Date: October 11, 2019 10:11AM

Please tell us HOW it rejects the connection?


Have you read This answer

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.2.0 32bit & 64bit)
<Apache versions MULTIPE> <PHP versions MULTIPLE> <MySQL Versions MULTIPLE>
<MariaDB versions MULTIPLE> <phpMyAdmin versions MULTIPLE> <MySQL Workbench 8.0.16>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-

Options: ReplyQuote
Re: 443 not a Listen Port
Posted by: yanker (---.151.221.87.dynamic.jazztel.es)
Date: February 11, 2020 01:30PM

I have Apache wampserver 3.2 installed with Apache 2.4.41 and SSL configured

I have put my vhost inside the http-ssl.conf file, open port 443, loaded the necessary modules etc etc.

But when I access SSL, the connection is rejected and by firefox, for example, the error PR_END_OF_FILE_ERROR returns.

I have already tried everything and instead if I use Apache 2.4.35, I access SSL without problems.

Any solution? Thank you

Options: ReplyQuote
Re: 443 not a Listen Port
Posted by: yanker (---.151.221.87.dynamic.jazztel.es)
Date: February 11, 2020 02:36PM

I have made a new test, I have installed version 4.4.35 and I have compared the files http.conf, http-ssl.conf and httpd-vhost.con and they are the same, instead SSL WAN works with 4.4.35 and not with 4.4.41.

I rule out problems with Firewall

Options: ReplyQuote
Pages: Previous12
Current Page: 2 of 2


Sorry, only registered users may post in this forum.