SSL Module not loading after Apache Update
Posted by: newmanity (---.eastlink.ca)
Date: November 27, 2018 06:42PM

I recently upgraded my Wampserver to 3.1.5, installed the latest Visual Studio C++ files, and successfully upgraded PHP from version 7.1.9 to 7.2.12.
I then tried upgrading Apache from 2.4.27 to 2.4.37. When I switch to 37, however, the service does not start. I cannot see anything in the error log about this, but I can see that when I disable the ssl_module the Apache service starts up. This module works just fine when I switch back to 2.4.27.
What should I be looking at for further troubleshooting?
I can confirm that the mod_ssl.so file exists in the C:\wamp64\bin\apache\apache2.4.37\modules folder and is visible from the Wampserver -> Apache -> Apache Modules menu...

I just tried copying the mod_ssl.so file from the apache2.4.27\modules folder and replacing the apache2.4.37 file, and the service starts up...will this be a problem?



Edited 2 time(s). Last edit at 11/27/2018 06:48PM by newmanity.

Options: ReplyQuote
Re: SSL Module not loading after Apache Update
Posted by: RiggsFolly (Moderator)
Date: November 27, 2018 08:16PM

Did you copy your httpd-ssl.conf file and uncomment the include in the bottom of httpd.conf?

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.1.3 32bit & 64bit)
<Apache 2.4.29/2.2.31> <PHP 7.2/7.1/7.0/5.6/5.5/5.4> <MySQL 5.7.19/5.6.39/5.5.28>
<MariaDB 10.2.14> <phpMyAdmin4.8.1> <MySQL Workbench 6.3.10>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-

Options: ReplyQuote
Re: SSL Module not loading after Apache Update
Posted by: newmanity (---.eastlink.ca)
Date: November 27, 2018 08:41PM

I had never uncommented conf/extra/httpd-ssl.conf in 2.4.27, so no, I didn't do that in 2.4.37...

Options: ReplyQuote


Sorry, only registered users may post in this forum.