Pages: Previous12
Current Page: 2 of 2
Re: Problem with extensions when installing wampserver 3.1.0
Posted by: piton (84.78.18.---)
Date: October 26, 2018 10:53AM

I understand you, but I'm using the google translator, that's why the confusion.
I meant that there are no services in the service manager.

comment that the wampserver works and boots well, except the extension that I put up that is activated by default or any other extension that tries to enable.

Options: ReplyQuote
Re: Problem with extensions when installing wampserver 3.1.0
Posted by: Otomatic (Moderator)
Date: October 26, 2018 11:22AM

Hi,

> except the extension that I put up that is activated by default
All the errors you can have, like:
[25-Oct-2018 09:32:28 UTC] PHP Warning: PHP Startup: mysqli: Unable to initialize module
Module compiled with module API=20131226
PHP compiled with module API=20170718
These options need to match
All are due to the fact that the php.ini loaded is not the one corresponding to the PHP version of Wampserver.
If you load the "good" php.ini, for example for PHP 5.6.31, the extension path in php.ini must be:

extension_dir ="c:/wamp/bin/php/php5.6.31/ext/"

and, in this case, we load the PHP extensions compiled with the correct VC++ version and there are no loading errors.

But in your case, the wrong php.ini is loaded.
Indeed, Apache will first look for a php.ini file in the Windows folder, then in the folders defined in the PATH environment variable, then possibly uses the PHPDIR or PHPPATH environment variables if they exist then if it has not found a php.ini file, will see in its bin folder, i.e. in c:/wamp/bin/bin/apache/apache2.4.27/bin/ if there is a php.ini file - and this is the right one.

I repeat that you have a php.ini file or even an installation of another PHP version elsewhere than in the folder c:/wamp/bin/php/ and that it is this php.ini that is loaded first.

Note : If your language is Spanish, DeepL Translator is better than Google Translate.

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.4 32 bit - Apache 2.4.37 - PHP 7.2.12/7.1.24/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.10
Wampserver 3.1.4 64 bit - Apache 2.4.37 - PHP 7.2.12/7.1.24/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.10
PhPMyadmin 4.8.3 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »



Edited 1 time(s). Last edit at 10/26/2018 11:26AM by Otomatic.

Options: ReplyQuote
Re: Problem with extensions when installing wampserver 3.1.0
Posted by: Otomatic (Moderator)
Date: October 26, 2018 12:06PM

Hi,

I would add that paths to load php.ini can also exist in the registry, in keys like:

HKEY_LOCAL_MACHINE\SOFTWARE\PHP

For Windows 64 bit there is also :

HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\PHP

These keys are not created by Wampserver.

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.4 32 bit - Apache 2.4.37 - PHP 7.2.12/7.1.24/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.10
Wampserver 3.1.4 64 bit - Apache 2.4.37 - PHP 7.2.12/7.1.24/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.10
PhPMyadmin 4.8.3 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: Problem with extensions when installing wampserver 3.1.0
Posted by: piton (---.red-88-24-41.staticip.rima-tde.net)
Date: October 26, 2018 12:30PM

I didn't find any php.ini and the PATH doesn't exist anything that points to php.

I reinstalled the wampserver 3.0.1 after verifying that there were no services in the service manager, I repaired one by one the visual ++ executed from the administrator.

I'm still with the same problem but this time I'm going to pass you all the logs


APACHE

[Fri Oct 26 12:15:37.295759 2018] [mpm_winnt:notice] [pid 12092:tid 640] AH00455: Apache/2.4.27 (Win32) PHP/5.6.31 configured -- resuming normal operations
[Fri Oct 26 12:15:37.295759 2018] [mpm_winnt:notice] [pid 12092:tid 640] AH00456: Apache Lounge VC15 Server built: Jul 7 2017 11:43:51
[Fri Oct 26 12:15:37.295759 2018] [core:notice] [pid 12092:tid 640] AH00094: Command line: 'c:\\wamp\\bin\\apache\\apache2.4.27\\bin\\httpd.exe -d C:/wamp/bin/apache/apache2.4.27'
[Fri Oct 26 12:15:37.313419 2018] [mpm_winnt:notice] [pid 12092:tid 640] AH00418: Parent: Created child process 9784
[Fri Oct 26 12:15:38.670110 2018] [mpm_winnt:notice] [pid 9784:tid 700] AH00354: Child: Starting 64 worker threads.

PHP

[26-Oct-2018 10:15:32 UTC] PHP Fatal error: Call to undefined function symlink() in C:\wamp\scripts\wampserver.lib.php on line 85
[26-Oct-2018 10:15:36 UTC] PHP Warning: PHP Startup: Unable to load dynamic library 'c:/wamp/bin/php/php5.6.31/ext/php_intl.dll' - No se puede encontrar el m�dulo especificado.

in Unknown on line 0

[26-Oct-2018 10:15:38 UTC] PHP Warning: PHP Startup: Unable to load dynamic library 'c:/wamp/bin/php/php5.6.31/ext/php_intl.dll' - No se puede encontrar el m�dulo especificado.

in Unknown on line 0

[26-Oct-2018 10:15:32 UTC] PHP Fatal error: Call to undefined function symlink() in C:\wamp\scripts\wampserver.lib.php on line 85
[26-Oct-2018 10:15:36 UTC] PHP Warning: PHP Startup: Unable to load dynamic library 'c:/wamp/bin/php/php5.6.31/ext/php_intl.dll' - No se puede encontrar el m�dulo especificado.

in Unknown on line 0

[26-Oct-2018 10:15:38 UTC] PHP Warning: PHP Startup: Unable to load dynamic library 'c:/wamp/bin/php/php5.6.31/ext/php_intl.dll' - No se puede encontrar el m�dulo especificado.

in Unknown on line 0


MYSQL

2018-10-26T10:15:39.250190Z 0 [Warning] InnoDB: Resizing redo log from 2*3072 to 2*320 pages, LSN=2540456
2018-10-26T10:15:39.461467Z 0 [Warning] InnoDB: Starting to delete and rewrite log files.
2018-10-26T10:15:40.492813Z 0 [Warning] InnoDB: New log files created, LSN=2540456

MARIADB

2018-10-26 12:15:38 5580 [Note] InnoDB: Mutexes and rw_locks use Windows interlocked functions
2018-10-26 12:15:38 5580 [Note] InnoDB: Uses event mutexes
2018-10-26 12:15:38 5580 [Note] InnoDB: Compressed tables use zlib 1.2.3
2018-10-26 12:15:38 5580 [Note] InnoDB: Number of pools: 1
2018-10-26 12:15:38 5580 [Note] InnoDB: Using generic crc32 instructions
2018-10-26 12:15:39 5580 [Note] InnoDB: Initializing buffer pool, total size = 32M, instances = 1, chunk size = 32M
2018-10-26 12:15:39 5580 [Note] InnoDB: Completed initialization of buffer pool
2018-10-26 12:15:39 5580 [Note] InnoDB: Highest supported file format is Barracuda.
2018-10-26 12:15:40 5580 [Note] InnoDB: Resizing redo log from 2*50331648 to 2*5242880 bytes; LSN=1620107
2018-10-26 12:15:40 5580 [Note] InnoDB: Starting to delete and rewrite log files.
2018-10-26 12:15:40 5580 [Note] InnoDB: Setting log file .\ib_logfile101 size to 5242880 bytes
2018-10-26 12:15:41 5580 [Note] InnoDB: Setting log file .\ib_logfile1 size to 5242880 bytes
2018-10-26 12:15:41 5580 [Note] InnoDB: Renaming log file .\ib_logfile101 to .\ib_logfile0
2018-10-26 12:15:41 5580 [Note] InnoDB: New log files created, LSN=1620107
2018-10-26 12:15:41 5580 [Note] InnoDB: 128 out of 128 rollback segments are active.
2018-10-26 12:15:41 5580 [Note] InnoDB: Creating shared tablespace for temporary tables
2018-10-26 12:15:41 5580 [Note] InnoDB: Setting file '.\ibtmp1' size to 12 MB. Physically writing the file full; Please wait ...
2018-10-26 12:15:44 5580 [Note] InnoDB: File '.\ibtmp1' size is now 12 MB.
2018-10-26 12:15:44 5580 [Note] InnoDB: Waiting for purge to start
2018-10-26 12:15:44 5580 [Note] InnoDB: 5.7.19 started; log sequence number 1620098
2018-10-26 12:15:44 11988 [Note] InnoDB: Loading buffer pool(s) from c:\wamp\bin\mariadb\mariadb10.2.8\data\ib_buffer_pool
2018-10-26 12:15:44 11988 [Note] InnoDB: Buffer pool(s) load completed at 181026 12:15:44
2018-10-26 12:15:44 5580 [Note] Plugin 'FEEDBACK' is disabled.
2018-10-26 12:15:44 5580 [Note] Server socket created on IP: '::'.
2018-10-26 12:15:45 5580 [Note] Reading of all Master_info entries succeded
2018-10-26 12:15:45 5580 [Note] Added new Master_info '' to hash table
2018-10-26 12:15:45 5580 [Note] wampmariadb: ready for connections.
Version: '10.2.8-MariaDB' socket: '' port: 3307 mariadb.org binary distribution

Options: ReplyQuote
Re: Problem with extensions when installing wampserver 3.1.0
Posted by: Otomatic (Moderator)
Date: October 26, 2018 01:29PM

Hi,

> I reinstalled the wampserver 3.0.1 after verifying
I think it is 3.1.0 (not 3.0.1). Full installer are : 3.0.0, 3.0.4, 3.0.6, 3.1.0, 3.1.3 and 3.1.4

- Apache is OK
- MySQL is OK
- MariaDB is OK

The first error for PHP :
PHP Fatal error: Call to undefined function symlink() in C:\wamp\scripts\wampserver.lib.php on line 85
is completely incomprehensible because the symlink() function is a basic PHP function that exists for Windows since PHP 5.3.0 and Windows Vista.

The only explanation I have would be:
- that you are not in a Windows session with administrator rights
- that Wampserver has not been installed "as an administrator"
- that Wampserver is not launched "as an administrator"

The shortcut that launches Wampserver must have the option "As administrator":
Right-Click on the shortcut -> Properties
Button Advanced
Option Run as an administrator must be checked

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.4 32 bit - Apache 2.4.37 - PHP 7.2.12/7.1.24/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.10
Wampserver 3.1.4 64 bit - Apache 2.4.37 - PHP 7.2.12/7.1.24/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.10
PhPMyadmin 4.8.3 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: Problem with extensions when installing wampserver 3.1.0
Posted by: piton (---.red-88-24-41.staticip.rima-tde.net)
Date: October 26, 2018 02:12PM

Hello, if the icon that starts the wampserver is marked as administrator, apart from that is one of the first things I saw, on the other hand I found a my.ini file of a mysql version that I had, I removed it, although this was not the problem because as you said, mysql was installed correctly, anyway I did the installation again making sure that everything is correct but nothing continues to give the php error.

Already exhausted the forces.
I have a question, how much space is needed for the installation of the wamp? I have 60 GB

by the way thank you very much for the help and translator that goes very well.

Options: ReplyQuote
Re: Problem with extensions when installing wampserver 3.1.0
Posted by: Otomatic (Moderator)
Date: October 26, 2018 03:27PM

Hi,

About 3 GB. MySQL and MariaDB take up the most space. About 1.5 GB for MySQL and 1 GB for MariaDB.

I must admit that I do not understand what is happening here, nor how to correct the problem.
At first glance, it is the creation of symbolic links (symlink) that does not want to be done on your system, since even the symlink function, although basic PHP, is not recognized.
We will not despair, I will look at how to replace the creation of symbolic links with copies of files.
It's going to take me a little while, but I'll find a solution.
See you soon.

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.4 32 bit - Apache 2.4.37 - PHP 7.2.12/7.1.24/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.10
Wampserver 3.1.4 64 bit - Apache 2.4.37 - PHP 7.2.12/7.1.24/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.10
PhPMyadmin 4.8.3 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: Problem with extensions when installing wampserver 3.1.0
Posted by: Otomatic (Moderator)
Date: October 27, 2018 09:36AM

Hi,

Replacing the creation of symbolic links with copies of files is a little more complex than I expected.

Indeed, Wampserver performs many checks, including the relevance of symbolic links in the Apache bin folder and it is very simple to know the target of a symbolic link in PHP by the readlink() function.

On the other hand, it is impossible to know what the original file is after a file copy.
This is why since Wampserver 2.5 it is used to create symbolic links instead of copying files.

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.4 32 bit - Apache 2.4.37 - PHP 7.2.12/7.1.24/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.10
Wampserver 3.1.4 64 bit - Apache 2.4.37 - PHP 7.2.12/7.1.24/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.10
PhPMyadmin 4.8.3 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: Problem with extensions when installing wampserver 3.1.0
Posted by: Otomatic (Moderator)
Date: October 27, 2018 10:55AM

Hi,

We will first check that your version of Windows supports symbolic links creation by using the "mklink" system command that exists since Windows Vista.
First, check with the file explorer to see if there is the php.ini file (or link) in the bin folder of your Apache version (c:\wamp\bin\apache\apache2.4.27\bin\php.ini) if php.ini exists, it must be deleted.

Then open a command window as an administrator (the word Administrator must be in the title bar) and in this command window, type :
mklink c:\wamp\bin\apache\apache2.4.27\bin\php.ini c:\wamp\bin\php\php5.6.31\phpForApache.ini
then Enter

The answer should be like : Symbolic link created for
Below, an example made on my system, but for Apache 2.4.37 and PHP 7.2.11 with wamp on J: (not on C: ) the answer in French ( "Lien symbolique créé pour" ) means "Symbolic link created for"
C:\>mklink j:\wamp\bin\apache\apache2.4.37\bin\php.ini j:\wamp\bin\php\php7.2.11\phpForApache.ini
Lien symbolique créé pour j:\wamp\bin\apache\apache2.4.37\bin\php.ini <<===>> j:\wamp\bin\php\php7.2.11\phpForApache.ini

You should also check that you can copy the files instead of creating symbolic links.
So, still in the command window type:
copy /Y c:\wamp\bin\php\php5.6.31\phpForApache.ini c:\wamp\bin\apache\apache2.4.27\bin\php.ini
then Enter
The result should be like :
1 file(s) copied

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.4 32 bit - Apache 2.4.37 - PHP 7.2.12/7.1.24/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.10
Wampserver 3.1.4 64 bit - Apache 2.4.37 - PHP 7.2.12/7.1.24/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.10
PhPMyadmin 4.8.3 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »



Edited 1 time(s). Last edit at 10/28/2018 05:49PM by Otomatic.

Options: ReplyQuote
Re: Problem with extensions when installing wampserver 3.1.0
Posted by: piton (84.78.17.---)
Date: October 27, 2018 01:57PM

Hi, I'm out on Monday I look at it, thanks.

Options: ReplyQuote
Re: Problem with extensions when installing wampserver 3.1.0
Posted by: piton (---.red-95-120-228.dynamicip.rima-tde.net)
Date: October 29, 2018 10:38AM

Hello, the result for the creation of symbolic links is this:

symbolic link created for c:wamp\bin\apache\apache2.4.27\bin\p.ini <<===>> c:\wamp\bin\p\php5.6.31\phpForApache.ini


I believe it but with 0 bytes, instead when I copy it it is complete.

It seems to be a failure of my system, I have no idea what this is due to.

Options: ReplyQuote
Re: Problem with extensions when installing wampserver 3.1.0
Posted by: RiggsFolly (Moderator)
Date: October 29, 2018 11:00AM

SYMLINKS always show as 0 Bytes, that is not a problem.

Looks at the ic*.dll files in the apache/bin folder for example.

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.1.3 32bit & 64bit)
<Apache 2.4.29/2.2.31> <PHP 7.2/7.1/7.0/5.6/5.5/5.4> <MySQL 5.7.19/5.6.39/5.5.28>
<MariaDB 10.2.14> <phpMyAdmin4.8.1> <MySQL Workbench 6.3.10>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-



Edited 1 time(s). Last edit at 10/29/2018 11:01AM by RiggsFolly.

Options: ReplyQuote
Re: Problem with extensions when installing wampserver 3.1.0
Posted by: Otomatic (Moderator)
Date: October 29, 2018 11:20AM

Hi,

> I believe it but with 0 bytes, instead when I copy it it is complete.
Normal. A symbolic line has a size of 0 bit, but in the Properties (Right-click Properties), you can see which is the target in the Link tab.

While waiting to find out why symbolic link creation by PHP does not work because the symlink() function is considered non-existent, I have prepared a special update 3.1.4.1 to support copying PHP dll files and ini files instead of creating symbolic links.

The file is here Update wampserver 3.1.4.1
To download and run as an administrator.

After installation, and before starting Wampserver, modify the file wamp64/wampmanager.conf to replace:
CreateSymlink= "symlink"
by
CreateSymlink= "copy"

You may have to launch and exit Wampserver two or three times before it works properly.
It is also possible that the wampmariadb64 service will not start.
If the icon does not turn green, it is possible to see which service is not started by:
Right-click -> Tools -> Check the status of services

And, to start a service that would not have been automatically started:
Left-click -> MariaDB -> Service administration -> Start/Resume Service

You can also launch:
Right-click -> Refresh

Note : Those who may wish to use this temporary and unofficial update are warned that using the copy mode several checks cannot be performed and should only be used for troubleshooting.

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.4 32 bit - Apache 2.4.37 - PHP 7.2.12/7.1.24/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.10
Wampserver 3.1.4 64 bit - Apache 2.4.37 - PHP 7.2.12/7.1.24/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.10
PhPMyadmin 4.8.3 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: Problem with extensions when installing wampserver 3.1.0
Posted by: piton (---.red-95-120-228.dynamicip.rima-tde.net)
Date: October 29, 2018 01:03PM

Hello, After following the steps and restart the wampserver twice I remove the error of the symbolic links, but instead I still can not activate the enchant extension, I get this error.

[29-Oct-2018 11:58:42 UTC] PHP Warning: PHP Startup: Unable to load dynamic library 'c:/wamp/bin/php/php5.6.31/ext/php_enchant.dll' - No se puede encontrar el m�dulo especificado.

in Unknown on line 0

Options: ReplyQuote
Re: Problem with extensions when installing wampserver 3.1.0
Posted by: Otomatic (Moderator)
Date: October 29, 2018 02:15PM

Hi,

enchant extension is not loaded by default because you need to install other "things" to use it.
See PHP documentation [php.net]

So, uncheck it by:
Left-Click -> PHP -> Extensions -> php_enchant to uncheck

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.4 32 bit - Apache 2.4.37 - PHP 7.2.12/7.1.24/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.10
Wampserver 3.1.4 64 bit - Apache 2.4.37 - PHP 7.2.12/7.1.24/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.10
PhPMyadmin 4.8.3 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: Problem with extensions when installing wampserver 3.1.0
Posted by: piton (---.red-95-120-228.dynamicip.rima-tde.net)
Date: October 29, 2018 02:36PM

hello, you're right, to install enchant, I need to install aspell and point to php, so it seems that my problem was solved.
Thank you very much for all your help, greetings

Options: ReplyQuote
Pages: Previous12
Current Page: 2 of 2


Sorry, only registered users may post in this forum.