Pages: 12Next
Current Page: 1 of 2
Problem with extensions when installing wampserver 3.1.0
Posted by: piton (---.red-88-24-41.staticip.rima-tde.net)
Date: October 25, 2018 02:25AM

Install version 3.1.3 seems that everything works fine, except that some php extensions give problems, this is the php log when starting the wampserver for the first time.


[24-Oct-2018 23:39:37 UTC] PHP Fatal error: Call to undefined function symlink() in C:\wamp\scripts\wampserver.lib.php on line 85
[24-Oct-2018 23:39:42 UTC] PHP Warning: PHP Startup: Unable to load dynamic library 'c:/wamp/bin/php/php5.6.31/ext/php_intl.dll' - The specified module can not be found..

in Unknown on line 0

[24-Oct-2018 23:39:44 UTC] PHP Warning: PHP Startup: Unable to load dynamic library 'c:/wamp/bin/php/php5.6.31/ext/php_intl.dll' -The specified module can not be found.

in Unknown on line 0





Apache works well at least at its first start.
I followed the instructions uninstalling the previous version I had, stopping the processes, verifying that I have everything updated and ready to install the wampserver.

I reiterate that everything works fine except this problem of extensions.

What is this error?
How should I solve it?

Options: ReplyQuote
Re: Problem with extensions when installing wampserver 3.1.0
Posted by: Otomatic (Moderator)
Date: October 25, 2018 09:14AM

Hi,

> Install version 3.1.3
No more exists. The current version is 3.1.4
Did you apply all the prerequisites displayed just before the installation actually started?

Among others things:
- 1 - Verify that all VC ++ packages are installed and with the latest versions.
To do this, use the tool:
Checks VC++ packages installed
Do not use a previously loaded tool. Make a new download to make sure you are using the correct version.
To download missing packages, do not rely on Microsoft links, they are not reliable, download packages on http://wampserver.aviatechno.net in section Visual C++ Redistribuable Packages
Do not forget that if you have a 64 bit Windows, you must install both 32 and 64 bit versions of each package.
You must install each package "as an administrator", so right-click the exe file and then run as Administrator.

- 2 - Items 03 and 08 of TROUBLESHOOTING TIPS but nothing prevents you from reading all the items.

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.4 32 bit - Apache 2.4.37 - PHP 7.2.12/7.1.24/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.10
Wampserver 3.1.4 64 bit - Apache 2.4.37 - PHP 7.2.12/7.1.24/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.10
PhPMyadmin 4.8.3 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: Problem with extensions when installing wampserver 3.1.0
Posted by: piton (84.78.18.---)
Date: October 25, 2018 09:45AM

If I made all the recommendations before installation, where do you find the latest version of wampserver?

Options: ReplyQuote
Re: Problem with extensions when installing wampserver 3.1.0
Posted by: Otomatic (Moderator)
Date: October 25, 2018 10:10AM

Hi,

WAMPserver 3 - All you need to know

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.4 32 bit - Apache 2.4.37 - PHP 7.2.12/7.1.24/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.10
Wampserver 3.1.4 64 bit - Apache 2.4.37 - PHP 7.2.12/7.1.24/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.10
PhPMyadmin 4.8.3 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: Problem with extensions when installing wampserver 3.1.0
Posted by: piton (---.red-88-24-41.staticip.rima-tde.net)
Date: October 25, 2018 11:36AM

I'm still having problems, I'm sure I'm leaving something and I do not know what it is. Here I leave the log of the first wamp boot.

APACHE

[Thu Oct 25 11:32:28.851169 2018] [mpm_winnt:notice] [pid 11124:tid 668] AH00455: Apache/2.4.35 (Win32) PHP/7.2.10 configured -- resuming normal operations
[Thu Oct 25 11:32:28.851169 2018] [mpm_winnt:notice] [pid 11124:tid 668] AH00456: Apache Lounge VC15 Server built: Sep 19 2018 15:43:45
[Thu Oct 25 11:32:28.851169 2018] [core:notice] [pid 11124:tid 668] AH00094: Command line: 'c:\\wamp\\bin\\apache\\apache2.4.35\\bin\\httpd.exe -d C:/wamp/bin/apache/apache2.4.35'
[Thu Oct 25 11:32:28.851169 2018] [mpm_winnt:notice] [pid 11124:tid 668] AH00418: Parent: Created child process 4412
Zend OPcache requires Zend Engine API version 220131226.
The Zend Engine API version 320170718 which is installed, is newer.
Contact Zend Technologies at [www.zend.com] for a later version of Zend OPcache.

Xdebug requires Zend Engine API version 220131226.
The Zend Engine API version 320170718 which is installed, is newer.
Contact Derick Rethans at [xdebug.org] for a later version of Xdebug.

[Thu Oct 25 11:32:30.994901 2018] [mpm_winnt:notice] [pid 4412:tid 4] AH00354: Child: Starting 64 worker threads.



PHP

[25-Oct-2018 09:32:22 UTC] PHP Fatal error: Call to undefined function symlink() in C:\wamp\scripts\wampserver.lib.php on line 85
[25-Oct-2018 09:32:26 UTC] PHP Warning: PHP Startup: bz2: Unable to initialize module
Module compiled with module API=20131226
PHP compiled with module API=20170718
These options need to match
in Unknown on line 0
[25-Oct-2018 09:32:27 UTC] PHP Warning: PHP Startup: curl: Unable to initialize module
Module compiled with module API=20131226
PHP compiled with module API=20170718
These options need to match
in Unknown on line 0
[25-Oct-2018 09:32:27 UTC] PHP Warning: PHP Startup: com_dotnet: Unable to initialize module
Module compiled with module API=20131226
PHP compiled with module API=20170718
These options need to match
in Unknown on line 0
[25-Oct-2018 09:32:27 UTC] PHP Warning: PHP Startup: fileinfo: Unable to initialize module
Module compiled with module API=20131226
PHP compiled with module API=20170718
These options need to match
in Unknown on line 0
[25-Oct-2018 09:32:27 UTC] PHP Warning: PHP Startup: gd: Unable to initialize module
Module compiled with module API=20131226
PHP compiled with module API=20170718
These options need to match
in Unknown on line 0
[25-Oct-2018 09:32:27 UTC] PHP Warning: PHP Startup: gettext: Unable to initialize module
Module compiled with module API=20131226
PHP compiled with module API=20170718
These options need to match
in Unknown on line 0
[25-Oct-2018 09:32:27 UTC] PHP Warning: PHP Startup: gmp: Unable to initialize module
Module compiled with module API=20131226
PHP compiled with module API=20170718
These options need to match
in Unknown on line 0
[25-Oct-2018 09:32:27 UTC] PHP Warning: PHP Startup: intl: Unable to initialize module
Module compiled with module API=20131226
PHP compiled with module API=20170718
These options need to match
in Unknown on line 0
[25-Oct-2018 09:32:27 UTC] PHP Warning: PHP Startup: imap: Unable to initialize module
Module compiled with module API=20131226
PHP compiled with module API=20170718
These options need to match
in Unknown on line 0
[25-Oct-2018 09:32:27 UTC] PHP Warning: PHP Startup: ldap: Unable to initialize module
Module compiled with module API=20131226
PHP compiled with module API=20170718
These options need to match
in Unknown on line 0
[25-Oct-2018 09:32:27 UTC] PHP Warning: PHP Startup: mbstring: Unable to initialize module
Module compiled with module API=20131226
PHP compiled with module API=20170718
These options need to match
in Unknown on line 0
[25-Oct-2018 09:32:27 UTC] PHP Warning: PHP Startup: exif: Unable to initialize module
Module compiled with module API=20131226
PHP compiled with module API=20170718
These options need to match
in Unknown on line 0
[25-Oct-2018 09:32:27 UTC] PHP Warning: PHP Startup: mysql: Unable to initialize module
Module compiled with module API=20131226
PHP compiled with module API=20170718
These options need to match
in Unknown on line 0
[25-Oct-2018 09:32:28 UTC] PHP Warning: PHP Startup: mysqli: Unable to initialize module
Module compiled with module API=20131226
PHP compiled with module API=20170718
These options need to match
in Unknown on line 0
[25-Oct-2018 09:32:28 UTC] PHP Warning: PHP Startup: openssl: Unable to initialize module
Module compiled with module API=20131226
PHP compiled with module API=20170718
These options need to match
in Unknown on line 0
[25-Oct-2018 09:32:28 UTC] PHP Warning: PHP Startup: pdo_mysql: Unable to initialize module
Module compiled with module API=20131226
PHP compiled with module API=20170718
These options need to match
in Unknown on line 0
[25-Oct-2018 09:32:28 UTC] PHP Warning: PHP Startup: pdo_sqlite: Unable to initialize module
Module compiled with module API=20131226
PHP compiled with module API=20170718
These options need to match
in Unknown on line 0
[25-Oct-2018 09:32:28 UTC] PHP Warning: PHP Startup: soap: Unable to initialize module
Module compiled with module API=20131226
PHP compiled with module API=20170718
These options need to match
in Unknown on line 0
[25-Oct-2018 09:32:28 UTC] PHP Warning: PHP Startup: sockets: Unable to initialize module
Module compiled with module API=20131226
PHP compiled with module API=20170718
These options need to match
in Unknown on line 0
[25-Oct-2018 09:32:28 UTC] PHP Warning: PHP Startup: sqlite3: Unable to initialize module
Module compiled with module API=20131226
PHP compiled with module API=20170718
These options need to match
in Unknown on line 0
[25-Oct-2018 09:32:28 UTC] PHP Warning: PHP Startup: xmlrpc: Unable to initialize module
Module compiled with module API=20131226
PHP compiled with module API=20170718
These options need to match
in Unknown on line 0
[25-Oct-2018 09:32:28 UTC] PHP Warning: PHP Startup: xsl: Unable to initialize module
Module compiled with module API=20131226
PHP compiled with module API=20170718
These options need to match
in Unknown on line 0
[25-Oct-2018 09:32:28 UTC] PHP Deprecated: Directive 'track_errors' is deprecated in Unknown on line 0
[25-Oct-2018 09:32:30 UTC] PHP Warning: PHP Startup: bz2: Unable to initialize module
Module compiled with module API=20131226
PHP compiled with module API=20170718
These options need to match
in Unknown on line 0
[25-Oct-2018 09:32:30 UTC] PHP Warning: PHP Startup: curl: Unable to initialize module
Module compiled with module API=20131226
PHP compiled with module API=20170718
These options need to match
in Unknown on line 0
[25-Oct-2018 09:32:30 UTC] PHP Warning: PHP Startup: com_dotnet: Unable to initialize module
Module compiled with module API=20131226
PHP compiled with module API=20170718
These options need to match
in Unknown on line 0
[25-Oct-2018 09:32:30 UTC] PHP Warning: PHP Startup: fileinfo: Unable to initialize module
Module compiled with module API=20131226
PHP compiled with module API=20170718
These options need to match
in Unknown on line 0
[25-Oct-2018 09:32:30 UTC] PHP Warning: PHP Startup: gd: Unable to initialize module
Module compiled with module API=20131226
PHP compiled with module API=20170718
These options need to match
in Unknown on line 0
[25-Oct-2018 09:32:30 UTC] PHP Warning: PHP Startup: gettext: Unable to initialize module
Module compiled with module API=20131226
PHP compiled with module API=20170718
These options need to match
in Unknown on line 0
[25-Oct-2018 09:32:30 UTC] PHP Warning: PHP Startup: gmp: Unable to initialize module
Module compiled with module API=20131226
PHP compiled with module API=20170718
These options need to match
in Unknown on line 0
[25-Oct-2018 09:32:30 UTC] PHP Warning: PHP Startup: intl: Unable to initialize module
Module compiled with module API=20131226
PHP compiled with module API=20170718
These options need to match
in Unknown on line 0
[25-Oct-2018 09:32:30 UTC] PHP Warning: PHP Startup: imap: Unable to initialize module
Module compiled with module API=20131226
PHP compiled with module API=20170718
These options need to match
in Unknown on line 0
[25-Oct-2018 09:32:30 UTC] PHP Warning: PHP Startup: ldap: Unable to initialize module
Module compiled with module API=20131226
PHP compiled with module API=20170718
These options need to match
in Unknown on line 0
[25-Oct-2018 09:32:30 UTC] PHP Warning: PHP Startup: mbstring: Unable to initialize module
Module compiled with module API=20131226
PHP compiled with module API=20170718
These options need to match
in Unknown on line 0
[25-Oct-2018 09:32:30 UTC] PHP Warning: PHP Startup: exif: Unable to initialize module
Module compiled with module API=20131226
PHP compiled with module API=20170718
These options need to match
in Unknown on line 0
[25-Oct-2018 09:32:30 UTC] PHP Warning: PHP Startup: mysql: Unable to initialize module
Module compiled with module API=20131226
PHP compiled with module API=20170718
These options need to match
in Unknown on line 0
[25-Oct-2018 09:32:30 UTC] PHP Warning: PHP Startup: mysqli: Unable to initialize module
Module compiled with module API=20131226
PHP compiled with module API=20170718
These options need to match
in Unknown on line 0
[25-Oct-2018 09:32:30 UTC] PHP Warning: PHP Startup: openssl: Unable to initialize module
Module compiled with module API=20131226
PHP compiled with module API=20170718
These options need to match
in Unknown on line 0
[25-Oct-2018 09:32:30 UTC] PHP Warning: PHP Startup: pdo_mysql: Unable to initialize module
Module compiled with module API=20131226
PHP compiled with module API=20170718
These options need to match
in Unknown on line 0
[25-Oct-2018 09:32:30 UTC] PHP Warning: PHP Startup: pdo_sqlite: Unable to initialize module
Module compiled with module API=20131226
PHP compiled with module API=20170718
These options need to match
in Unknown on line 0
[25-Oct-2018 09:32:30 UTC] PHP Warning: PHP Startup: soap: Unable to initialize module
Module compiled with module API=20131226
PHP compiled with module API=20170718
These options need to match
in Unknown on line 0
[25-Oct-2018 09:32:30 UTC] PHP Warning: PHP Startup: sockets: Unable to initialize module
Module compiled with module API=20131226
PHP compiled with module API=20170718
These options need to match
in Unknown on line 0
[25-Oct-2018 09:32:30 UTC] PHP Warning: PHP Startup: sqlite3: Unable to initialize module
Module compiled with module API=20131226
PHP compiled with module API=20170718
These options need to match
in Unknown on line 0
[25-Oct-2018 09:32:30 UTC] PHP Warning: PHP Startup: xmlrpc: Unable to initialize module
Module compiled with module API=20131226
PHP compiled with module API=20170718
These options need to match
in Unknown on line 0
[25-Oct-2018 09:32:30 UTC] PHP Warning: PHP Startup: xsl: Unable to initialize module
Module compiled with module API=20131226
PHP compiled with module API=20170718
These options need to match
in Unknown on line 0
[25-Oct-2018 09:32:30 UTC] PHP Deprecated: Directive 'track_errors' is deprecated in Unknown on line 0





check the visual c ++ with the wampserver tool and it is all installed correctly, apart from the other requirements

Options: ReplyQuote
Re: Problem with extensions when installing wampserver 3.1.0
Posted by: Otomatic (Moderator)
Date: October 25, 2018 12:42PM

Hi,

What version of Windows ?
Is your disk formatted NTFS ?

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.4 32 bit - Apache 2.4.37 - PHP 7.2.12/7.1.24/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.10
Wampserver 3.1.4 64 bit - Apache 2.4.37 - PHP 7.2.12/7.1.24/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.10
PhPMyadmin 4.8.3 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: Problem with extensions when installing wampserver 3.1.0
Posted by: piton (---.red-88-24-41.staticip.rima-tde.net)
Date: October 25, 2018 12:48PM

Hello, if you have NTFS format, the windows10 version was updated from the w7.

regards

Options: ReplyQuote
Re: Problem with extensions when installing wampserver 3.1.0
Posted by: Otomatic (Moderator)
Date: October 25, 2018 01:10PM

Hi,

Follow all steps of TROUBLESHOOTING TIPS

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.4 32 bit - Apache 2.4.37 - PHP 7.2.12/7.1.24/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.10
Wampserver 3.1.4 64 bit - Apache 2.4.37 - PHP 7.2.12/7.1.24/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.10
PhPMyadmin 4.8.3 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: Problem with extensions when installing wampserver 3.1.0
Posted by: piton (---.red-88-24-41.staticip.rima-tde.net)
Date: October 25, 2018 03:49PM

hello, I read again the instructions for the installation, this time I decided to install a less version of wampserver for having avoid conflicts with zend extensions, the version that install is 3.1.0 and when starting the wamp shows me these errors in php.

log php

[25-Oct-2018 12:51:55 UTC] PHP Fatal error: Call to undefined function symlink() in C:\wamp\scripts\wampserver.lib.php on line 85
[25-Oct-2018 12:51:55 UTC] PHP Warning: PHP Startup: Unable to load dynamic library 'c:/wamp/bin/php/php5.6.31/ext/php_intl.dll' - No se puede encontrar el m�dulo especificado.

in Unknown on line 0



make exactly the recommendations or I think so, disable iis run the wampserver installer from administrator, check visual ++, ...

what causes can be to get the first error, in my path there is nothing pointing to wampserver since it does not need it.

when I start the wamp I also do it from the administrator.





verify that there was not a php.ini before the installation, this is the exit after the installation, there may be my problem.



El volumen de la unidad C es Windows10
El número de serie del volumen es: 7072-0C26

Directorio de C:\wamp\bin\apache\apache2.4.27\bin

25/10/2018 14:13 <SYMLINK> php.ini [c:\wamp\bin\php\php5.6.31\phpForApache.ini]
1 archivos 0 bytes

Directorio de C:\wamp\bin\php\php5.6.31

25/10/2018 16:04 76.281 php.ini
1 archivos 76.281 bytes

Directorio de C:\wamp\bin\php\php7.0.23

25/10/2018 14:13 73.122 php.ini
1 archivos 73.122 bytes

Directorio de C:\wamp\bin\php\php7.1.9

25/10/2018 14:13 73.592 php.ini
1 archivos 73.592 bytes

Total de archivos en la lista:
4 archivos 222.995 bytes
0 dirs 62.653.841.408 bytes libres



Edited 1 time(s). Last edit at 10/25/2018 04:21PM by piton.

Options: ReplyQuote
Re: Problem with extensions when installing wampserver 3.1.0
Posted by: Otomatic (Moderator)
Date: October 25, 2018 04:29PM

Hi,

symlink() is a PHP function not a Wampserver specific function.

In view of the error messages stipulating different versions of the APIs between the PHP version and the extensions:
Module compiled with module API=20131226
PHP compiled with module API=20170718

The loaded PHP version is compiled with VC+++ 2017 (VC15) and the loaded extensions are compiled with VC 2013 (VC11).
However, all PHP versions and their extensions installed by Wampserver are intrinsically compiled with the same VC version.

So, there is
- another version of PHP on your disk,
- or a php.ini file somewhere other than in the c:\wamp tree structure
- or a path to a PHP version in the PATH environment variable
- or a combination of the previous options

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.4 32 bit - Apache 2.4.37 - PHP 7.2.12/7.1.24/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.10
Wampserver 3.1.4 64 bit - Apache 2.4.37 - PHP 7.2.12/7.1.24/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.10
PhPMyadmin 4.8.3 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: Problem with extensions when installing wampserver 3.1.0
Posted by: piton (---.red-88-24-41.staticip.rima-tde.net)
Date: October 25, 2018 04:40PM

The PATH is correct and I do not have any php.ini, it could be that I already had a php installed, how could I verify that?
Thank you

Options: ReplyQuote
Re: Problem with extensions when installing wampserver 3.1.0
Posted by: Otomatic (Moderator)
Date: October 25, 2018 04:58PM

Hi,

> it could be that I already had a php installed, how could I verify that?
It's your system. Basic Windows has no PHP installed. So, if you say there could be a PHP installed, you did it.

What is the result, in a command window of:

C:\>dir /s php.ini

To avoid having to copy the result, if you type:

C:\>dir /s php.ini | clip

the result will go directly to the clipboard.

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.4 32 bit - Apache 2.4.37 - PHP 7.2.12/7.1.24/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.10
Wampserver 3.1.4 64 bit - Apache 2.4.37 - PHP 7.2.12/7.1.24/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.10
PhPMyadmin 4.8.3 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: Problem with extensions when installing wampserver 3.1.0
Posted by: piton (---.red-88-24-41.staticip.rima-tde.net)
Date: October 25, 2018 05:29PM

Remove wampserver.


C:\>dir /s php.ini | clip

he tells me that the file is not found


I have not used wampserver for a while but I remember changing php before and also changing the php version of the previous wampserver.

What else can I do?

Options: ReplyQuote
Re: Problem with extensions when installing wampserver 3.1.0
Posted by: Otomatic (Moderator)
Date: October 25, 2018 06:06PM

Hi,

Quote
piton
C:\>dir /s php.ini | clip

he tells me that the file is not found
There's a problem, the result should at least give the php.ini files that are in c:\wamp\bin\php\php5.6.31\, c:\wamp\bin\php\php7.0.23\, c:\wamp\bin\php\php7.1.9\ and in c:\wamp\bin\apache2.4.27\bin\

In the c:\wamp\wampmanager.conf file what are the lines :

- phpVersion =
- phpCliVersion

In the service manager (Run: services.msc) for the wampapache service, properties, what is the content of :
- Description:
- Access path of exec files:

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.4 32 bit - Apache 2.4.37 - PHP 7.2.12/7.1.24/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.10
Wampserver 3.1.4 64 bit - Apache 2.4.37 - PHP 7.2.12/7.1.24/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.10
PhPMyadmin 4.8.3 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: Problem with extensions when installing wampserver 3.1.0
Posted by: piton (84.78.18.---)
Date: October 25, 2018 06:23PM

no php.ini comes out because uninstall the wampserver.
Could it be a problem instead of php that was Apache?
greetings and thanks for helping

Options: ReplyQuote
Re: Problem with extensions when installing wampserver 3.1.0
Posted by: Otomatic (Moderator)
Date: October 25, 2018 06:32PM

Hi,

> no php.ini comes out because uninstall the wampserver.

I wonder if this is a test, a kind of hidden camera, but here, as they say in France, "I'm pedalling in sauerkraut"
You just wrote that there is no php.ini file because you uninstalled Wampserver; if there is no more Wampserver there is no more problem.
I don't understand anything anymore!

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.4 32 bit - Apache 2.4.37 - PHP 7.2.12/7.1.24/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.10
Wampserver 3.1.4 64 bit - Apache 2.4.37 - PHP 7.2.12/7.1.24/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.10
PhPMyadmin 4.8.3 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: Problem with extensions when installing wampserver 3.1.0
Posted by: piton (84.78.18.---)
Date: October 25, 2018 06:40PM

I thought the conflict was in another php version installed without wampserver, so uninstall wampserver to find that installed php version and be able to install the wampserver again. If that was the error, I had to reinstall the wampserver.

Options: ReplyQuote
Re: Problem with extensions when installing wampserver 3.1.0
Posted by: Otomatic (Moderator)
Date: October 25, 2018 06:58PM

Hi,

Before reinstalling Wampserver, it is necessary to check that the two (or three) services used by Wampserver have been deleted.
In the service manager (Run : services.msc) Check for the possible presence of services whose name begins with "wamp.....".
If services still exist, note the names, exit the service manager and in a command window (as administrator) type:

sc delete service_name

If the wampapache service still existed, it would be:

sc delete wampapache

It is imperative that the services no longer exist before installing Wampserver.

Note : See you tomorrow, it's closing time.

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.4 32 bit - Apache 2.4.37 - PHP 7.2.12/7.1.24/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.10
Wampserver 3.1.4 64 bit - Apache 2.4.37 - PHP 7.2.12/7.1.24/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.10
PhPMyadmin 4.8.3 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »



Edited 1 time(s). Last edit at 10/26/2018 09:15AM by Otomatic.

Options: ReplyQuote
Re: Problem with extensions when installing wampserver 3.1.0
Posted by: piton (---.red-88-24-41.staticip.rima-tde.net)
Date: October 25, 2018 10:25PM

Hi, I have no service started, good night.

Options: ReplyQuote
Re: Problem with extensions when installing wampserver 3.1.0
Posted by: Otomatic (Moderator)
Date: October 26, 2018 09:19AM

Hi,

> I have no service started

I didn't write that there shouldn't be "wamp..." services started, but that there shouldn't be "wamp..." services in the service manager before installing Wampserver.
So, if there are one or more "wamp......" services, they must be deleted before installing Wampserver.

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.4 32 bit - Apache 2.4.37 - PHP 7.2.12/7.1.24/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.10
Wampserver 3.1.4 64 bit - Apache 2.4.37 - PHP 7.2.12/7.1.24/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.10
PhPMyadmin 4.8.3 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Pages: 12Next
Current Page: 1 of 2


Sorry, only registered users may post in this forum.