my rewrite is something wrong
Posted by: bixinchao (1.194.20.---)
Date: August 16, 2018 03:59PM

I have searched, nothing.
wampserver 3.0 64
I use .htaccess, It not work as i mind,
I find wam have defalut rewrite rule, and my rule cant high to defalut
i remove .htaccess. the defalut rewreite rule real work
e.g:/news/123.html the defalut is /news.php/123.html
my own rule is /news.php?id=123,but not work,
my english is poor, can you see my word ? thx!

Options: ReplyQuote
Re: my rewrite is something wrong
Posted by: RiggsFolly (Moderator)
Date: August 16, 2018 04:13PM

Hi,

There are ABSOLUTELY NO .htaccess files delivered as part of WAMPServer. If you have one, then either the app/site you installed placed it there or you did it yourself.

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.1.3 32bit & 64bit)
<Apache 2.4.29/2.2.31> <PHP 7.2/7.1/7.0/5.6/5.5/5.4> <MySQL 5.7.19/5.6.39/5.5.28>
<MariaDB 10.2.14> <phpMyAdmin4.8.1> <MySQL Workbench 6.3.10>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-

Options: ReplyQuote
Re: my rewrite is something wrong
Posted by: bixinchao (1.194.20.---)
Date: August 17, 2018 08:01AM

oh thx,
I said Not exactly before
I find,If the URL is the first nonexistent folder name is the file name, he will be converted, not only php,
html,jpg, and even my arbitrarily built 123 suffix will be like this too.

the screenshots:
[imgur.com]



Edited 1 time(s). Last edit at 08/17/2018 08:42AM by bixinchao.

Options: ReplyQuote
Re: my rewrite is something wrong
Posted by: bixinchao (65.49.68.---)
Date: September 06, 2018 12:37PM

hello , it append after add alise,
on wamp2 it only append alise,
on wamp3 the defalut append too, the prev review picture isreal.

Options: ReplyQuote
Re: my rewrite is something wrong
Posted by: bixinchao (65.49.68.---)
Date: September 06, 2018 12:42PM

and on wamp2, my arbitrarily built 123 suffix not work

Options: ReplyQuote
Re: my rewrite is something wrong
Posted by: RiggsFolly (Moderator)
Date: September 06, 2018 12:50PM

I am really not sure exactly what you are saying here

BUT

This is nothing to do with WAMPServer, this is totally a site issue.

Nothing in WAMPServer does anything with favicons that are not done by Apache, and it is a vanilla Apache that is delivered by WAMPServer.

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.1.3 32bit & 64bit)
<Apache 2.4.29/2.2.31> <PHP 7.2/7.1/7.0/5.6/5.5/5.4> <MySQL 5.7.19/5.6.39/5.5.28>
<MariaDB 10.2.14> <phpMyAdmin4.8.1> <MySQL Workbench 6.3.10>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-

Options: ReplyQuote


Sorry, only registered users may post in this forum.