Installed 3.1.3 64bit no access permission for virtual hosts
Posted by: jbwebworks (---.pn.at.cox.net)
Date: July 26, 2018 10:00PM

My httpd-vhosts

# Virtual Hosts
#
<VirtualHost *:80>
  ServerName localhost
  ServerAlias localhost
  DocumentRoot "${INSTALL_DIR}/www"
  <Directory "${INSTALL_DIR}/www/">
    Options +Indexes +Includes +FollowSymLinks +MultiViews
    AllowOverride All
    Require local
  </Directory>
</VirtualHost>



Edited 1 time(s). Last edit at 07/27/2018 12:18AM by RiggsFolly.

Options: ReplyQuote
Re: Installed 3.1.3 64bit no access permission for virtual hosts
Posted by: RiggsFolly (Moderator)
Date: July 27, 2018 12:19AM

Hi,

?

Would you care to explain what problem you are having please. We are not clairvoyant

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.1.3 32bit & 64bit)
<Apache 2.4.29/2.2.31> <PHP 7.2/7.1/7.0/5.6/5.5/5.4> <MySQL 5.7.19/5.6.39/5.5.28>
<MariaDB 10.2.14> <phpMyAdmin4.8.1> <MySQL Workbench 6.3.10>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-



Edited 1 time(s). Last edit at 07/27/2018 01:42AM by RiggsFolly.

Options: ReplyQuote
Re: Installed 3.1.3 64bit no access permission for virtual hosts
Posted by: jbwebworks (---.pn.at.cox.net)
Date: July 27, 2018 01:41AM

I installed wampserver 3.1.3 64bit as an administrator on windows 10.
IIS is disabled. I can go to localhost home page and also phpmyadmin.
I have several virtual hosts and when I go to home page and click on add a virtual host my path to the files is C:\vhosts\echealthfinance
I then go to tools and restart DNS.

when I try to access the virtual host site of [echealthfinance] on firefox, I get this error

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator at wampserver@wampserver.invalid to inform them of the time this error occurred, and the actions you performed just before this error.

More information about this error may be available in the server error log.
Apache/2.4.33 (Win64) PHP/5.6.35 Server at echealthfinance Port 80


here is the current httpd-vhosts.conf
# Virtual Hosts
#
<VirtualHost *:80>
ServerName localhost
ServerAlias localhost
DocumentRoot "${INSTALL_DIR}/www"
<Directory "${INSTALL_DIR}/www/">
Options +Indexes +Includes +FollowSymLinks +MultiViews
AllowOverride All
Require local
</Directory>
</VirtualHost>


#
<VirtualHost *:80>
ServerName echealthfinance
DocumentRoot "c:/vhosts/echealthfinance"
<Directory "c:/vhosts/echealthfinance/">
Options +Indexes +Includes +FollowSymLinks +MultiViews
AllowOverride All
Require local
</Directory>
</VirtualHost>



Edited 1 time(s). Last edit at 07/27/2018 01:43AM by jbwebworks.

Options: ReplyQuote
Re: Installed 3.1.3 64bit no access permission for virtual hosts
Posted by: RiggsFolly (Moderator)
Date: July 27, 2018 01:47AM

Ok,

The mechanism used to restart the DNS Cache has changed recently in Window 10 and WAMPSever has not yet caught up. The fix will be in the next version of WAMPServer.

So either reboot to restart the DNS Cache or launch a command window and run

ipconfig /flushdns

If this does not work for you, please post your Virtual host definitions and your HOSTS file contents

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.1.3 32bit & 64bit)
<Apache 2.4.29/2.2.31> <PHP 7.2/7.1/7.0/5.6/5.5/5.4> <MySQL 5.7.19/5.6.39/5.5.28>
<MariaDB 10.2.14> <phpMyAdmin4.8.1> <MySQL Workbench 6.3.10>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-

Options: ReplyQuote
Re: Installed 3.1.3 64bit no access permission for virtual hosts
Posted by: jbwebworks (---.pn.at.cox.net)
Date: July 27, 2018 03:30AM

Did not work. Still getting the internal server error.
This is from the error log

[Thu Jul 26 19:10:10.198872 2018] [core:alert] [pid 1084:tid 1224] [client ::1:52006] C:/vhosts/echealthfinance/.htaccess: Invalid command 'AddOutputFilterByType', perhaps misspelled or defined by a module not included in the server configuration
[Thu Jul 26 19:10:11.785587 2018] [core:alert] [pid 1084:tid 1224] [client ::1:52014] C:/vhosts/echealthfinance/.htaccess: Invalid command 'AddOutputFilterByType', perhaps misspelled or defined by a module not included in the server configuration
[Thu Jul 26 19:10:11.786475 2018] [core:alert] [pid 1084:tid 1220] [client ::1:52015] C:/vhosts/echealthfinance/.htaccess: Invalid command 'AddOutputFilterByType', perhaps misspelled or defined by a module not included in the server configuration
[Thu Jul 26 19:10:52.688541 2018] [core:alert] [pid 1084:tid 1224] [client ::1:52025] C:/vhosts/echealthfinance/.htaccess: Invalid command 'AddOutputFilterByType', perhaps misspelled or defined by a module not included in the server configuration

the hosts file contents are the website files for www.echealthfinance.org

Options: ReplyQuote
Re: Installed 3.1.3 64bit no access permission for virtual hosts
Posted by: Otomatic (Moderator)
Date: July 27, 2018 08:24AM

Hi,

99% of Internal Server Error errors are due to one or more errors in an .htaccess file.
And there, you just have to read the errors - which everyone should do BEFORE coming to ask questions.

> .htaccess: Invalid command 'AddOutputFilterByType', perhaps misspelled or defined by a module not included in the server configuration

It's clear, though, and you don't have to come out of Polytechnique or Harvard to understand.
There is a syntax error associated with 'AddOutputFilterByType' or an Apache module not loaded.
And in such a case, the best thing is to read the relevant documentation.

Apache Documentation [httpd.apache.org]

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.6 32 bit - Apache 2.4.37 - PHP 7.3.0/7.2.13/7.1.25/7.0.33/5.6.39 - MySQL 5.7.23 - MariaDB 10.3.11
Wampserver 3.1.6 64 bit - Apache 2.4.37 - PHP 7.3.0/7.2.13/7.1.25/7.0.33/5.6.39 - MySQL 5.7.23 - MariaDB 10.3.11
PhPMyadmin 4.8.3 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »



Edited 1 time(s). Last edit at 07/27/2018 09:33AM by Otomatic.

Options: ReplyQuote
Re: Installed 3.1.3 64bit no access permission for virtual hosts
Posted by: jbwebworks (---.pn.at.cox.net)
Date: July 27, 2018 02:22PM

Yes, the problem is in my .htaccess file in the vhosts folder.
I removed the .htaccess file and no longer get the error.

Not sure what my syntax error is in the .htaccess file but that is not your problem.

Thanks for your assistance.

Options: ReplyQuote


Sorry, only registered users may post in this forum.