Wampserver installation Windows 10 broken
Posted by: maikens (---.eastlink.ca)
Date: July 09, 2018 02:59PM

I installed the latest version of Wampserver from sourceforge.net on a clean install of Windows 10 and I encountered about 15 errors during installation, which reported successful completion in about 5 seconds after the error messages were dismissed. Wampserver came up in my tray as an orange icon, saying 1 of 3 processes were started. Clicking the icon does nothing, nor does right-click.

Options: ReplyQuote
Re: Wampserver installation Windows 10 broken
Posted by: maikens (---.eastlink.ca)
Date: July 09, 2018 03:11PM

I got the following error messages multiple times. This is after choosing default web browser and text editor:

- MSVCR120.dll was not found
- VCRUNTIME13.dll was not found

Afterward the installation continues with "Some explanations on how Wampserver works. I am then advised Wampserver has been successfully installed on my machine, and given the option to exit setup.

A correction to my original post: the icon does not show up in the tray until I run the program, where I get the first error about the MSVCR120.dll missing, and then I get the orange icon that does nothing.

Options: ReplyQuote
Re: Wampserver installation Windows 10 broken
Posted by: Otomatic (Moderator)
Date: July 09, 2018 03:17PM

Hi,

It would be nice to say exactly what errors you've had.

There is a high probability that you have neither read nor applied the prerequisites that are displayed just before the Wampserver installation actually starts.

- Uninstall Wampserver : IMPERATIVE
- Verify that all VC ++ packages are installed and with the latest versions.
To do this, use the tool:
Checks VC++ packages installed
And you will find all the packages on [wampserver.aviatechno.net] in section Visual C++ Redistribuable Packages
Do not forget that if you have a 64 bit Windows, you must install both 32 and 64 bit versions of each package.
You must install each package "as an administrator", so right-click the exe file and then run as Administrator.
Do not use a previously loaded tool. Make a new download to make sure you are using the correct version.

And, as requested in the prerequisites, before reinstalling Wampserver, you still need to check items 03 and 08 of TROUBLESHOOTING TIPS

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.3 32 bit - Apache 2.4.33 - PHP 7.2.7/7.1.19/7.0.30/5.6.36 - MySQL 5.7.22 - MariaDB 10.3.8
Wampserver 3.1.3 64 bit - Apache 2.4.33 - PHP 7.2.7/7.1.19/7.0.30/5.6.36 - MySQL 5.7.22 - MariaDB 10.3.8
PhPMyAdmin 4.8.2 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: Wampserver installation Windows 10 broken
Posted by: maikens (---.eastlink.ca)
Date: July 11, 2018 05:42PM

I listed both errors I received. I ran the tool you provided, thank you. It appears I am indeed missing some dependencies... so many, in fact, that I cannot close the windows dialog that displays the list without Task Manager.

Options: ReplyQuote


Sorry, only registered users may post in this forum.