Only click Remove service can start Apache
Posted by: juhann (---.155.143.219.broad.bj.bj.dynamic.163data.com.cn)
Date: July 05, 2018 01:00AM

I installed Wampserver 3.0.6 on Windows10, and it show orange icon when i run the wampserver and apache service can not start, mysql service is started.

BUT, when i click "Remove Service" in Apache, apache service is STARTED. and now i can see httpd.exe in service list. Can anyone help to comment what is the problem?

1. Visual C++ Packages is correctly installed
2. 80 is not used

When apache can not be started, i checked the Window error log, it shows:
Log name: Application

Source: Application Error

Date: 2018/7/5 6:11:54

Event ID: 1000

Task categories: (100)

Level: error

Keyword: Classic

Users: vacant

Description:

Wrong application name: httpd.exe, version: 2.4.23.0, timestamp: 0x5776399f

Wrong module name: ucrtbase.dll, version: 10.0.16299.15, timestamp: 0x70f70cc4

Exception code: 0xc0000409

Error offset: 0x000000000006a478

Error process ID: 0xda4

Error application startup time: 0x01d413e403f5e61d

Wrong application path: D:\\wamp64\\bin\\apache\\apache2.4.23\\bin\\httpd.exe

Wrong module path: C:\\windows\\System32\\ucrtbase.dll

Report ID: fb57aa1f-030f-49d4-89b5-9efd88f7452f

Full name of the error package:

Error package relative application ID:

Event Xml:
<Event xmlns="[schemas.microsoft.com];
<System>
<Provider Name="Application Error" />
<EventID Qualifiers="0">1000</EventID>
<Level>2</Level>
<Task>100</Task>
<Keywords>0x80000000000000</Keywords>
<TimeCreated SystemTime="2018-07-04T22:11:54.438622700Z" />
<EventRecordID>3595</EventRecordID>
<Channel>Application</Channel>
<Computer>Hans</Computer>
<Security />
</System>
<EventData>
<Data>httpd.exe</Data>
<Data>2.4.23.0</Data>
<Data>5776399f</Data>
<Data>ucrtbase.dll</Data>
<Data>10.0.16299.15</Data>
<Data>70f70cc4</Data>
<Data>c0000409</Data>
<Data>000000000006a478</Data>
<Data>da4</Data>
<Data>01d413e403f5e61d</Data>
<Data>D:\wamp64\bin\apache\apache2.4.23\bin\httpd.exe</Data>
<Data>C:\windows\System32\ucrtbase.dll</Data>
<Data>fb57aa1f-030f-49d4-89b5-9efd88f7452f</Data>
<Data>
</Data>
<Data>
</Data>
</EventData>
</Event>

Options: ReplyQuote
Re: Only click Remove service can start Apache
Posted by: RiggsFolly (Moderator)
Date: July 05, 2018 01:54AM

At a guess you had another Apache installed and that was auto started.

However, not sure that doing a remove service will have removed the old one, so you may have removed the WAMPServer service.

Check for and uninstall the other Apache.
Then do a Install Service to get WAMPServers Apache back

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.1.3 32bit & 64bit)
<Apache 2.4.29/2.2.31> <PHP 7.2/7.1/7.0/5.6/5.5/5.4> <MySQL 5.7.19/5.6.39/5.5.28>
<MariaDB 10.2.14> <phpMyAdmin4.8.1> <MySQL Workbench 6.3.10>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-

Options: ReplyQuote
Re: Only click Remove service can start Apache
Posted by: juhann (---.155.143.219.broad.bj.bj.dynamic.163data.com.cn)
Date: July 05, 2018 02:16AM

Thanks

But i don't find another installed Apache, and after i shut down all existing httpd.exe in service and install apache again and try to start, new service still can not be started.

Options: ReplyQuote
Re: Only click Remove service can start Apache
Posted by: juhann (---.155.143.219.broad.bj.bj.dynamic.163data.com.cn)
Date: July 05, 2018 03:42AM

if i run httpd.exe, it will start and window remains.

if i run httpd.exe -k xxx it will start and stop, window closed

Options: ReplyQuote
Re: Only click Remove service can start Apache
Posted by: Otomatic (Moderator)
Date: July 05, 2018 09:20AM

Hi,

- Verify that all VC ++ packages are installed and with the latest versions.
To do this, use the tool:
Checks VC++ packages installed
And you will find all the packages on [wampserver.aviatechno.net] in section Visual C++ Redistribuable Packages
Do not forget that if you have a 64 bit Windows, you must install both 32 and 64 bit versions of each package.
You must install each package "as an administrator", so right-click the exe file and then run as Administrator.
Do not use a previously loaded tool. Make a new download to make sure you are using the correct version.

> I installed Wampserver 3.0.6
Where did you find a version 3.0.6 of Wampserver?
The latest version is 3.1.3.
On both Sourceforge and [wampserver.aviatechno.net], there is no 3.0.6 installer.

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.3 32 bit - Apache 2.4.34 - PHP 7.2.10/7.1.22/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.9
Wampserver 3.1.3 64 bit - Apache 2.4.34 - PHP 7.2.10/7.1.22/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.9
PhPMyadmin 4.8.3 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote


Sorry, only registered users may post in this forum.