wampserver apache
Posted by: User_maya (---.centertel.pl)
Date: May 30, 2018 09:01AM

Hello,
After upgrading Windows 10 my wampserver is not working, 1 of 2 servieces running. I tried to edit httpd.conf like everyone says, but this file is encoded, all I can see its 0000 0000... What can I do?

Options: ReplyQuote
Re: wampserver apache
Posted by: Otomatic (Moderator)
Date: May 30, 2018 09:40AM

Hi,

> but this file is encoded
NO. It is a simple text file.

- Verify that all VC ++ packages are installed and with the latest versions.
To do this, use the tool:
Checks VC++ packages installed
And you will find all the packages on [wampserver.aviatechno.net] in section Visual C++ Redistribuable Packages
Do not forget that if you have a 64 bit Windows, you must install both 32 and 64 bit versions of each package.
You must install each package "as an administrator", so right-click the exe file and then run as Administrator.
Do not use a previously loaded tool. Make a new download to make sure you are using the correct version.

- If it is not already done, apply Update 3.1.3 to your version of Wampserver
Wampserver update 3.1.3

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.4 32 bit - Apache 2.4.35 - PHP 7.2.11/7.1.23/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.10
Wampserver 3.1.4 64 bit - Apache 2.4.35 - PHP 7.2.11/7.1.23/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.10
PhPMyadmin 4.8.3 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: wampserver apache
Posted by: RiggsFolly (Moderator)
Date: May 30, 2018 09:54AM

Hi

Do you mean you upgraded to Windows 10 from another version of Windows, or, you applied an normal Windows 10 update on top of an existing version of Windows 10?

If you moved to Windows 10 from another version of Windows then the Windows 10 install does not add all the MSVC runtime libraries, one of which you appear to require.

In this case you should also install ALL the MSVC Runtimes as mentioned in Oto's answer.
If you are using 64bit version of Windows and a 64bit version of WAMPServer then you should apply both the 32bit and 64bit MSVC Runtimes.

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.1.3 32bit & 64bit)
<Apache 2.4.29/2.2.31> <PHP 7.2/7.1/7.0/5.6/5.5/5.4> <MySQL 5.7.19/5.6.39/5.5.28>
<MariaDB 10.2.14> <phpMyAdmin4.8.1> <MySQL Workbench 6.3.10>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-

Options: ReplyQuote
Re: wampserver apache
Posted by: User_maya (---.centertel.pl)
Date: May 30, 2018 10:27AM

Before upgrading I had Windows 10. I installed all pages - "All VC ++ packages needed to Wampserver are installed correctly". Still orange icon and 1 of 2 services running.

Options: ReplyQuote
Re: wampserver apache
Posted by: Otomatic (Moderator)
Date: May 30, 2018 11:41AM

Hi,

> Still orange icon and 1 of 2 services running.
Result of :
Right-Clcik -> Tools -> Test port 80

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.4 32 bit - Apache 2.4.35 - PHP 7.2.11/7.1.23/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.10
Wampserver 3.1.4 64 bit - Apache 2.4.35 - PHP 7.2.11/7.1.23/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.10
PhPMyadmin 4.8.3 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: wampserver apache
Posted by: User_maya (---.centertel.pl)
Date: May 30, 2018 12:05PM

"Your port 80 is not actually used"

Options: ReplyQuote
Re: wampserver apache
Posted by: RiggsFolly (Moderator)
Date: May 30, 2018 12:35PM

Hi

1. Are you using Port 80 for Apache?
2. Had you changed the port number that Apache was using?
3. Have you looked at the Apache error log?
4. Have you looked at the Windows Event Log for error messages from Apache (also look for errors from MySQL)

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.1.3 32bit & 64bit)
<Apache 2.4.29/2.2.31> <PHP 7.2/7.1/7.0/5.6/5.5/5.4> <MySQL 5.7.19/5.6.39/5.5.28>
<MariaDB 10.2.14> <phpMyAdmin4.8.1> <MySQL Workbench 6.3.10>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-

Options: ReplyQuote
Re: wampserver apache
Posted by: User_maya (---.centertel.pl)
Date: May 30, 2018 01:51PM

1. i'm not sure, how can I check that?
2. I don't remember doing it
3. File apache error log is empty
4. I found errors:

The Apache service named reported the following error:
>>> AH00558: httpd.exe: Could not reliably determine the server's fully qualified domain name, using ::1. Set the 'ServerName' directive globally to suppress this message

The Apache service named reported the following error:
>>> AH00451: no listening sockets available, shutting down

The Apache service named reported the following error:
>>> AH00015: Unable to open logs

Options: ReplyQuote
Re: wampserver apache
Posted by: Otomatic (Moderator)
Date: May 30, 2018 03:06PM

Hi,

Please READ (and answer) BEFORE YOU ASK A QUESTION

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.4 32 bit - Apache 2.4.35 - PHP 7.2.11/7.1.23/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.10
Wampserver 3.1.4 64 bit - Apache 2.4.35 - PHP 7.2.11/7.1.23/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.10
PhPMyadmin 4.8.3 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: wampserver apache
Posted by: User_maya (---.centertel.pl)
Date: May 30, 2018 03:20PM

Sorry,



Set the 'ServerName' directive globally to suppress this message
?
Sorry, I dont' understand, should I change server name somewhere?



Edited 1 time(s). Last edit at 05/30/2018 06:00PM by User_maya.

Options: ReplyQuote
Re: wampserver apache
Posted by: User_maya (---.centertel.pl)
Date: May 30, 2018 09:24PM

I think my file httpd.conf was damaged. I copied httpd.conf from folder Orginal and paste where was this file with 0000. Changed path for document root and server root. Now its green icon.
Many thanks

Options: ReplyQuote


Sorry, only registered users may post in this forum.