Cannot install Composer because error in Wamp
Posted by: peterkn (---.rev.stofanet.dk)
Date: May 14, 2018 10:24PM

When I try to install Composer this error comes:

PHP Warning: PHP Startup: Unable to load dynamic library 'c:/wamp/bin/php/php5.6.35/ext/php_cl_dbg_5_6_VC11.dll' - %1 is not a valid Win32-application.
in Unknown on line 0

I have updated all Visual C++ and my Wamp-version is 3.1.3 and it is 64-bit
What have i to do?

Options: ReplyQuote
Re: Cannot install Composer because error in Wamp
Posted by: RiggsFolly (Moderator)
Date: May 15, 2018 11:14AM

Hi,

I use composer and as you say there is not such DLL distributed with either the 32 or 64bit versions of WAMPServer.

I can only assume that you have added this to the `php.ini` file yourself OR that you have another `php.ini` file somewhere on your system OR that you have added some other PHP distribution to your PATH in windows,


First look for any php.ini file that is NOT in the \wamp\ or `\wamp64` folder structure. The most likely place is in the windows folder. If you find one anywhere else rename it or better still delete it.

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.1.3 32bit & 64bit)
<Apache 2.4.29/2.2.31> <PHP 7.2/7.1/7.0/5.6/5.5/5.4> <MySQL 5.7.19/5.6.39/5.5.28>
<MariaDB 10.2.14> <phpMyAdmin4.8.1> <MySQL Workbench 6.3.10>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-

Options: ReplyQuote
Re: Cannot install Composer because error in Wamp
Posted by: peterkn (---.rev.stofanet.dk)
Date: May 15, 2018 06:12PM

Thank you! There was a section called CLDbg in php.ini. I removed this and then it is OK

Options: ReplyQuote
Re: Cannot install Composer because error in Wamp
Posted by: Otomatic (Moderator)
Date: May 15, 2018 06:52PM

Hi,

> There was a section called CLDbg in php.ini.
In which php.ini file?
No php.ini file, for all PHP versions distributed with full Wampserver or as an addon, includes any section CLDbg.

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.3 32 bit - Apache 2.4.33 - PHP 7.2.7/7.1.19/7.0.30/5.6.36 - MySQL 5.7.22 - MariaDB 10.3.8
Wampserver 3.1.3 64 bit - Apache 2.4.33 - PHP 7.2.7/7.1.19/7.0.30/5.6.36 - MySQL 5.7.22 - MariaDB 10.3.8
PhPMyAdmin 4.8.2 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote


Sorry, only registered users may post in this forum.