Wrong file opening
Posted by: rpjd (37.228.229.---)
Date: January 02, 2018 10:16PM

Windows10-64bit,version-3.0.6,apache-2.4.23,php-5.6.25,mysql-5.7.14,icon-green,127.0.0.1 localhost ::1 localhost,localhost-yes,8a-no,9-yes,11-Avira,c:/wamp64

One of the files in a projects index of files is opening the wrong file. It shows the correct file/path when mouse hovers, but opens a different file. Never seen this before.

Options: ReplyQuote
Re: Wrong file opening
Posted by: RiggsFolly (Moderator)
Date: January 03, 2018 10:02AM

Hi,

This sounds odd.

Can you say which file(s), as there is no obvious reason for this.

Do you have a .htaccess that may be effecting this?

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.1.3 32bit & 64bit)
<Apache 2.4.29/2.2.31> <PHP 7.2/7.1/7.0/5.6/5.5/5.4> <MySQL 5.7.19/5.6.39/5.5.28>
<MariaDB 10.2.14> <phpMyAdmin4.8.1> <MySQL Workbench 6.3.10>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-

Options: ReplyQuote
Re: Wrong file opening
Posted by: rpjd (37.228.229.---)
Date: January 03, 2018 11:09PM

Its a php file. I thought it was strange myself. I uninstalled and re-installed wampserver. Added the project to www, then added the database I backed up with mysqldump. Whats happening now is that when I click on the project, it displays in the url as "project/" but displays localhost, not the project files. Localhost, phpinfo and phpmyadmin all work. I'm guessing I'm missing an apache config somewhere.

Options: ReplyQuote
Re: Wrong file opening
Posted by: Otomatic (Moderator)
Date: January 04, 2018 11:49AM

Hi,

You must use VirtuaHost. See The need for Virtual Host

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.4 32 bit - Apache 2.4.35 - PHP 7.2.11/7.1.23/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.10
Wampserver 3.1.4 64 bit - Apache 2.4.35 - PHP 7.2.11/7.1.23/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.10
PhPMyadmin 4.8.3 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: Wrong file opening
Posted by: rpjd (37.228.229.---)
Date: January 06, 2018 08:28PM

I deleted the problem file and create a new file with the same name, no code. It opened correctly. I then added to code in steps and eventually with all the code its still opening correctly. I then created a vh, its working as well. No idea what caused the issue thought. Its working, that's all that matters.

Options: ReplyQuote


Sorry, only registered users may post in this forum.