The CLI keeps crashing when I use it
Posted by: desbest (---.range86-177.btcentralplus.com)
Date: March 30, 2017 10:30PM

When I enter "php -v" in the command line a window appears that says "CLI has stopped working. A problem caused the program to stop working correctly. Windows will close the problem and notify you if a solution is available."

Because of the CLI not working, I cannot install Composer.

1 - Windows version used: Windows 8.1 64 bit
2 - Version WampServer: 3.0.6 64 bit
3 - Apache Version: 2.4.23
4 - PHP Version: 5.6.25
5 - MySQL Version: 5.7.14
6 - What color is the WampServer icon: Green
7: There are no active lines with localhost in them.
8: Yes I do.
8a: No error message
9: Yes
10: See above
11: Comodo Internet Security and Spyshelter Premium
12: c:\wamp
13: I have no virtual hosts.

Options: ReplyQuote
Re: The CLI keeps crashing when I use it
Posted by: Otomatic (Moderator)
Date: March 31, 2017 09:57AM

Hi,

J:\wamp\bin\php\php5.6.30>php -v
PHP 5.6.30 (cli) (built: Jan 18 2017 19:48:22)
Copyright (c) 1997-2016 The PHP Group
Zend Engine v2.6.0, Copyright (c) 1998-2016 Zend Technologies
J:\wamp\bin\php\php5.3.29>php -v
PHP 5.3.29 (cli) (built: Aug 13 2014 21:58:10)
Copyright (c) 1997-2014 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2014 Zend Technologies
J:\wamp\bin\php\php7.0.17>php -v
PHP 7.0.17 (cli) (built: Mar 14 2017 16:53:35) ( ZTS )
Copyright (c) 1997-2017 The PHP Group
Zend Engine v3.0.0, Copyright (c) 1998-2017 Zend Technologies
J:\wamp\bin\php\php7.1.3>php -v
PHP 7.1.3 (cli) (built: Mar 14 2017 23:46:26) ( ZTS MSVC14 (Visual C++ 2015) x86 )
Copyright (c) 1997-2017 The PHP Group
Zend Engine v3.1.0, Copyright (c) 1998-2017 Zend Technologies

- Verify that all VC ++ packages are installed and with the latest versions.
To do this, use the tool:
Checks VC++ packages installed
And you will find all the packages on [wampserver.aviatechno.net] in the section Visual C++ Redistribuable Packages

------------------------------------------------------------------------------------------------------------
(W7 Pro 64 bit)-Wampserver 3.1.0 32 bit - Apache 2.4.27 - PHP 7.1.9/7.0.23/5.6.31 - MySQL 5.7.19 - MariaDB 10.2.8
Wampserver 3.1.0 64 bit - Apache 2.4.27 - PHP 7.1.9/7.0.23/5.6.31 - MySQL 5.7.19 - MariaDB 10.2.8
PhPMyAdmin 4.7.4 - MysqlDumper 1.24.5

Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: The CLI keeps crashing when I use it
Posted by: desbest (---.range86-177.btcentralplus.com)
Date: March 31, 2017 12:52PM

I have all the VC ++ packages installed and I still have the same issue.

Options: ReplyQuote
Re: The CLI keeps crashing when I use it
Posted by: Otomatic (Moderator)
Date: March 31, 2017 02:45PM

Hi,

CLI mode works perfectly regardless of PHP versions, both 32-bit and 64-bit.
You have a problem with your system.
See the PHP log files and errors in the event viewer.

------------------------------------------------------------------------------------------------------------
(W7 Pro 64 bit)-Wampserver 3.1.0 32 bit - Apache 2.4.27 - PHP 7.1.9/7.0.23/5.6.31 - MySQL 5.7.19 - MariaDB 10.2.8
Wampserver 3.1.0 64 bit - Apache 2.4.27 - PHP 7.1.9/7.0.23/5.6.31 - MySQL 5.7.19 - MariaDB 10.2.8
PhPMyAdmin 4.7.4 - MysqlDumper 1.24.5

Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: The CLI keeps crashing when I use it
Posted by: desbest (---.range86-177.btcentralplus.com)
Date: March 31, 2017 04:07PM

php error log is blank

I'm getting this error in Event Viewer.

Faulting application name: php.exe, version: 5.6.25.0, time stamp: 0x57b60174
Faulting module name: ntdll.dll, version: 6.3.9600.18438, time stamp: 0x57ae642e
Exception code: 0xc0000005
Fault offset: 0x0000000000030c57
Faulting process ID: 0x2e70
Faulting application start time: 0x01d2aa27475e178b
Faulting application path: C:\wamp\bin\php\php5.6.25\php.exe
Faulting module path: C:\WINDOWS\SYSTEM32\ntdll.dll
Report ID: 870dbe02-161a-11e7-8263-38b1dbf6d8ea
Faulting package full name:
Faulting package-relative application ID:

Faulting application name: php-win.exe, version: 5.6.25.0, time stamp: 0x57b60195
Faulting module name: ntdll.dll, version: 6.3.9600.18438, time stamp: 0x57ae642e
Exception code: 0xc0000005
Fault offset: 0x0000000000030c57
Faulting process ID: 0x2f1c
Faulting application start time: 0x01d2aa0cab8c6362
Faulting application path: c:\wamp\bin\php\php5.6.25\php-win.exe
Faulting module path: C:\WINDOWS\SYSTEM32\ntdll.dll
Report ID: f3184580-15ff-11e7-8263-38b1dbf6d8ea
Faulting package full name:

Options: ReplyQuote
Re: The CLI keeps crashing when I use it
Posted by: Otomatic (Moderator)
Date: March 31, 2017 04:32PM

Hi,

It works perfectly, without any error, under Windows 7 Pro and under Windows 10 Pro.
I do not know how to decode the error you have with Windows 8.1.

------------------------------------------------------------------------------------------------------------
(W7 Pro 64 bit)-Wampserver 3.1.0 32 bit - Apache 2.4.27 - PHP 7.1.9/7.0.23/5.6.31 - MySQL 5.7.19 - MariaDB 10.2.8
Wampserver 3.1.0 64 bit - Apache 2.4.27 - PHP 7.1.9/7.0.23/5.6.31 - MySQL 5.7.19 - MariaDB 10.2.8
PhPMyAdmin 4.7.4 - MysqlDumper 1.24.5

Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote


Sorry, only registered users may post in this forum.