phpMyAdmin #1251 authentication error
Posted by: Brian (
Date: January 24, 2006 02:36AM

Have everything setup, can access mysql directly from the command line with the password, but phpMyAdmin is coming up with this error. When I remove the password from MySQL, it opens up fine.

#1251 - Client does not support authentication protocol requested by server; consider upgrading MySQL client


Options: ReplyQuote
Re: phpMyAdmin #1251 authentication error
Posted by: domecc (222.104.32.---)
Date: February 16, 2006 01:28PM

I meet the same problem.

Options: ReplyQuote
Re: phpMyAdmin #1251 authentication error
Posted by: senatorslab (
Date: February 21, 2006 10:43PM

anyone had any luck solving this?? i just set up wamp on a new computer. was going through and giving root user a pass and making the changes in the file like described in this faq: [] now i am gett the 1251 error. this is weird, and i think when i set this up the first time i remember doing something else to get this to work. and now the solution has COMPLETELY eluded me.... sad smiley any help would be greatly appreciated.

Options: ReplyQuote
Re: phpMyAdmin #1251 authentication error
Posted by: Werner Avenant (
Date: February 23, 2006 11:56AM


This is not a WAMP problem but rather based on the fact that PHP4 still uses the old password mechanism of MySQL. This usually happens when your change your password. This is not a problem however. The full explanation is at:


The instructions above is for a Linux server. For Windows it is almost the same - just a few changes here and there

WINDOWS walkthrough to fix problem
(just to make 100% sure.. you must TYPE in everything BETWEEN the "" quotation marks... but not the quotation marks itself)

1. Click Start -> Run and enter "cmd" to get to the command prompt.

2. Enter "cd \wamp\mysql\bin"

3. Enter "mysql -u root -p"

4. It will ask you for your database password. Enter it. You will now have a mysql> prompt

5. Enter "SET PASSWORD FOR root@localhost = OLD_PASSWORD('***********');"
Of course, REPLACE the ********* with your own password

6. Enter "exit" and close that window

6. Click on your WAMP icon (above the clock in the lower right corner of your screen)

7. Click on Config Files -> my.ini

8. Look for a section that says: [wampmysqld]. It is about a page down.

9. Add this line under the line that says port=3306

# set mysql to use old password mechanism

10. Here is an example of what the section in my.ini must look like

# The TCP/IP Port the MySQL Server will listen on

# set mysql to use old password mechanism

#Path to installation directory. All paths are usually resolved relative to this.

---- example-----

11. Save and close the file my.ini file

12. Click your WAMP icon -> MySQL -> Restart Service

13. If you did everything correctly your PHP4 will now connect to your MySQL database without any problems.

Wermer Avenant

Options: ReplyQuote

Sorry, only registered users may post in this forum.