Pages: 12Next
Current Page: 1 of 2
change localhost port
Posted by: Rebbekka (---.maricopa.gov)
Date: January 10, 2006 09:22PM

How do I change wamp's localhost port from 80 to something else? That port is currently being used by something else...
Thanks


Options: ReplyQuote
Re: change localhost port
Posted by: viral (---.dhcp.jcsn.tn.charter.com)
Date: January 11, 2006 06:42AM

Edit http.conf file in notepad usually located in C:\wamp\Apache2\conf .
then do either CTL+F or go to EDIT/FIND from the notepad menubar. this will open FIND window. type 80 in the 'Find What' box and click find next. replace 80 to whichever port to want apache to listen to. you may have to change to two or more places depending on your configuration. and then restart your apache server. Apache should listen to the port you set in the http.conf file. Hope this helps.


Options: ReplyQuote
Re: change localhost port
Posted by: Rebbekka (---.maricopa.gov)
Date: January 11, 2006 04:39PM

Thanks much - I should have been more clear, but I had the Apache part of it that you list above completed, I was just wondering if there was a way to 'let wamp know' - if you try to use the wamp5 menu list from the icon in the tray, and select 'localhost' it brings up [localhost] but it would just be nice if it brought up [X/" rel="nofollow">localhost] where XX is my new port number.


Options: ReplyQuote
Re: change localhost port
Posted by: Malcolm (---.ip.e-nt.net)
Date: January 12, 2006 07:11PM

I have the same issue with my server. If anyone has a solution...that would be wonderful! Thanks in advance,

- Malcolm

Options: ReplyQuote
Re: change localhost port
Posted by: Malcolm (---.ip.e-nt.net)
Date: January 13, 2006 07:31PM

Rebbekka,

I think I figured it out. Here's what I did, Just in case backup anyfiles you have.

First:

Goto your wamp root folder, x:\wamp, then there's a file called 'wampserver' (configuration settings).
OPEN that in notepad and you should see something like this:

[Menu.Left]
Type: separator; Caption: "WAMP5"
Type: item; Caption: "Localhost"; Action: run; FileName: "C:\Program Files\Mozilla Firefox\firefox.exe"; Parameters: "[localhost];; Glyph: 5
Type: item; Caption: "phpMyAdmin"; Action: run; FileName: "C:\Program Files\Mozilla Firefox\firefox.exe"; Parameters: "[localhost];; Glyph: 5
Type: item; Caption: "SQLiteManager"; Action: run; FileName: "C:\Program Files\Mozilla Firefox\firefox.exe"; Parameters: "[localhost];; Glyph: 5
Type: item; Caption: "www directory"; Action: shellexecute; FileName: "E:/wamp/www"; Glyph: 2
Type: submenu; Caption: "Log files"; SubMenu: log_files; Glyph: 3
Type: submenu; Caption: "Config files"; SubMenu: conf_files; Glyph: 3
Type: separator; Caption: "Services"
Type: servicesubmenu; Caption: "Apache"; Service: wampapache; SubMenu: apache
Type: servicesubmenu; Caption: "MySQL"; Service: wampmysqld; SubMenu: MySql
Type: item; Caption: "Start All Services"; Action: multi; Actions: StartAll
Type: item; Caption: "Stop All Services"; Action: multi; Actions: StopAll
Type: item; Caption: "Restart All Services"; Action: multi; Actions: RestartAll


As you can see I alread edited my localhost paths to say "[localhost]; instead of "[localhost];. Do that for each of the three Parameters.

NEXT i went to my phpmyadmin folder, and opened my 'config.inc.php' file.

from there you should see something like this:

$cfg['PmaAbsoluteUri'] = 'localhost/phpmyadmin/';


Quote this out by sorrounding the string above with /* */ LIKE SO:

/* $cfg['PmaAbsoluteUri'] = 'localhost/phpmyadmin/'; */


THEN in the same file, find:

$cfg['PmaAbsoluteUri_DisableWarning'] = FALSE;

Change this to TRUE like so:

$cfg['PmaAbsoluteUri_DisableWarning'] = TRUE;

Save and close. Then restart your server and try again. Worked for me.

Hope that helps! Remember to backup the files mentioned just in case you want to revert to your old configuration. smiling smiley

- Malcolm

Options: ReplyQuote
Re: change localhost port
Posted by: rizadrkm (112.135.14.---)
Date: March 12, 2010 06:53AM

same issue with port problem. Port 80 is using in some other application.
i want to change the port. i tried the above things but its not working, i thing this will work on OLD version of WAPM. but mine is new version 2.0..
can anyone help me ?

Options: ReplyQuote
Re: change localhost port
Posted by: shameersyedmohamed (195.229.237.---)
Date: April 12, 2010 03:32PM

HI,

In http.conf file, i changed the port number from 80 into 90. after that if I open the application through localhost:90/projectname, it is automaticaly redirecting to localhost/projectname.
please help me to rectify this.



Edited 1 time(s). Last edit at 04/12/2010 03:32PM by shameersyedmohamed.

Options: ReplyQuote
Re: change localhost port
Posted by: aminoy (213.210.213.---)
Date: May 27, 2010 10:22AM

Hi all,

Just go to X:\wamp\bin\apache\apache2.2.8\conf\httpd.conf

and search for "Listen 80" change 80 to whatever you want ....

I hope it's clear.

Options: ReplyQuote
Re: change localhost port
Posted by: KingScar (---.proxy.aol.com)
Date: May 27, 2010 09:02PM

Hey guys,

By default, WampServer is installed to [localhost] and port 80, which is already used by IIS. To set WampServer to use an open port, LEFT CLICK on the WampServer icon in the system tray and go to Apache > httpd.conf

The httpd.conf file will open in Notepad. Hit ctrl+f and search for "Listen 80", change this line to "Listen 8080", and then close and save the httpd.conf file.

Open a web browser and enter "[];, this will open the WampServer configuration page where you can configure Apache, MySQL, and PHP.


Hope it helps.

Options: ReplyQuote
change localhost port
Posted by: shah_kunjan (203.77.202.---)
Date: August 04, 2010 11:46AM

Hello Sir,

I am facing following problem.....

I have installed wamp5 1.7.0

I have gone through "Left click on tray icon -> phpMyAdmin"

It shows following message:

---------------------------

Not Found

The requested URL /phpmyadmin/ was not found on this server.
Apache/2.2.3 (CentOS) Server at localhost Port 80

---------------------------

I have also tried to change port number in httpd.conf file from 80 to 90. Then I tried 8080 but still same message displays...

May be I am doing silly mistake.... I don't know.

Please help me....

Thanks in advance

Kunjan

Options: ReplyQuote
Re: change localhost port
Posted by: toumimi (---.162.192-77.rev.gaoland.net)
Date: August 08, 2010 03:06AM

You should use WampServer 2.0 (evolution of Wamp5), since the previous one is not more maintained.

For those who want to change Apache port, I developed a patch to add this functionnality.
By switching port, it updates wamp conf files to use the given port automatically.

If you can't start Apache, then you can find a cli version under install_class/cli/INSTALL_CLI_AUTO.

Florian

WampServer Patch (Screenshots)
Topic EN : www.wampserver.com
Topic FR : www.wampserver.com

Options: ReplyQuote
Re: change localhost port
Posted by: Alex Leung (183.14.192.---)
Date: November 08, 2011 05:34AM

I have the same problem, and I found a simple way to solve it
enter your wampserver directory first(default by wamp), and you should see a file named "wampmanager.tpl", open it in your editor, and find the following:

[Menu.Left]
Type: item; Caption: "${w_localhost}"; Action: run; FileName: "${c_navigator}"; Parameters: "[localhost];; Glyph: 5
Type: item; Caption: "${w_phpmyadmin}"; Action: run; FileName: "${c_navigator}"; Parameters: "[localhost];; Glyph: 5

you can change the tray left menu item in above, such as change the url, add a port etc, then save the file and restart your wampserver program( not services). it works for me. hope it can help you.

Options: ReplyQuote
Re: change localhost port
Posted by: Cozzbie (41.203.64.---)
Date: April 14, 2012 04:05PM

Actually changing the old port from the old one (80) to the new one works. You just have to access it through "localhost:[new port]"...(no brackets please)

Options: ReplyQuote
Re: change localhost port
Posted by: lisa_lingoes (---.gar.clearwire-wmx.net)
Date: August 30, 2012 07:06PM

I have tried every one of these suggestions and none work. I'm running wampserver 2.2 on windows 7 using firefox as a browser.

Does anyone have any other suggestions?

Lisa

Options: ReplyQuote
Re: change localhost port
Posted by: stevenmartin99 (Moderator)
Date: August 30, 2012 07:15PM

Get Teamviewer and I'll take a look for you now if you like

Steven Martin
stevenmartin99@gmail.com
stevenmartin99@hotmail.com
PampServer.com - [pampserver.com]

Options: ReplyQuote
Re: change localhost port
Posted by: missr1900 (---.rdsnet.ro)
Date: December 14, 2012 10:08AM

#smiling smiley



Edited 1 time(s). Last edit at 12/14/2012 10:08AM by missr1900.

Options: ReplyQuote
Re: change localhost port
Posted by: missr1900 (---.rdsnet.ro)
Date: December 14, 2012 10:08AM

Hi,
I am writing to you because I hope you will be kind to need help with WAMP.

I have tried every one of suggestions from above and none work for me . I'm running wampserver 2.2.22 on windows 8 using firefox as a browser.

Port 80 is actually used by : Microsoft-IIS/8.0

After I changed config file WAMP is online but it returns me an empty page instead of index.php [wamp home page].

Thanks a lot

Options: ReplyQuote
Re: change localhost port
Posted by: RiggsFolly (---.as13285.net)
Date: December 14, 2012 10:55AM

It would be better to disable IIS ( if you are not using it ) and stay with port 80 for the web server.
Everything expect a web server to be on port 80.

If you changed Apache port to lets say 8080 you would have to add that port number to all the address's you use in the browser.

So
http://localhost:8080

This is the other reason for using the standard port 80, you dont need to add the :80

Options: ReplyQuote
Re: change localhost port
Posted by: missr1900 (---.rdsnet.ro)
Date: December 15, 2012 03:12PM

if I stop Microsoft-IIS/8.0 my system is restarting
sad smiley

Options: ReplyQuote
Re: change localhost port
Posted by: missr1900 (---.rdsnet.ro)
Date: December 15, 2012 03:28PM

smiling smiley guys,

could anyone of you write a small tutorial "how to change port 80 for last version of wamp"?

Thanks a lot

Options: ReplyQuote
Pages: 12Next
Current Page: 1 of 2


Sorry, only registered users may post in this forum.