Windows 10
Posted by: ickaz (139.216.186.---)
Date: August 02, 2015 04:37PM

Hello Ladies & Gentlemen.

Yesterday I upgraded to Windows 10 so I had to re-uninstall my applications, and the only one that apparently the only one that caused me trouble is wamp server, so I tried everything, but every time I launch the application, it goes from red to orange, and sticks there, doesn't go up ( green)
Any suggestions?

Windows 10 Home x64.


Thanks in advance.

Options: ReplyQuote
Re: Windows 10
Posted by: RiggsFolly (---.as43234.net)
Date: August 02, 2015 05:25PM

Hi,

Please read this and answer the questions, also use the troubleshooting tips to work out WHICH SERVICE is not starting. [forum.wampserver.com]

Also depending on which version of WAMPServer and therefore Apache you are using, make sure you have the right Microsoft C/C++ Runtimes installed. The W10 install does not install OLD VERSIONS of the MSVC Runtime libraries and you will need to install at least one of the old ones yourself. [forum.wampserver.com]

If you still have problems feel free to ask a question as soon as you have some relevant details to help us provide an answer.

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.1.8 32bit & 64bit)
<Apache versions MULTIPE> <PHP versions MULTIPLE> <MySQL Versions MULTIPLE>
<MariaDB versions MULTIPLE> <phpMyAdmin versions MULTIPLE> <MySQL Workbench 8.0.16>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-



Edited 1 time(s). Last edit at 08/02/2015 05:25PM by RiggsFolly.

Options: ReplyQuote
Re: Windows 10
Posted by: ickaz (139.216.186.---)
Date: August 03, 2015 02:11PM

- Windows 10 64bit.
- Wamp server 2.5, 64 bit
- Apache : 2.4.9
- MySQL : 5.6.17
- PHP : 5.5.12
- Yellow


- Apache,SQL,PHP log's empty.

7 - 127.0.0.1 localhost
127.0.0.1 localhost

Options: ReplyQuote
Re: Windows 10
Posted by: RiggsFolly (---.as43234.net)
Date: August 03, 2015 02:50PM

ickaz,


I asked you to work out which service was not starting. If the icon is Orange, then one has started and one has not. Which service is running and which is NOT?

Did you also check that your system has the MSVC 2012 runtime librarry installed?

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.1.8 32bit & 64bit)
<Apache versions MULTIPE> <PHP versions MULTIPLE> <MySQL Versions MULTIPLE>
<MariaDB versions MULTIPLE> <phpMyAdmin versions MULTIPLE> <MySQL Workbench 8.0.16>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-



Edited 1 time(s). Last edit at 08/03/2015 02:51PM by RiggsFolly.

Options: ReplyQuote
Re: Windows 10
Posted by: ickaz (139.216.186.---)
Date: August 03, 2015 04:25PM

How can I know which service is not started?

Options: ReplyQuote
Re: Windows 10
Posted by: RiggsFolly (---.as43234.net)
Date: August 03, 2015 06:17PM

left click wampmanager -> Apache -> Service -> [If Start/Resume Service is green = SERVICE NOT STARTED]
left click wampmanager -> MYSQL -> Service -> [If Start/Resume Service is green = SERVICE NOT STARTED]

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.1.8 32bit & 64bit)
<Apache versions MULTIPE> <PHP versions MULTIPLE> <MySQL Versions MULTIPLE>
<MariaDB versions MULTIPLE> <phpMyAdmin versions MULTIPLE> <MySQL Workbench 8.0.16>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-

Options: ReplyQuote
Re: Windows 10
Posted by: ickaz (203.12.140.---)
Date: August 04, 2015 01:55AM

MSQL Working

Apache all the options are grey except the 3 last ones
so I guess APACHE is dead

Options: ReplyQuote
Re: Windows 10
Posted by: RiggsFolly (---.as43234.net)
Date: August 04, 2015 02:17AM

Try this

left click wampmanager -> Apache -> Service -> Install Service

Now try

left click wampmanager -> Apache -> Service -> Start/Resume Service

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.1.8 32bit & 64bit)
<Apache versions MULTIPE> <PHP versions MULTIPLE> <MySQL Versions MULTIPLE>
<MariaDB versions MULTIPLE> <phpMyAdmin versions MULTIPLE> <MySQL Workbench 8.0.16>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-

Options: ReplyQuote
Re: Windows 10
Posted by: ickaz (203.12.140.---)
Date: August 04, 2015 03:00AM

Worked, congratulations! Thanks.

Options: ReplyQuote
Re: Windows 10
Posted by: tompatterson (---.lightspeed.hstntx.sbcglobal.net)
Date: August 04, 2015 05:11PM

To run Wampserver on Windows 10:

- Run cmd as Administrator, and enter: iisreset /stop.

- To run as Administrator, enter cmd in the windows search box and hit Control, Shift and Enter

- Now you can start Wampserver

Options: ReplyQuote
Re: Windows 10
Posted by: tiagoduque (---.user.veloxzone.com.br)
Date: August 07, 2015 09:18PM

guys, try this: C:\Windows\System32\inetsrv\config\applicationhost and look for this line: <binding protocol="http" bindingInformation="*:80:" />. change for 85 and done. to me, its worked.

Options: ReplyQuote
Re: Windows 10
Posted by: mmlodzik (---.res.bhn.net)
Date: August 08, 2015 02:12AM

Hello

I just upgraded to Windows 10 (windows 10 Home x64) and I have a problem with
Wamp Server. It's not going to online (goes from red to orange), with the
suggestions I check:
1) I instaled last version of Microsoft C/C++ Runtimes instaler;
2) I check wich serwis it's not running and its Apache;
3) I instaled Apache by install service
4) I run CMD as administrator and iisreset /stop
5) I change in aplicationhost.config port from 80 to 85
6) I tested and my port 80 is free;
That's does not help. My Apache is orange and removeing, instaling, starting doesn't help
Options in Apache with yeld ! sing:
- auth_form_module
- cache_socache_module
- macro_module
- proxy_wstunnel_module
Any suggestions?

Options: ReplyQuote
Re: Windows 10
Posted by: RiggsFolly (---.as43234.net)
Date: August 08, 2015 12:24PM

Hello,

Look at the Windows Event Viewer for messages from Either Apache or MySQL.

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.1.8 32bit & 64bit)
<Apache versions MULTIPE> <PHP versions MULTIPLE> <MySQL Versions MULTIPLE>
<MariaDB versions MULTIPLE> <phpMyAdmin versions MULTIPLE> <MySQL Workbench 8.0.16>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-

Options: ReplyQuote
Re: Windows 10
Posted by: LazyDaisy (---.range86-167.btcentralplus.com)
Date: August 15, 2015 01:06PM

Hi, my son helped me solve this and looking back was easy.

In Windows 10 go to the search box (bottom left of screen) next to the window icon that used to say "Start" in the olden days! smiling smiley

Type in the following abbreviation:

cmd

and then simultaneously depress the 'Shift key' the 'Ctrl key' and 'Enter key' together.

This as by Magic brings up the Admin Command Prompt (black box)

Now all you need to do is type in the following code:

iisreset /stop

This should return with a message telling you the service was stopped.

Now the WAMP icon should have changed from Orange to Green.

Options: ReplyQuote
Re: Windows 10
Posted by: Otomatic (Moderator)
Date: August 15, 2015 01:18PM

Hi,

> Now all you need to do is type in the following code: iisreset /stop
NO, NO and NO.
This stops IIS but does not prevent it from restarting when it sees fit.
The only way to prevent IIS starts is to eradicate it, so never load it.
Control Panel, Programs and Features, Turn Windows features on or off
Uncheck:
-- Main instance Web of Internet Information Services (IIS)
-- All items of the branch : Internet Information Services
OK
Then restart Windows 10

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.9 32 bit - Apache 2.4.41 - PHP 7.3.9/7.2.22/7.1.32/7.0.33/5.6.40 - MySQL 5.7.27 - MariaDB 10.4.7
Wampserver 3.1.9 64 bit - Apache 2.4.41 - PHP 7.3.9/7.2.22/7.1.32/7.0.33/5.6.40 - MySQL 5.7.27/8.0.17 - MariaDB 10.4.7
PhPMyadmin 4.9.0.1 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: Windows 10
Posted by: phirow (---.17-1.cable.virginm.net)
Date: August 15, 2015 04:56PM

I have just post my solution Phirow

Options: ReplyQuote
Re: Windows 10
Posted by: Otomatic (Moderator)
Date: August 15, 2015 05:42PM

Hi,

> I have just post my solution.
This is not the solution to the IIS problem. It's just a temporary stopgap when it will again restart IIS for some reason. And if IIS restarts, the user will think the problem is not IIS just because he has already implemented the solution.
Always implement reliable and sustainable solutions, not snake oil.

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.9 32 bit - Apache 2.4.41 - PHP 7.3.9/7.2.22/7.1.32/7.0.33/5.6.40 - MySQL 5.7.27 - MariaDB 10.4.7
Wampserver 3.1.9 64 bit - Apache 2.4.41 - PHP 7.3.9/7.2.22/7.1.32/7.0.33/5.6.40 - MySQL 5.7.27/8.0.17 - MariaDB 10.4.7
PhPMyadmin 4.9.0.1 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote


Sorry, only registered users may post in this forum.