Pages: Previous123
Current Page: 3 of 3
Re: PHP running very slow within Windows 8
Posted by: musicjerm (70.102.169.---)
Date: November 11, 2012 07:13PM

stevenmartin99 Wrote:
-------------------------------------------------------
> again i am not taking about the url , im taking
> about the host varirable in your mysql connection
> string.
>
> mysql_connect("locahost".......
>
> change to 127.0.0.1 and see if you get the 1 sec
> delay


Well dang, this has solved the problem for me! Thank you so much! Everything seems nice and smooth now, no delay!

Options: ReplyQuote
Re: PHP running very slow within Windows 8
Posted by: stevenmartin99 (Moderator)
Date: November 11, 2012 07:17PM

ok, ill look further into the cause as to why thats happening,

if your finding phpmyadmin slow

in the config.inc.php you can change localhost to 127.0.0.1 also

Steven Martin
stevenmartin99@gmail.com
stevenmartin99@hotmail.com
PampServer.com - [pampserver.com]

Options: ReplyQuote
Re: PHP running very slow within Windows 8
Posted by: musicjerm (70.102.169.---)
Date: November 11, 2012 08:07PM

stevenmartin99 Wrote:
-------------------------------------------------------
> ok, ill look further into the cause as to why
> thats happening,
>
> if your finding phpmyadmin slow
>
> in the config.inc.php you can change localhost to
> 127.0.0.1 also


That did make phpmyadmin much much faster. It was taking 2-3 seconds to load and now it's almost instant. Thanks again for your help.

Options: ReplyQuote
Re: PHP running very slow within Windows 8
Posted by: tzhu07 (---.hsd1.wa.comcast.net)
Date: November 12, 2012 02:23AM

Yup, I can confirm that changing the mysql connection string from 'localhost' to '127.0.0.1' worked and now my PHP pages load instantly.

Also, I did not have to change the URL. I'm still using 'localhost' in the URL just fine.

Thanks to stevenmartin99 for the help. Hopefully this thread gets indexed in Google very highly so that others who no doubt are having this issue see this thread.

BTW, is there a way for us to contact the creators of WAMP and report these kinds of issues? I don't see a direct contact form.

Options: ReplyQuote
Re: PHP running very slow within Windows 8 - SOLVED!!!!
Posted by: faguvenli (---.as253190.sol.superonline.com)
Date: November 12, 2012 11:20AM

Thanks for your support.
changing mysql_connect('localhost','root','') -> mysql_connect('127.0.0.1','root','') solved the problem. Everything opens instantly now.

Options: ReplyQuote
Re: PHP running very slow within Windows 8 - SOLVED!!!!
Posted by: wuzhichen (27.197.130.---)
Date: November 22, 2012 03:00AM

Very useful, problem solved!Thanks!

Options: ReplyQuote
Re: PHP running very slow within Windows 8 - SOLVED!!!!
Posted by: dmadpar (178.255.65.---)
Date: November 23, 2012 03:44PM

Hi

Where do I find this parameter - mysql_connect('localhost','root','')?

Thanks

Options: ReplyQuote
Re: PHP running very slow within Windows 8 - SOLVED!!!!
Posted by: alaki (---.bb.dnainternet.fi)
Date: December 25, 2012 01:52AM

so yeah, where can i find this mysql_connect('localhost','root','') ?!

Options: ReplyQuote
Re: PHP running very slow within Windows 8
Posted by: Adobarsby (---.aztw.cable.virginmedia.com)
Date: January 05, 2013 02:23PM

After installing Windows 8 and the latest 64 bit wampserver setup, I found that the sites I had written were taking 10 seconds to load per page. I tracked this down to where mysql was being accessed - 1 second each for 10 hits on the database.

I then came to this page and tried each "fix" in turn. Changing the httpd.conf and my.ini files didn't help. However, I changed localhost in my php script to 127.0.0.1 and that worked perfectly.

@Steven Martin: Thanks

Adrian Barsby

Options: ReplyQuote
Re: PHP running very slow within Windows 8
Posted by: grunik (---.kls-mt.client.bresnan.net)
Date: January 17, 2013 12:38AM

stevenmartin99 Wrote:
-------------------------------------------------------

>
>... if your finding phpmyadmin slow
>
> in the config.inc.php you can change localhost to
> 127.0.0.1 also


SOLVED FOR ME:

I just installed win 8 and a fresh wamp install to go with it. I have been using wamp on a project for months with great results until now. Same as everyone else, the wamp homepage, sqlbuddy and phpmyadmin take over 2 minutes to load both locally and remotely. I found this page while looking for answers. Changing the two instances of Localhost in my config.inc.php file fixed all of it. I restarted wamp, and it's back to its old self.

thanks stevenmartin99

Options: ReplyQuote
Re: PHP running very slow within Windows 8
Posted by: kerusso (---.lightspeed.cicril.sbcglobal.net)
Date: February 08, 2013 11:14PM

Kindly tell me where I can find the config.inc.php file? So I can also change the mysql_connect('localhost','root','')... forgive me for being a bit "slow" on this too.

Options: ReplyQuote
Re: PHP running very slow within Windows 8
Posted by: stevenmartin99 (Moderator)
Date: February 08, 2013 11:17PM

c:\wamp\apps\phpmyadmin\config.inc.php


just change

$cfg['Servers'][$i]['host'] = 'localhost';
to
$cfg['Servers'][$i]['host'] = '127.0.0.1';

Steven Martin
stevenmartin99@gmail.com
stevenmartin99@hotmail.com
PampServer.com - [pampserver.com]

Options: ReplyQuote
Re: PHPMyAdmin/ Mysql running very slow within Windows 8 - SOLVED!!!!
Posted by: bartlewis (---.dsl.bkfd14.sbcglobal.net)
Date: April 09, 2013 05:36PM

Awesome. Thanks you so so much for this. This solved the problem on my local WIMP server too.

Options: ReplyQuote
Re: PHPMyAdmin/ Mysql running very slow within Windows 8 - SOLVED!!!!
Posted by: james79 (60.49.172.---)
Date: April 27, 2013 12:23PM

Can you try to help me to solve the problem also?

I have installed WAMP into Windows Server 2012. i have disable all the firewalls. but when i using others PC to open the pages. It take a lot of times. What can i do ??

Options: ReplyQuote
Re: PHPMyAdmin/ Mysql running very slow within Windows 8 - SOLVED!!!!
Posted by: RiggsFolly (---.as13285.net)
Date: April 27, 2013 04:20PM

Have you tried what was suggested above??

Options: ReplyQuote
Re: PHPMyAdmin/ Mysql running very slow within Windows 8 - SOLVED!!!!
Posted by: AstridKarsten (---.ip.telfort.nl)
Date: May 04, 2013 02:01PM

Tried everything above, wamp still extremly slow, most of the time coming up with this error:

( ! ) SCREAM: Error suppression ignored for
( ! ) Fatal error: Maximum execution time of 30 seconds exceeded in C:\wamp\www\commitments\wp-includes\kses.php on line 968

the fatal error occurs on a different line anytime I load, it just is so slow it stops loading....

Any help? via teamviewer maybe?

Options: ReplyQuote
Re: PHPMyAdmin/ Mysql running very slow within Windows 8 - SOLVED!!!!
Posted by: RiggsFolly (---.as13285.net)
Date: May 04, 2013 07:49PM

Wordpress can be a little slow, and it can be very slow.

I suggest you change that param and allow a script longer befreo it gets zapped.

Edit php.ini and change

max_execution_time = 30
to
max_execution_time = 60

See if taht helps

Options: ReplyQuote
Re: PHPMyAdmin/ Mysql running very slow within Windows 8 - SOLVED!!!!
Posted by: claudio.galdiolo (---.hsd1.il.comcast.net)
Date: July 02, 2013 07:07AM

In my opinion is better to avoid to change the code of the applications especially when the issue is not in my code but is a MySQL/IPv6 issue (localhost is interpreted as ::1 while MySQL is expecting 127.0.0.1)
This is the solution that worked for me (MySQL 5.5.24, development machine NOT production server):

edit file 'my.ini' (you can find it into 'MySQL' menu in Wampserver)

under the section [wampmysqld] add the following line:
bind-address = ::

save file 'my.ini'

restart mysql service

solved!



Edited 1 time(s). Last edit at 07/02/2013 05:30PM by claudio.galdiolo.

Options: ReplyQuote
Pages: Previous123
Current Page: 3 of 3


Sorry, only registered users may post in this forum.