Pages: 1234Next
Current Page: 1 of 4
wamp server does not turn GREEN
Posted by: oreomonkey (129.33.49.---)
Date: September 14, 2012 06:14PM

I installed WAMP server. The icon in the tray goes orange from red. I can get to the mysql console. But the icon does not turn green.
I cannot get to the phpmyadmin site too. It gives me an error
Error

MySQL said: Documentation
#1045 - Access denied for user 'root'@'localhost' (using password: NO)

Please advise..

Options: ReplyQuote
Re: wamp server does not turn GREEN
Posted by: RiggsFolly (---.as13285.net)
Date: September 17, 2012 10:44AM

It sounds like apache has not started, this is normally because something else is using port 80.

Do left click on wampmanager ->Apache ->Service-> Test port 80

This will load a command window and tell you what is using port 80.

You will have to stop or uninstall that app.

Options: ReplyQuote
Re: wamp server does not turn GREEN
Posted by: oreomonkey (129.33.49.---)
Date: September 17, 2012 02:48PM

Actually the port 80 is used by Apache. The command window that pops up says:

You port 80 is actually used by :

Server: Apache/2.4.2 (Win64) PHP/5.4.3

Press Enter to exit


The WAMPSERVER icon does not go green.....
Can anyone tell me what I am doing wrong....

Thanks

Options: ReplyQuote
Re: wamp server does not turn GREEN
Posted by: RiggsFolly (---.as13285.net)
Date: September 17, 2012 04:28PM

Well in that case it must be MySQL that is not starting properly.

Have you tried to install MSQL before, if you have do a search for my.ini and delete all occurances except for those that exist in the C:\wamp folder or subfolders.

Options: ReplyQuote
Re: wamp server does not turn GREEN
Posted by: Tahir29 (---.hsd1.il.comcast.net)
Date: September 17, 2012 09:34PM

same here

Options: ReplyQuote
Re: wamp server does not turn GREEN
Posted by: oreomonkey (129.33.49.---)
Date: September 17, 2012 09:37PM

I did have couple of my.ini files. I deleted all those except for the ones in c:/wamp directory. Still does not help....
It looks like mysql starts and runs for a little while and then stops...

Any hints PLEASE ... I am stuck cannot move on............

Options: ReplyQuote
Re: wamp server does not turn GREEN
Posted by: RiggsFolly (---.as13285.net)
Date: September 17, 2012 09:56PM

Check that you have not left a old version of mysql installed

Look at windows services, wamps mysql is called 'wampmysql'

uninstall the other service using

sc delete <service-name>


also check if you also have another Apache wamps is called wampapache

Options: ReplyQuote
Re: wamp server does not turn GREEN
Posted by: oreomonkey (129.33.49.---)
Date: September 17, 2012 10:45PM

Thanks RiggsFolly,
It worked.

Options: ReplyQuote
Re: wamp server does not turn GREEN
Posted by: barnabas.gunaraj (101.62.50.---)
Date: March 04, 2013 06:30AM

I have found that if no programs are in conflict in port 80, you just need to do the following : In the web server icon in the system tray, (which is orange by the way!), left click, go to Apache -> Service -> Install Service and Enter in the MS-Dos dialog box....That's it!! It turned green and...I think you cant wait for anything more...so try it!!

Options: ReplyQuote
Re: wamp server does not turn GREEN
Posted by: barnabas.gunaraj (101.62.50.---)
Date: March 04, 2013 06:30AM

I have found that if no programs are in conflict in port 80, you just need to do the following : In the web server icon in the system tray, (which is orange by the way!), left click, go to Apache -> Service -> Install Service and Enter in the MS-Dos dialog box....That's it!! It turned green and...I think you cant wait for anything more...so try it!!

Options: ReplyQuote
Re: wamp server does not turn GREEN
Posted by: harman (117.203.138.---)
Date: June 25, 2014 04:48PM

hii
thanks
i am sucessfully installed my wamp server and its logo is hopefully get green with help of ur reviews but it can't access my php codes or file
more over it did't contain already exist file in phpmyadmin i.e. index.PHP

help me

Options: ReplyQuote
Re: wamp server does not turn GREEN
Posted by: SmileyOh (---.54.73.7.pldt.net)
Date: July 31, 2014 09:38AM

It still doesn't turn green. What are the other possible solutions?
I've already deleted all the other my.ini, I also ensured that only Apache is running on port 80.
Please help. Thanks in advance!

Options: ReplyQuote
Re: wamp server does not turn GREEN
Posted by: RiggsFolly (---.dynamic.dsl.as9105.com)
Date: July 31, 2014 11:15AM

Hi Smiley,

Can you answer these basic questions so we know a little about what you have installed please [forum.wampserver.com]

Also What colour is your wampmanager icon?


Are you sure its Apache that is not starting?


How to tell which service is not running if the wampmanager icon is orange.

Left click the wampmanager icon to reveal the menu-> Apache -> Service
If the Start/Resume service menu is Green then Apache IS NOT running.

Left click the wampmanager icon to reveal the menu-> MySQL -> Service
If the Start/Resume service menu is Green then MySQL IS NOT running.

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.1.3 32bit & 64bit)
<Apache 2.4.29/2.2.31> <PHP 7.2/7.1/7.0/5.6/5.5/5.4> <MySQL 5.7.19/5.6.39/5.5.28>
<MariaDB 10.2.14> <phpMyAdmin4.8.1> <MySQL Workbench 6.3.10>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-

Options: ReplyQuote
Re: wamp server does not turn GREEN
Posted by: lishacg@yahoo.in (---.live.vodafone.in)
Date: August 13, 2014 06:10AM

Windows 7 Pro 32bit running Wampserver 2.5 32bits
<Apache Versions 2.4.9/2.2.26> <PHP 5.5.12 <MySQL 5.6.17>
mysql service started and indication red color
appache sevice not started indicating green
test port 80 displays the following message your port 80 is not actually used
icon in the system tray, (which is orange by the way!), left click, go to Apache -> Service -> Install Service and Enter in the MS-Dos dialog box....nothing happend after enter key pressed dos command window also closed nothing happend it stil remains orange

Options: ReplyQuote
Re: wamp server does not turn GREEN
Posted by: RiggsFolly (---.dynamic.dsl.as9105.com)
Date: August 13, 2014 11:50AM

lishacg,

If Apache is not starting can you look at the apache error log, if that shows nothing also look at the Windows Event Viewer for messages from Apache. Apache writes its log to Event Viewer if it fails before it can open its own log file.


I see you have 2 versions of Apache installed into WAMPServer.

Apache 2.2.6 will not run with PHP 5.5.12, is this what you are trying to do?

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.1.3 32bit & 64bit)
<Apache 2.4.29/2.2.31> <PHP 7.2/7.1/7.0/5.6/5.5/5.4> <MySQL 5.7.19/5.6.39/5.5.28>
<MariaDB 10.2.14> <phpMyAdmin4.8.1> <MySQL Workbench 6.3.10>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-

Options: ReplyQuote
Re: wamp server does not turn GREEN
Posted by: IvanBlack (74.115.214.---)
Date: August 13, 2014 12:51PM

WHY??????

Options: ReplyQuote
Re: wamp server does not turn GREEN
Posted by: RiggsFolly (---.dynamic.dsl.as9105.com)
Date: August 13, 2014 01:34PM

Inav,

I assume you mean WHY????? does Apache 2.2.6 not run PHP5.5.12 !!!!


Well to put it simply there is no PHP imterpreter delivered in PHP5.5.12 that will run with Apache 2.2.
They only deliver this interpreter 'php5apache2_4.dll' and there is no 'php5apache2_2.dll' equivalent supplied.

In fact no PHP5.5 version will run with Apache2.2 they all require Apache2.4

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.1.3 32bit & 64bit)
<Apache 2.4.29/2.2.31> <PHP 7.2/7.1/7.0/5.6/5.5/5.4> <MySQL 5.7.19/5.6.39/5.5.28>
<MariaDB 10.2.14> <phpMyAdmin4.8.1> <MySQL Workbench 6.3.10>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-

Options: ReplyQuote
Re: wamp server does not turn GREEN
Posted by: lishacg@yahoo.in (---.live.vodafone.in)
Date: August 14, 2014 12:23PM

Windows 7 Pro 32bit running Wampserver 2.5 32bits
<Apache Versions 2.4.9/ <PHP 5.5.12 <MySQL 5.6.17>
mysql service started and indication red color
appache sevice not started indicating green
test port 80 displays the following message your port 80 is not actually used
icon in the system tray, (which is orange by the way!), left click, go to Apache -> Service -> Install Service and Enter in the MS-Dos dialog box.
your port 80 is available press enter to continue
...nothing happend after enter key pressed dos command window also closed it stil remains orange
Administrative tools ->evet viewer log displays
The Apache service named reported the following error:
>>> Invalid command 'This', perhaps misspelled or defined by a module not included in the server configuration .
The Apache service named reported the following error:
>>> AH00526: Syntax error on line 1 of C:/wamp/alias/snapshot.txt: .

Options: ReplyQuote
Re: wamp server does not turn GREEN
Posted by: RiggsFolly (---.dynamic.dsl.as9105.com)
Date: August 14, 2014 01:08PM

Posting the same question 3 times does not make the answer any different.

If you wont read the answer and act apon it, we will just ignore any future posts on this subject.



This mesage
AH00526: Syntax error on line 1 of C:/wamp/alias/snapshot.txt: .

makes the problem ABSOLUTELY OBVIOUS


Whatever you have placed into the file C:/wamp/alias/snapshot.txt contains an error on line 1


How to prove this is the problem

If you remove that file from the c\wamp\alias folder and restart all services ... does the wamp icon turn GREEN?

If the answer is YES then there is an error in the contents of that file.


If you cannot see the error yourself post the contents of that file here and we will have a look at it

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.1.3 32bit & 64bit)
<Apache 2.4.29/2.2.31> <PHP 7.2/7.1/7.0/5.6/5.5/5.4> <MySQL 5.7.19/5.6.39/5.5.28>
<MariaDB 10.2.14> <phpMyAdmin4.8.1> <MySQL Workbench 6.3.10>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-

Options: ReplyQuote
Re: wamp server does not turn GREEN
Posted by: lishacg@yahoo.in (---.live.vodafone.in)
Date: August 14, 2014 05:53PM

hi ,
thank you finally wampsever turned green after removing snapshot.txt from c:\wamp\alias\snapshot.txt
the content of snpshot.txt
This snapshot was automatically generated on Wed, 23 Jul 2014 22:23:53 +0000 Version: 5.5.15 Branch: HEAD Build: C:\php-sdk\php55\vc11\x86\obj\Release
Built-in Extensions


===========================
Core
bcmath
calendar
ctype
date
ereg
filter
ftp
hash
iconv
json
mcrypt
SPL
odbc
pcre
Reflection
session
standard
mysqlnd
tokenizer
zip
zlib
libxml
dom
PDO
Phar
SimpleXML
wddx
xml
xmlreader
xmlwriter
mhash


Dependency information:
Module: php-cgi.exe
===========================
msvcr110.dll

Module: php.exe
===========================
msvcr110.dll

Module: php-win.exe
===========================
msvcr110.dll

Module: php_bz2.dll
===========================
msvcr110.dll

Module: php_com_dotnet.dll
===========================
msvcr110.dll

Module: php_curl.dll
===========================
libeay32.dll
ssleay32.dll
normaliz.dll
msvcr110.dll

Module: php_enchant.dll
===========================
libenchant.dll
msvcr110.dll

Module: php_fileinfo.dll
===========================
msvcr110.dll

Module: php_gd2.dll
===========================
msvcr110.dll

Module: php_gettext.dll
===========================
msvcr110.dll

Module: php_gmp.dll
===========================
msvcr110.dll

Module: php_imap.dll
===========================
msvcr110.dll

Module: php_interbase.dll
===========================
msvcr110.dll

Module: php_intl.dll
===========================
icuuc51.dll
icuin51.dll
icuio51.dll
msvcr110.dll
msvcp110.dll

Module: php_ldap.dll
===========================
libsasl.dll
msvcr110.dll
ssleay32.dll
libeay32.dll

Module: php_mbstring.dll
===========================
msvcr110.dll

Module: php_oci8.dll
===========================
msvcr110.dll

Module: php_oci8_11g.dll
===========================
msvcr110.dll

Module: php_opcache.dll
===========================
msvcr110.dll

Module: php_openssl.dll
===========================
ssleay32.dll
libeay32.dll
msvcr110.dll

Module: php_pgsql.dll
===========================
libpq.dll
msvcr110.dll

Module: php_shmop.dll
===========================
msvcr110.dll

Module: php_snmp.dll
===========================
libeay32.dll
msvcr110.dll

Module: php_sockets.dll
===========================
iphlpapi.dll
msvcr110.dll

Module: php_sqlite3.dll
===========================
msvcr110.dll

Module: php_sybase_ct.dll
===========================
libsybcs.dll
libsybct.dll
msvcr110.dll

Module: php_tidy.dll
===========================
msvcr110.dll

Module: php_exif.dll
===========================
msvcr110.dll

Module: php_mysql.dll
===========================
msvcr110.dll

Module: php_mysqli.dll
===========================
msvcr110.dll

Module: php_pdo_firebird.dll
===========================
msvcr110.dll

Module: php_pdo_mysql.dll
===========================
msvcr110.dll

Module: php_pdo_oci.dll
===========================
msvcr110.dll

Module: php_pdo_odbc.dll
===========================
msvcr110.dll

Module: php_pdo_pgsql.dll
===========================
libpq.dll
msvcr110.dll

Module: php_pdo_sqlite.dll
===========================
msvcr110.dll

Module: php_soap.dll
===========================
msvcr110.dll

Module: php_xmlrpc.dll
===========================
msvcr110.dll

Module: php_xsl.dll
===========================
msvcr110.dll

Options: ReplyQuote
Pages: 1234Next
Current Page: 1 of 4


Sorry, only registered users may post in this forum.