PhpMyadmin does not open
Posted by: Newestbie (
Date: July 30, 2012 08:45AM

Im new all these things. I decided to learn php and mysql I have html and JS knowledge. I heard wamp as a test tool. I installed Wamp 2.2 x64 with php5.4.3+mysql5.5.24 package. it is installed under C:\wamp folder. My OS is Windows7 64bit

I onlined wamp. its green. looks like php server working. I wrote my first "hello world" example, some simple beginner examples. they are working I can reach [localhost] from computer where wamp installed and also also another computer on network.

but I cant Open PhpMyAdmin. I can open local host, it show server configuration but when I click phpMyadmin it gives

The website declined to show this webpage
HTTP 403
Most likely causes:
•This website requires you to log in.

This error (HTTP 403 Forbidden) means that Internet Explorer was able to connect to the website, but it does not have permission to view the webpage.

Webgrinds is not working either. I receive same meassage when I click webgrind.

I dont know what user it wants me log in. My computer has single user and it has admin rights. other than I dont know how can I create user for wamp.

Options: ReplyQuote
Re: PhpMyadmin does not open
Posted by: RiggsFolly (
Date: July 30, 2012 11:26AM

If the wamp manager icon is Green you are most of the way there.

1. The online/offline function
Offline = your websites are accessible only from one ip address ( i.e. localhost )
Online = your websites are accessible from ANY ip address ( i.e. the world but this should mean only your internal network unless you port forward port 80 in your router)

2. Trying to access your sites from your internal network will work when you have Onlined wamp, but for security reasons phpMyAdmin has extra security applied. After all you dont want just anybody playing with your databases Do You!

If you want to maintain your databases from another IP address in your internal network you have to make a change to the following file.


Which by default looks like this
<Directory "D:/wamp/apps/phpmyadmin3.3.9/">
Options Indexes FollowSymLinks MultiViews
AllowOverride all
Order Deny,Allow
Deny from all
Allow from

NOTE the "Allow from"

You can add another Allow line to allow access from a specific ip address on your network


Or drop the last dot and number and allow access from anywhere on your internal network like this

Allow 192.168.2

There is one of these files for each of the tools you mention!!!

BIG NOTE: Check what your internal networks subnet is by running >ipconfig from a command window and looking for the line
Default Gateway . . . . . . . . . :
Thats actually the ip address of your router but it gives you the first 3 numbers.
Look at the line
IPv4 Address. . . . . . . . . . . :
for the ip address of the PC you just ran ipconfig on.

3. WAIT. Thats not quite everything.

MySQL userids:
a. MySQL comes out of the box with a userid of 'root', this userid by default has no password.

However a mysql userid is associated with an ip address and the root userid is only allowed "out of the box" to login from 3 locations
2. ::1
3. localhost
which of course are all in fact the PC that wamp is installed on ( localhost ). Again for security reasons.

So if you want to allow yourself to administer MySQL from your other PC you will have to run phpMyAdmin on the wamp PC and create a new root user that is allowed access from your other PC's ipaddress.
To do this look for the "Privileges" tab in phpMyAdmin and create your new root user allowed from for example.

Beware if your PCs are getting there ip address's from the routers DHCP server they may not always have the same ip address. Look to make your PC's have Static Ip address.

Options: ReplyQuote

Sorry, only registered users may post in this forum.