unable to load dynamic library '.../ext/ php_intl.dll' - module could not be found !!!???
Posted by: Don_X (---.135-160-184.mc.videotron.ca)
Date: January 21, 2012 03:09PM

Hello,
At startup, I keep getting the following msg : unable to load dynamic library,'..../php_intl.dll,

followed by : - the specified module could not be found !

While the module is there

I am using WAMPServer 2.2 with PHP 5.3.8 and Apache 2.2.21

After searching the web, I have tried many suggestions

in my php.ini file, I have done what was suggested, by adding the extension=php_intl.dll

and i still get the same msg at startup !

please help !

Options: ReplyQuote
Re: unable to load dynamic library '.../ext/ php_intl.dll' - module could not be found !!!???
Posted by: showstopper (186.44.209.---)
Date: January 22, 2012 11:53PM

Befor u can just add extension=php_intl.dll i believe u need to set the extension directory in the php.ini or u can use extension=c:/wamp/path/to/php extension dir/php_intl.dll

Fitcom - Technology and SEO with a side of awesome

Installing and Configuring a WAMP Server in Windows 7 & 8

Options: ReplyQuote
Re: unable to load dynamic library '.../ext/ php_intl.dll' - module could not be found !!!???
Posted by: Don_X (---.135-160-184.mc.videotron.ca)
Date: January 24, 2012 05:00AM

Thank you for the reply ...

But .. I assure you that the extension_dir is set properly in the php.ini like this :

extension_dir = "c:/wamp/bin/php/php5.3.8/ext/"

and php_intl.dll is there, in the ext directory, the one that comes by

default with the WAMPServer 2.2a x32 package

while all the proper icu**46.dll files are accounted for in the C:\wamp\bin\php\php5.3.8\ directory

I really don't know what is going on ... i did not have this problem with my previous wampserver installation ...until I uninstalled it and installed that new one ( 2.2a) ... and this is the problem that I am having
it keeps telling me that the the specified module could not be found.... I have never had this problem before..... this is happening with the 2.2a version

do you have any other suggestions ???? ...

Can anyone one please help or assist ... this is really annoying !

thank you

Options: ReplyQuote
Re: unable to load dynamic library '.../ext/ php_intl.dll' - module could not be found !!!???
Posted by: Reliance (---.red.bezeqint.net)
Date: March 13, 2012 08:04PM

I am having this problem with php5.3.10 from Wampserver 2.2d. Same checks for the extension path, same error message. No clue. I think I'll try a different version of PHP and see what happens.

Options: ReplyQuote
Re: unable to load dynamic library '.../ext/ php_intl.dll' - module could not be found !!!???
Posted by: barobba (---.bhfc.net)
Date: March 13, 2012 08:16PM

I'm having the same problem with WAMP Server from the normal installation.

Options: ReplyQuote
Re: unable to load dynamic library '.../ext/ php_intl.dll' - module could not be found !!!???
Posted by: Reliance (---.red.bezeqint.net)
Date: March 13, 2012 08:20PM

The (apparent) result of not having php_intl is failure of "locale_set_default" and of "Locale::setDefault ". Class Locale is unknown to PHP. I am aware that php_intl is supposed to be built in to php 5.3, and the DLL is on the disk. But it does not load at start-up.

I am working on multilingual web sites, and Locale will be very important. Any work-around will be greatly appreciated.

Options: ReplyQuote
Re: unable to load dynamic library '.../ext/ php_intl.dll' - module could not be found !!!???
Posted by: barobba (---.bhfc.net)
Date: March 13, 2012 09:17PM

Ok, I got it to work. It looks like Apache can't find the icu*.dll files (in the php directory).

So, one solution is to add "C:\wamp\bin\php\php5.3.9" (or similar directory) to your system PATH.

The other solution is to copy the icu*.dll files to your apache's bin directory.

A third option is to copy the icu*.dll files to your Windows system directory (system32 or SysWOW64).

Options: ReplyQuote
Re: unable to load dynamic library '.../ext/ php_intl.dll' - module could not be found !!!???
Posted by: Reliance (---.red.bezeqint.net)
Date: March 14, 2012 12:48PM

Thank you barobba, copying the dll files to the Apache bin allowed the php_intl.dll to load. Now, however, setting the Locale seems to make no difference. I'm probably making the call wrong, though.

Options: ReplyQuote
Re: unable to load dynamic library '.../ext/ php_intl.dll' - module could not be found !!!???
Posted by: Pri (117.224.181.---)
Date: September 11, 2012 11:18AM

i am a beginner in moodle..n i am having the same problem..barobba or reliance could you please tell me which dll files i need to copy to the Apache bin..please reply asap

Options: ReplyQuote
Re: unable to load dynamic library '.../ext/ php_intl.dll' - module could not be found !!!???
Posted by: Eric_from_montreal (207.162.28.---)
Date: January 30, 2013 10:14PM

Lost some time with that problem too. The loading of intl extension seemed to be fine after copying the ICU files in Apche bin but it was not working at runtime when trying to run a collated sort by exemple (there as an error when trying to create the collator object).


Things where working fine using a fresh install of wamp (not exactly the same version) but I was not able to get my dev installation to work.

I was able to get things working by downloading the ICU files (icu4c-4_6-Win64- in this case) and copying them instead of those in the php folder. Maybe it was just a corrupted file.

ps: If you try to manage a second installation of wamp on windows (what I have attempted firstly to be able to do a diff on installed files and see if this would give me more information), there will be a conflict where wampmanager always seem to start the latest installation. You need to remove mysql and apache service using the wampmanager menus and reinstall them before restarting the services if you want to revert back to your previous wamp installation. It's obvious for me now but it's not well documented (I was looking in environnement var, registry, etc.). I guess that wampmanager should probably check if the registered service are in the same path that itself and send a warning if it's not the case to help resolve the issue.



Edited 2 time(s). Last edit at 01/30/2013 10:22PM by Eric_from_montreal.

Options: ReplyQuote
Re: unable to load dynamic library '.../ext/ php_intl.dll' - module could not be found !!!???
Posted by: pierrix25 (---.fbx.proxad.net)
Date: March 07, 2013 05:53PM

I' had the same problem which appeared after i reinstalled wampserver on my D disk because of insufficient place on my C disk.

I 'had desinstalled wamp before but maybe the process was wrong. It has a bad path with c:\wamp\bin\php\php5.3.10\ext.

So i changed it by D:\ .... and restart my computer and it's ok now !

Options: ReplyQuote
Re: unable to load dynamic library '.../ext/ php_intl.dll' - module could not be found !!!???
Posted by: Herbalite (---.dynamic.hinet.net)
Date: August 01, 2013 12:08PM

I got this problem in an unexpected way.

I've replaced the timezones tables provided by the inital install with those from mysql (as they are complete).

And only after that I got the warning.

So far I haven't found a fix for this issue.

Options: ReplyQuote
Re: unable to load dynamic library '.../ext/ php_intl.dll' - module could not be found !!!???
Posted by: Slayer (---.user.veloxzone.com.br)
Date: November 25, 2013 07:19PM

I uninstalled the wampserver and reinstalled with the same version and now I got this error only with library php_intl.dll

My config:
Windows Server x86
Wampserver 2.4

Options: ReplyQuote
Re: unable to load dynamic library '.../ext/ php_intl.dll' - module could not be found !!!???
Posted by: RiggsFolly (---.as13285.net)
Date: November 26, 2013 12:37AM

Look into the c:\wamp\bin\php\php5.4.16
Copy all the ICU*.DLL files from there into the C:\wamp\bin\apache\apache2.4.4\bin

These dlls are required to load the intl dll and should be in the Apache bin folder so they are found at runtime.


A more complete fix would be to change C:\wamp\scripts\config.inc.php as follow:

Find this section of that file

$phpDllToCopy = array (
'fdftk.dll',
'fribidi.dll',
'libeay32.dll',
'libmhash.dll',
'libmysql.dll',
'msql.dll',
'libmysqli.dll',
'ntwdblib.dll',
'php5activescript.dll',
'php5isapi.dll',
'php5nsapi.dll',
'ssleay32.dll',
'yaz.dll',
'libmcrypt.dll',
'php5ts.dll',
'php4ts.dll');

And change it to

$phpDllToCopy = array (
'fdftk.dll',
'fribidi.dll',
'icudt51.dll', // - Additions to avoid unknown error PHP 5.5.5
'icuin51.dll',
'icuio51.dll',
'icule51.dll',
'iculx51.dll',
'icutest51.dll',
'icutu51.dll',
'icuuc51.dll',
'icudt50.dll', // - Additions to avoid unknown error PHP 5.5
'icuin50.dll',
'icuio50.dll',
'icule50.dll',
'iculx50.dll',
'icutest50.dll',
'icutu50.dll',
'icuuc50.dll',
'icudt49.dll', // - Additions to avoid unknown error PHP 5.3/5.4
'icuin49.dll',
'icuio49.dll',
'icule49.dll',
'iculx49.dll',
'icutest49.dll',
'icutu49.dll',
'icuuc49.dll',
'libeay32.dll',
'libmhash.dll',
'libmysql.dll',
'libsasl.dll', // - Additions to avoid unknown error
'msql.dll',
'libmysqli.dll',
'ntwdblib.dll',
'php5activescript.dll',
'php5isapi.dll',
'php5nsapi.dll',
'ssleay32.dll',
'yaz.dll',
'libmcrypt.dll',
'php5ts.dll',
'php4ts.dll',
);

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.2.0 32bit & 64bit)
<Apache versions MULTIPE> <PHP versions MULTIPLE> <MySQL Versions MULTIPLE>
<MariaDB versions MULTIPLE> <phpMyAdmin versions MULTIPLE> <MySQL Workbench 8.0.16>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-



Edited 1 time(s). Last edit at 11/26/2013 12:45AM by RiggsFolly.

Options: ReplyQuote
Re: unable to load dynamic library '.../ext/ php_intl.dll' - module could not be found !!!???
Posted by: Slayer (---.user.veloxzone.com.br)
Date: November 26, 2013 10:21PM

I changed the C:\wamp\scripts\config.inc.php and restarted the wampserver, but still with error.

Copy all ICU dlls and fixed the error.


Thx!

Options: ReplyQuote
Re: unable to load dynamic library '.../ext/ php_intl.dll' - module could not be found !!!???
Posted by: RiggsFolly (---.as13285.net)
Date: November 27, 2013 10:57AM

Good,

The change to C:\wamp\scripts\config.inc.php will just ensure that when/if you install another version of Apache and or PHP that the files will get copies as part of the switching process within WAMPServer

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.2.0 32bit & 64bit)
<Apache versions MULTIPE> <PHP versions MULTIPLE> <MySQL Versions MULTIPLE>
<MariaDB versions MULTIPLE> <phpMyAdmin versions MULTIPLE> <MySQL Workbench 8.0.16>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-

Options: ReplyQuote


Sorry, only registered users may post in this forum.