"It works!" Is all i get... sad smiley
Posted by: Anifacted (---.k704.webspeed.dk)
Date: May 13, 2011 02:21PM


I resently installed WAMP on my laptop with no problems at all, and thought that now, when I had to put it on my desktop PC, it would be a painless matter.
I was wrong though, cause I am stuck with this problem and I have no clue what is causing it.

The problem is that after the succesful installation, whenever I access localhost in my browser, I am displayed the message:

"It works! - This is the default web page for this server. - The web server software is running but no
content has been added, yet."

I have removed everything in c:/wamp/www, added and changed index.php files, but the message even keeps showing regardless of the presence of the c:/wamp/www dirictory or not.
I installed WAMP on a freshly created Windows user account, and I have no other virtual servers previously or currently installed.

The only thing conflicting with WAMP after the installation was TeamViewer, which was occupying port 80, but I disabled that, and the server would start.

What could be causing this message to overule localhost directory access?

Thank you,

Options: ReplyQuote
Re: "It works!" Is all i get... sad smiley
Posted by: yfastud (Moderator)
Date: May 13, 2011 04:37PM

You have to disable IIS

Make sure no other program conflict Wamp such as IIS, SQL, Skype, Zonealarm, firewall/antivirus, NOD32, Eset, any web related program including Remote Desktop, Teamviewer ...

IIS and Apache/Wamp are both web server and might conflict in some way, so you have to disable IIS in order for Wamp to work

Disable IIS in Vista/W7:

Control Panel, Uninstall Programs, Turn Widows Features On or Off, uncheck Internet Information Services

Disable IIS in XP:

Control Panel, Add/Remove Programs, Add/Remove Windows Components, uncheck Internet Information Services (IIS)

Restart computer, then restart Wamp

Also, in folder C:\WINDOWS\System32\drivers\etc, open file hosts and delete anything in this file and have only this line below and nothing else localhost

If using Skype, open Skype > Tools > Options > Advanced > Connection then uncheck "use port 80..." restart Wamp then Skype

Have fun,

FREE One A Day
FREE Photo
FREE Games
FREE Websites
FREE Portable GPS

Options: ReplyQuote
Re: "It works!" Is all i get... sad smiley
Posted by: Anifacted (---.k704.webspeed.dk)
Date: May 13, 2011 05:07PM

My IIS was already disabled.

It seems my hosts file was messed up, since clearing it and only having the line " localhost" Solved the problem.

Thank you very much for your quick and helpful reply! :-)

Edited 1 time(s). Last edit at 05/13/2011 05:09PM by Anifacted.

Options: ReplyQuote

Sorry, only registered users may post in this forum.